Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] cryptsetup Problem - diesmal ein Neues ;)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
rogge
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2006
Posts: 92
Location: Erfurt

PostPosted: Sat Jan 25, 2014 7:27 pm    Post subject: [gelöst] cryptsetup Problem - diesmal ein Neues ;) Reply with quote

Hallo zusammen,

nachdem meine neu Festplatte nach nur einem Monat die Hufe gestreckt hat
und ich endlich mein neue habe, geht es mal wieder ans einrichten - und
scheitere grade an cryptsetup.
Ich versuche die neue HDD via
Code:
 cryptsetup luksFormat /dev/sdb1 -s 256 -c aes-cbc-essiv:sha512 -y -i 5000 -h sha512

zu verschlüsseln und bekomme nach der Passworteingabe folgende Fehlermeldung:
Code:
Kann den Kopfbereich auf Gerät /dev/sdb1 nicht auslöschen.

Wenn ich versuche das Kommando auf /dev/sdb anzuwenden, kommt auch nur Murks dabei raus:
Code:
device-mapper: reload ioctl on  failed: Das Argument ist ungültig
Öffnen des temporären Schlüsselspeichergeräts fehlgeschlagen.
device-mapper: remove ioctl on temporary-cryptsetup-3536 failed: Kein passendes Gerät bzw. keine passende Adresse gefunden
device-mapper: reload ioctl on temporary-cryptsetup-3536 failed: Kein passendes Gerät bzw. keine passende Adresse gefunden
device-mapper: remove ioctl on temporary-cryptsetup-3536 failed: Kein passendes Gerät bzw. keine passende Adresse gefunden
device-mapper: remove ioctl on temporary-cryptsetup-3536 failed: Kein passendes Gerät bzw. keine passende Adresse gefunden
device-mapper: remove ioctl on temporary-cryptsetup-3536 failed: Kein passendes Gerät bzw. keine passende Adresse gefunden
device-mapper: remove ioctl on temporary-cryptsetup-3536 failed: Kein passendes Gerät bzw. keine passende Adresse gefunden


Ich konnte leider den Header auf der "alten" Platte nicht mehr auslesen um zu sehen wie die verschlüsselt war.

Hat jemand eine Idee? Google schweigt sich zu der ersten Fehlermeldung aus :(

Grüße, rogge


Last edited by rogge on Sat Jan 25, 2014 9:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
rogge
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2006
Posts: 92
Location: Erfurt

PostPosted: Sat Jan 25, 2014 9:26 pm    Post subject: Reply with quote

Hat sich erledigt. Das Problem lag daran, dass ESSIV in Verbindung mit sha512 (...-essiv:sha512) nicht läuft, das aber wohl standardmäßig verwendet.
Eine explizite Angabe von :sha256 funktioniert.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Jan 25, 2014 9:33 pm    Post subject: Reply with quote

ich weiß ja nicht, was für einen Kernel und cryptsetup-Version du einsetzt aber verschlüssle doch die Partition lieber mit

(64bit System & CPU ?)

aes-xts-benbi:sha512

sicherer ist es und wenn ich mich an die Leistungsbenchmarks richtig erinnere auch schneller
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
rogge
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2006
Posts: 92
Location: Erfurt

PostPosted: Fri Jan 31, 2014 10:38 am    Post subject: Reply with quote

benbi hatte ich überhaupt nicht auf dem Schirm. Danke für den Tipp.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Feb 02, 2014 8:43 pm    Post subject: Reply with quote

rogge wrote:
benbi hatte ich überhaupt nicht auf dem Schirm. Danke für den Tipp.


Gerne :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum