Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge dev-libs/eet scheitert...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1163
Location: Eppingen, Germany

PostPosted: Mon Jan 27, 2014 8:49 pm    Post subject: emerge dev-libs/eet scheitert... Reply with quote

Das ist der Fehler:

Code:
checking for libjpeg... yes
checking for zlib... yes
checking for EET... no
configure: error: Package requirements (eina >= 1.7.10 openssl  zlib) were not met:
Requested 'eina >= 1.7.10' but version of Eina is 1.7.9


Das ist vorhanden:
Code:
eix eina
[D] dev-libs/eina
     Available versions:  (~)1.7.9 [M](**)9999 {altivec debug default-mempool doc mempool-buddy +mempool-chained-pool mempool-fixed-bitmap +mempool-one-big mempool-pass-through mmx nls sse sse2 static-libs test valgrind}
     Installed versions:  9999(22:07:47 15.12.2013)(mempool-chained-pool mempool-one-big mmx nls sse sse2 -altivec -debug -default-mempool -doc -mempool-buddy -mempool-fixed-bitmap -mempool-pass-through -static-libs -test -valgrind)
     Homepage:            http://www.enlightenment.org/
     Description:         Enlightenment's data types library (list, hash, etc) in C


Das zeigt er auch:

Code:
Requested 'eina >= 1.7.10' but version of Eina is 1.7.9
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables EET_CFLAGS
and EET_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Eine Version 1.7.10 scheint es nicht zu geben...? Das enlightenment-Overlay habe ich, eine neuere Version als 1.7.9 bekomme ich aber auch dort nicht.... Was bedueten die USE_Flags openssl und zlib in der ersten Fehlermeldung? Habe ich das Problem wegen dieser USE-Flags? die sind aber für eina nicht gesetzt...??

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Falmer
n00b
n00b


Joined: 22 Mar 2006
Posts: 51
Location: im grünen Herzen Deutschlands ;-)

PostPosted: Sat Feb 01, 2014 7:39 pm    Post subject: Reply with quote

Hallo uhai,

seit einiger Zeit ist für enlightenment kein overlay mehr nötig.
Alle benötigten libraries und Programme sind im offiziellen portage.

Schade ist, daß es keine neueren Versionen gibt - e hängt seit längerem bei Version 0.17.6.

Ich selbst benutze wegen der langsamen Plege im portage die Version von git.enlightenment.org und habe bisher recht gute Erfahrungen damit gemacht.

Die USE-flags in der Fehlermeldung bedeuten, daß nach eina gesucht wird, das mit diesen flags kompiliert sein muss. Das eigentliche Problem ist aber die Version, die zu niedrig ist.

Gruß
Falmer
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1163
Location: Eppingen, Germany

PostPosted: Mon Feb 03, 2014 5:44 am    Post subject: Reply with quote

Hallo Falmer,

hast Du das git.enlightenment über portage eingebunden?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Falmer
n00b
n00b


Joined: 22 Mar 2006
Posts: 51
Location: im grünen Herzen Deutschlands ;-)

PostPosted: Mon Feb 03, 2014 7:34 am    Post subject: Reply with quote

Moin uhai,

nee, das geht wohl eher nicht.
Ich lade mir die Sachen aus dem core-git so ca. alle 2 - 3 Tage herunter und übersetze es neu. Das landet dann unter /usr/local.
So weiß der Rest des Systems aber auch nicht, daß e mit den Bibliotheken installiert ist. Das ist manchmal etwas dumm.

Eine andere Möglichkeit wäre ein download der Quellen von http://www.enlightenment.org/p.php?p=download&l=en.
Das geht meines Wissens aber auch nicht in portage einzubinden. (Es sei denn Du baust Dir Dein eigenes overlay.)

Gruß
Falmer
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum