Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Schriftproblem: Zu enger Zeilenabstand
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sun Jan 26, 2014 11:23 am    Post subject: [Solved] Schriftproblem: Zu enger Zeilenabstand Reply with quote

Hallo,

hier ein Link zu einem Bild mit meinem Problem. Die Seite ist Watchever.de -> So funktioniert es und dann unten.
http://www.pic-upload.de/view-22069867/schrift.jpg.html

Ich habe das schon seit einiger Zeit.
Kennt das Problem jemand?

System: Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.17, 3.6.9 x86_64)
Stable

Vielen Dank
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke


Last edited by Finswimmer on Mon Jan 27, 2014 12:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sun Jan 26, 2014 11:44 am    Post subject: Reply with quote

Die zwei wichtigsten Infos fehlen:
Welcher Browser - welche Fonts ;)
Bei mir sieht das "ganz normal" aus. google-chrome-unstable + "Ahem 16"
Und firefox-bin-26.0 + "Serif 16" (wobei ich mich grad wunder, dass eselect fontconfig list keine Settings mehr mit "serif" anzeigt, nur "sans serif" - sollte aber Dejavu oder Bitstream sein) schaut auch i.O. aus.

Also entweder ist es ein Rendering-Problem deines Browsers oder fehlerhafte Metrics deines Fonts.
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Sun Jan 26, 2014 12:52 pm    Post subject: Reply with quote

Und wenn die Frage des OP abschließend beantwortet wurde, dann kann mir nochmal jemand erklären, ob man unter Linux irgendeine Chance auf ein 'silverlight'-Plugin hat! :)
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Sun Jan 26, 2014 1:13 pm    Post subject: Reply with quote

Hi cryptosteve,

ich antworte mal nach dem LIFO Prinzip weil ich zur Frage des OP nichts sagen kann.

Hab zwar keiner praktischen Erfahrungen und auch keine Verwendung für Silverlight, aber vielleicht hift Dir ja der Artikel den ich kürzlich gelesen hatte:
http://www.heise.de/open/meldung/Linux-Pipelight-0-2-4-unterstuetzt-noch-mehr-DRM-Komponenten-2090214.html

und siehe da, ein Overlay wär auch schon verfügbar. :wink:

http://gpo.zugaina.org/www-plugins/pipelight

Hoffe damit kommst Du zum Ziel.

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sun Jan 26, 2014 4:34 pm    Post subject: Reply with quote

Pipelight ist super.
Habe es mit Watchever 30 Tage getestet und es klappt sehr gut.
Die CPU ist aber stark am schwitzen... ;)

So:
Das ganze bezieht sich auch auf den Thunderbird, der Screenshot ist aus dem Firefox-26.0

eselect fontconfig list|grep "*" gibt:
[3] 10-scale-bitmap-fonts.conf *
[15] 20-unhint-small-vera.conf *
[17] 30-metric-aliases.conf *
[18] 30-urw-aliases.conf *
[19] 40-nonlatin.conf *
[20] 42-luxi-mono.conf *
[21] 45-latin.conf *
[22] 49-sansserif.conf *
[23] 50-user.conf *
[24] 51-local.conf *
[29] 60-latin.conf *
[35] 65-fonts-persian.conf *
[37] 65-nonlatin.conf *
[38] 69-unifont.conf *
[41] 80-delicious.conf *
[42] 90-synthetic.conf *

EDIT: Ich habe mal alle aktiviert und den Firefox neugestartet -> Kein Unterschied
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Sun Jan 26, 2014 5:11 pm    Post subject: Reply with quote

Also bei mir ist das auch normal. Klick dich mal durch die Einstellungen vom Firefox (Inhalt -> Schriftarten -> Erweitert). Da steht bei mir

Westlich
Proportional Serif - Größe 16
Serif: Serif
Sans Serif: sans-serif
Feste Breite: monospace Größe 12.
Minimale Schriftgröße: Keine

[x] Seite des Verwenden von eigenen statt der oben gewählten Schriftarten erlauben.


Tritt das denn bei anderen Browsern auch auf? Oder nur beim Firefox? Manchmal habe ich mit der Szoomeinstellung schon seltsame Ergebnisse auf manchen Webseiten gehabt. Watchever.de eben mal durchgezoomed und keine seltsamen Überschneidungen Festellen können.

Sonst vielleicht wirklich eine seltsame Einstellung der Fonts bei KDE/Gnome?
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sun Jan 26, 2014 5:30 pm    Post subject: Reply with quote

Die Einstellungen sind die gleichen wie bei dir.
Es tritt auch beim Chromium auf.

Beim Firefox und Zoom wird es nicht viel besser.
Bei KDE ist nichts spannendes eingestellt, denke ich...


EDIT: Neuer X-Server als Root gestartet und dort den Firefox getestet --> gleiches Resultat!
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Mon Jan 27, 2014 12:26 pm    Post subject: Reply with quote

Deaktivieren aller Fontconfig Schriften macht sogar KDE hässlich.

Hat denn niemand noch eine Idee?
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Mon Jan 27, 2014 12:37 pm    Post subject: Reply with quote

ich hab keine ahnung von fontconfig, aber bei mir sieht die seite gut aus im firefox. ich poste einfach mal meine fontconfig settings, vielleciht hilfts ja.
Code:
[4]   10-scale-bitmap-fonts.conf *
  [6]   10-sub-pixel-rgb.conf *
  [10]  11-lcdfilter-default.conf *
  [16]  20-unhint-small-vera.conf *
  [21]  30-metric-aliases.conf *
  [22]  30-urw-aliases.conf *
  [25]  40-nonlatin.conf *
  [28]  45-latin.conf *
  [29]  49-sansserif.conf *
  [31]  51-local.conf *
  [33]  57-dejavu-sans.conf *
  [34]  57-dejavu-sans-mono.conf *
  [35]  57-dejavu-serif.conf *
  [36]  60-latin.conf *
  [43]  65-fonts-persian.conf *
  [45]  65-nonlatin.conf *
  [66]  80-delicious.conf *
  [67]  90-synthetic.conf *
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Mon Jan 27, 2014 12:40 pm    Post subject: Reply with quote

Wenn ich im Firefox auf die watchever.de Seite gehe und dort in der CSS "font: inherit;" deaktiviere, dann wird dort "font-family: Helvetica,sans-serif;" wieder aktiv und es sieht gut aus.
Aber warum sieht es dann bei Euch gut aus?

Okaaaaaaaaaaaaaaaaaay.
Ich erinnere mich, dass ich von irgendwo eine "andere/richtigere" Helvetica installiert habe.
Die scheint aber Probleme mit dem Zeilenabstand zu haben.
Ich habe also Helvetica über Font in KDE Systemsteuerung gelöscht und nun sieht es wieder toll aus :)
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum