Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
rEFInd+Win8+Gentoo+EFI+GPT
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Sigma Kappa
n00b
n00b


Joined: 04 Mar 2012
Posts: 45

PostPosted: Wed Jan 29, 2014 12:07 pm    Post subject: rEFInd+Win8+Gentoo+EFI+GPT Reply with quote

Hi,

I have Lenovo B590 laptop with Win8 preinstalled, and using systemRescueCD (well, actually USB) I was able to partition the disk as follows:
Code:

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048         2050047   1000.0 MiB  2700 
   2         2050048         2582527   260.0 MiB   EF00  EFI system partition
   3         2582528         2844671   128.0 MiB   0C01  Microsoft reserved part
   4         2844672       785815551   373.3 GiB   0700  Basic data partition
   5       785815552       786223103   199.0 MiB   0700  Basic data partition
   6       786225152       794613759   4.0 GiB     8300  Linux filesystem
   7       794613760       950065151   74.1 GiB    8300  Linux filesystem
   8       950065152       976773119   12.7 GiB    2700 

Now
Code:
/dev/sda6
and
Code:
/dev/sda7
carry the boot and root partitions of the Gentoo installation. I made sure I followed all the steps in http://wiki.gentoo.org/wiki/UEFI_Dual_boot_with_Windows_7/8, and rEFInd shows the Gentoo allright. In
Code:
/usr/src/linux/.config
I also added the commandline argument passed to th kernel as
Code:
root=PARTUUID=93aca...3be
and put this string in
Code:
/boot/refind_linux.conf
as well. Now rEFInd hangs with
Code:
loading bzImage loading with options root=...
. My question is, should I be thinking of moving to grub2 and following the instructions in http://wiki.gentoo.org/wiki/GRUB2#UEFI.2FGPT? Or can I still make rEFInd work?

Thanks.[/url]
Back to top
View user's profile Send private message
cyberjun
Apprentice
Apprentice


Joined: 06 Nov 2005
Posts: 293

PostPosted: Wed Jan 29, 2014 12:15 pm    Post subject: Reply with quote

Are you using kernel seeds? I remember when I was installing Gentoo on Lenovo G500s, I faced a similar situation with kernel seeds.

--cyberjun
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2541
Location: Near Toronto

PostPosted: Wed Jan 29, 2014 1:44 pm    Post subject: Reply with quote

I have the same problem (same symptoms at least).

I chainload grub2 and can boot gentoo (but it is ugly), so
I think that will work for you

It just seems on my thinkpad t440s refind just won't boot the
kernel directly (I've read that uefi implementations are very
variable and this sort of thing is just the way it is).

but I would love to find a way to boot the kernel directly
via refind if possible
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Wed Jan 29, 2014 4:59 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-966240-highlight-refind+hangs.html is an extended discussion

if disk activity persists you may have the intel video problem - play with the brightness and backlight controls
Using the alternate, gnu-efi, form of refind, at http://sourceforge.net/projects/refind/files/0.7.7/refind-bin-gnuefi-0.7.7.zip/download has been known to work
changing kernel version may help
the latest legacy grub works with gpt disks
a refind flashdrive http://sourceforge.net/projects/refind/files/0.7.7/refind-flashdrive-0.7.7.zip/download
sysresccd has an option to boot first/second system on the hard drive
_________________
Defund the FCC.
Back to top
View user's profile Send private message
cyberjun
Apprentice
Apprentice


Joined: 06 Nov 2005
Posts: 293

PostPosted: Wed Jan 29, 2014 6:18 pm    Post subject: Reply with quote

Hi,
Here is my working .config for direct booting from EFI without grub: http://bpaste.net/show/173534/. I am not sure what did I change to make it work.

--cyberjun
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum