Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hplip-3.14.1 broken for x86? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1392

PostPosted: Thu Jan 30, 2014 5:49 pm    Post subject: hplip-3.14.1 broken for x86? [SOLVED] Reply with quote

I'm using hplip on an x86 machine. In my last update updated from hplip-3.12.10a to hplip-3.14.1.

Today I noticed that scanning was seriously broken, where scanimage segfaults every time. This is documented as a possible issue with binary plugins, but this is Photosmart 5520 which does not use any binary plugins.

When I tried to re-run hp-setup I got this:

Code:
Attempting to setup with hp-setup gets this:

Adding print queue to CUPS:
Device URI: hp:/net/Photosmart_5520_series?ip=192.168.1.50
Queue name: Photosmart_5520
PPD file: drv:///hp/hpcups.drv/hp-photosmart_5520_series.ppd
Location:
Information:
error: Printer queue setup failed. Error : server-error-internal-error


It refused to work. The only way I could resolve this was to downgrade back to hplip-3.12.10a. Worse yet, I see that if I sync now the ebuilds prior to 3.14.1 have been removed...yuk.

Anyone have any ideas on this? It seems to be a pretty significant failure all the way around and I'm not finding anything obvious in terms of any known issues etc.

Tom


Last edited by tld on Fri Jan 31, 2014 3:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
BradN
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2391
Location: Wisconsin (USA)

PostPosted: Fri Jan 31, 2014 7:10 am    Post subject: Reply with quote

I'm not sure I can help regarding the actual problem, but I believe there's a git repository for portage where you should be able to retrieve the old ebuild if you need it.
Back to top
View user's profile Send private message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1392

PostPosted: Fri Jan 31, 2014 3:14 pm    Post subject: Reply with quote

Thanks. Actually that's not an issue because I haven't synced yet, and have already copied the old version to my local overlay.

I just tried re-installing 3.14.1. Interestingly this time when I try to scan it doesn't segfault, but I get scans in greyscale that are almost unreadable. However, I'll bet that has something to do with the fact that I'm using a device configured with the old version...and again, hp-setup breaks for me with the above "server-error-internal-error" with 3.14.1, giving me no way to re-configure the printer.

I tried doing hp-check with 3.14.1. all it complained about was policykit, avahi-utils, and python-notify which are all optional, and the missing lsusb command...however this is a network printer and I use "hp-setup -i <ip>".

Seriously screwed up. My past experience tells me that hp-lip issues turn into total death marches. I just hope I figure out something before some dependency of 3.12.10a gets dropped or something.

Tom
Back to top
View user's profile Send private message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1392

PostPosted: Fri Jan 31, 2014 3:46 pm    Post subject: Reply with quote

Too weird. Here's what I found. I was getting the setup errors above when using this:

Code:
hp-setup -i 192.168.1.50


...which is all command line based. However when I tried this:

Code:
hp-setup 192.168.1.50


...which uses the gui, the setup completed. I mean FFS. The only other strange thing, and maybe someone can clear me up on this one: My scans still looked awful, but I figured out that scanimage is now defaulting to --mode=Lineart rather than --mode=Color for the newly configured device.

Anyone have a clue what that's all about?

Tom
Back to top
View user's profile Send private message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1392

PostPosted: Sun Feb 02, 2014 5:22 pm    Post subject: Reply with quote

Oh for crying out loud...I can't even believe what I just discovered...I went to scan a document for my taxes and AGAIN, scanimage segfaulted on me. I finally figured out that scanimage segfaults with hplip unless DBUS is running!...FFS.

One of the few reasons I even have DBUS installed is that hp-setup requires it, even though it's ONLY supposed to be required for fax support:

https://bugs.launchpad.net/hplip/+bug/1095783

...so I don't even start it unless I'm setting up the printer. They have to be kidding.

Tom
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum