Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Machine with current kernel needs old udev names.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
griffmcc
n00b
n00b


Joined: 18 Oct 2010
Posts: 6

PostPosted: Sun Feb 02, 2014 2:57 am    Post subject: [SOLVED] Machine with current kernel needs old udev names. Reply with quote

I adminster four gentoo machines. Three of them have transitioned to the new udev network adaptor naming conventions, for example, net.enp4s0. However, one of my machines that is running kernel 3.10.25 still requires the old network adaptor name net.eth0.

I have followed the instructions in the eselect news by "Samuli Suominen <ssuominen@gentoo.org>" in his "2013-03-29-udev-upgrade" posting called "Upgrading udev to version >=200," but one of my machines will still only connect to the network if I use the net.eth0 naming convention.

Of course, everything is working fine now, but I worry that it will break later. Does any one know why this machine has not started using the new udev network adaptor names?

Here are the relevant details:

# cat /proc/version
Linux version 3.10.25-gentoo (root@manhattan) (gcc version 4.7.3 (Gentoo 4.7.3-r1 p1.4, pie-0.5.5) ) #1 SMP Fri Jan 31 15:49:55 PST 2014

# equery l udev
* Searching for udev ...
[IP-] [ ] sys-fs/udev-208:0

# equery l udev-init-scripts
* Searching for udev-init-scripts ...
[IP-] [ ] sys-fs/udev-init-scripts-26:0

# ls -l /sys/class/net
total 0
lrwxrwxrwx 1 root root 0 Jan 31 16:33 eth0 -> ../../devices/pci0000:00/0000:00:1c.5/0000:02:00.0/net/eth0
lrwxrwxrwx 1 root root 0 Jan 31 16:33 lo -> ../../devices/virtual/net/lo
lrwxrwxrwx 1 root root 0 Jan 31 16:33 sit0 -> ../../devices/virtual/net/sit0

# equery l grub
* Searching for grub ...
[IP-] [ ] sys-boot/grub-2.00_p5107-r2:2

# emerge --info
Portage 2.2.7 (default/linux/amd64/13.0, gcc-4.7.3, glibc-2.17, 3.10.25-gentoo x86_64)
=================================================================
System uname: Linux-3.10.25-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E7400_@_2.80GHz-with-gentoo-2.2
KiB Mem: 4043944 total, 915892 free
KiB Swap: 530140 total, 530140 free
Timestamp of tree: Sat, 01 Feb 2014 11:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash: 4.2_p45
dev-lang/python: 2.7.5-r3, 3.3.3
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.12.4
sys-apps/sandbox: 2.6-r1
sys-devel/autoconf: 2.69
sys-devel/automake: 1.11.6, 1.13.4
sys-devel/binutils: 2.23.2
sys-devel/gcc: 4.4.7, 4.5.4, 4.7.3-r1
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4.2
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc: 2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://gentoo.mirrors.tds.net/gentoo http://128.61.111.11/pub/gentoo ftp://mirror.datapipe.net/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 mmx modules multilib ncurses nls nptl openmp pam pcre readline session sse sse2 ssl tcpd unicode zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Last edited by griffmcc on Sun Feb 02, 2014 11:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1746

PostPosted: Sun Feb 02, 2014 11:05 am    Post subject: Reply with quote

userspace names might be disdabled with kernel boot options or - more likely - /etc/udev/rules.d/* files.

cat /etc/udev/rules.d/80-net-name-slot.rules~
---/snip/---
# To activate this function, move this file to a name that doesn't end in.rules,
# or remove it then reboot your system.
----/snip/---

# Also, be aware that you can get the attributes of your network interface that
# would be used to name the interface in the new scheme by doing the following
# with this version of udev running:
#
# udevadm test-builtin net_id /sys/class/net/ifname 2> /dev/null
---/snip/---
Back to top
View user's profile Send private message
griffmcc
n00b
n00b


Joined: 18 Oct 2010
Posts: 6

PostPosted: Sun Feb 02, 2014 10:37 pm    Post subject: [SOLVED] Machine with current kernel needs old udev names. Reply with quote

Thank you, the issue is solved. I had renamed the files in /etc/udev/rules.d/ but they still had ".rules" file extensions. Once I changed the file extensions and rebooted, the new udev names worked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum