Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201402-04 ] libwww-perl: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Tue Feb 04, 2014 4:33 pm    Post subject: [ GLSA 201402-04 ] libwww-perl: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: libwww-perl: Multiple vulnerabilities (GLSA 201402-04)
Severity: normal
Exploitable: remote
Date: February 04, 2014
Bug(s): #329943, #386309
ID: 201402-04

Synopsis

Multiple vulnerabilities have been found in libwww-perl, the worst
of which could allow attackers to execute arbitrary code.


Background

libwww is a collection of Perl modules providing a consistent interface
to the World-Wide Web.


Affected Packages

Package: dev-perl/libwww-perl
Vulnerable: < 6.30.0
Unaffected: >= 6.30.0
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in libwww-perl. Please
review the CVE identifiers referenced below for details.


Impact

A remote attacker could entice a user to download a specially-crafted
file with an application linked against libwww-perl, which could result
in overwritten files or arbitrary code execution by writing to a dotfile
in the user’s home directory (such as .bashrc). Additionally, a remote
attacker could perform a Man-in-the-Middle attack.


Workaround

There is no known workaround at this time.

Resolution

All libwww-perl users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-perl/libwww-perl-6.30.0"
   
NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since December 18, 2011. It is likely that your system is
already no longer affected by this issue.


References

CVE-2010-2253
CVE-2011-0633
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum