Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't Load module python
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
naadavan
n00b
n00b


Joined: 23 Oct 2012
Posts: 4

PostPosted: Wed Feb 12, 2014 7:06 am    Post subject: Can't Load module python Reply with quote

Hi All,

Upon running the command:

eselect python list

I encountered this error msg:

!!! Error: Can't load module python
exiting

Please help!


Thanks and God Bless!
_________________
Thanks and God Bless,
Neil
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Thu Feb 13, 2014 12:59 am    Post subject: Reply with quote

Code:
emerge -s python
see if you have
Quote:
app-admin/eselect-python
Latest version available: 20111108
Latest version installed: 20111108
app-admin/python-updater
Latest version available: 0.11
Latest version installed: 0.11
dev-lang/python
Latest version available: 3.3.3
Latest version installed: 3.3.3
dev-lang/python-exec
Latest version available: 2.0.1
Latest version installed: 2.0.1
dev-python/dbus-python
Latest version available: 1.2.0
Latest version installed: 1.2.0
dev-python/gconf-python
Latest version available: 2.28.1
Latest version installed: 2.28.1
dev-python/gnome-python-base
Latest version available: 2.28.1
Latest version installed: 2.28.1
dev-python/python-exec
Latest version available: 10000.2
Latest version installed: 10000.2
virtual/python-argparse
Latest version available: 1
Latest version installed: 1
installed.
Code:
python-updater

_________________
Defund the FCC.
Back to top
View user's profile Send private message
naadavan
n00b
n00b


Joined: 23 Oct 2012
Posts: 4

PostPosted: Thu Feb 13, 2014 2:36 am    Post subject: Reply with quote

Hi,

This is the result of emerge -s python:

* dev-python/qpid-python [ Masked ]
Latest version available: 0.20
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'dev-python/qpid-python-0.20' has unsupported EAPI: '5')
Homepage:
Description:
License:

* dev-python/qscintilla-python [ Masked ]
Latest version available: 2.8
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'dev-python/qscintilla-python-2.8' has unsupported EAPI: '5')
Homepage:
Description:
License:

* dev-python/rax-backup-schedule-python-novaclient-ext [ Masked ]
Latest version available: 9999
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'dev-python/rax-backup-schedule-python-novaclient-ext-9999' has unsupported EAPI: '5')
Homepage:
Description:
License:

* dev-python/rax-default-network-flags-python-novaclient-ext [ Masked ]
Latest version available: 9999
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'dev-python/rax-default-network-flags-python-novaclient-ext-9999' has unsupported EAPI: '5')
Homepage:
Description:
License:

* dev-python/scientificpython [ Masked ]
Latest version available: 2.9.2
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'dev-python/scientificpython-2.9.2' has unsupported EAPI: '5')
Homepage:
Description:
License:

* dev-python/telepathy-python [ Masked ]
Latest version available: 0.15.19-r1
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'dev-python/telepathy-python-0.15.19-r1' has unsupported EAPI: '5')
Homepage:
Description:
License:

* dev-python/thunarx-python [ Masked ]
Latest version available: 0.3.0
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'dev-python/thunarx-python-0.3.0' has unsupported EAPI: '5')
Homepage:
Description:
License:

* dev-python/totem-python [ Masked ]
Latest version available: 2.32.0
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'dev-python/totem-python-2.32.0' has unsupported EAPI: '3')
Homepage:
Description:
License:

* dev-python/wxpython [ Masked ]
Latest version available: 3.0.0.0
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'dev-python/wxpython-3.0.0.0' has unsupported EAPI: '5')
Homepage:
Description:
License:

* dev-tcltk/tclpython [ Masked ]
Latest version available: 4.1-r2
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'dev-tcltk/tclpython-4.1-r2' has unsupported EAPI: '3')
Homepage:
Description:
License:

* dev-util/kdevelop-python [ Masked ]
Latest version available: 1.5.2
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'dev-util/kdevelop-python-1.5.2' has unsupported EAPI: '5')
Homepage:
Description:
License:

* kde-base/krosspython [ Masked ]
Latest version available: 4.12.2
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'kde-base/krosspython-4.12.2' has unsupported EAPI: '5')
Homepage:
Description:
License:

* mail-client/claws-mail-python [ Masked ]
Latest version available: 0.11
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'mail-client/claws-mail-python-0.11' has unsupported EAPI: '4')
Homepage:
Description:
License:

* media-gfx/fontypython [ Masked ]
Latest version available: 0.4.4-r1
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'media-gfx/fontypython-0.4.4-r1' has unsupported EAPI: '5')
Homepage:
Description:
License:

* media-gfx/qrencode-python [ Masked ]
Latest version available: 1.01-r1
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'media-gfx/qrencode-python-1.01-r1' has unsupported EAPI: '5')
Homepage:
Description:
License:

* net-wireless/python-wifi [ Masked ]
Latest version available: 0.5.0-r1
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'net-wireless/python-wifi-0.5.0-r1' has unsupported EAPI: '3')
Homepage:
Description:
License:

* sci-biology/biopython [ Masked ]
Latest version available: 1.63
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'sci-biology/biopython-1.63' has unsupported EAPI: '5')
Homepage:
Description:
License:

* sci-chemistry/openbabel-python [ Masked ]
Latest version available: 2.3.2
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'sci-chemistry/openbabel-python-2.3.2' has unsupported EAPI: '5')
Homepage:
Description:
License:

* sci-misc/pythoncad [ Masked ]
Latest version available: 1.37-r1
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'sci-misc/pythoncad-1.37-r1' has unsupported EAPI: '5')
Homepage:
Description:
License:

* sci-physics/geant-python [ Masked ]
Latest version available: 4.10.00
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'sci-physics/geant-python-4.10.00' has unsupported EAPI: '5')
Homepage:
Description:
License:

* sci-visualization/pythonprop [ Masked ]
Latest version available: 0.13
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'sci-visualization/pythonprop-0.13' has unsupported EAPI: '4')
Homepage:
Description:
License:

* sys-cluster/pbs-python [ Masked ]
Latest version available: 4.3.3-r1
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'sys-cluster/pbs-python-4.3.3-r1' has unsupported EAPI: '5')
Homepage:
Description:
License:

* virtual/python-argparse [ Masked ]
Latest version available: 1
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'virtual/python-argparse-1' has unsupported EAPI: '5')
Homepage:
Description:
License:

* virtual/python-futures [ Masked ]
Latest version available: 0
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'virtual/python-futures-0' has unsupported EAPI: '5')
Homepage:
Description:
License:

* virtual/python-imaging [ Masked ]
Latest version available: 2
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'virtual/python-imaging-2' has unsupported EAPI: '5')
Homepage:
Description:
License:

* virtual/python-unittest2 [ Masked ]
Latest version available: 1-r2
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'virtual/python-unittest2-1-r2' has unsupported EAPI: '5')
Homepage:
Description:
License:

* www-apache/mod_python [ Masked ]
Latest version available: 3.3.1-r1
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'www-apache/mod_python-3.3.1-r1' has unsupported EAPI: '3')
Homepage:
Description:
License:

* x11-apps/python-whiteboard [ Masked ]
Latest version available: 20101012
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'x11-apps/python-whiteboard-20101012' has unsupported EAPI: '3')
Homepage:
Description:
License:

Upon running the python-updater:

* Starting Python Updater from 2.4 to 2.5 :
* Adding to list: =sys-apps/file-4.21-r1
* Adding to list: =sys-libs/cracklib-2.8.10

!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
default/linux/x86/13.0


* IMPORTANT: 18 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=sys-apps/file-4.21-r1".


:?


Thanks and God Bless!
_________________
Thanks and God Bless,
Neil
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Thu Feb 13, 2014 3:57 am    Post subject: Reply with quote

The interesting part of the python-updater would be the very first part--tells what you have-looks like
Quote:
python-updater
* Starting Python Updater...
* Main active version of Python: 2.7
* Active version of Python 2: 2.7
* Active version of Python 3: 3.3
* Globally supported Python ABIs in installed repositories:
* gentoo: 2.4 2.5 2.6 2.7 3.1 3.2 3.3 2.5-jython 2.7-jython 2.7-pypy-1.7 2.7-pypy-1.8 2.7-pypy-1.9 2.7-pypy-2.0
it looks like the problem is a lack of emerged python packages.

Suggest
Code:
grep -i python /etc/portage/make.conf
emerge --info | grep -i python
emerge -1av eselect-python python-updater python python-exec dbus-python gconf-python gnome-python-base python-exec virtual/python-argparse

make.conf might contain a python USE flag or '" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3"' or '" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="python2_7 python3_3"'
with a current profile "emerge --info" output should include '" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3"' or '" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="python2_7 python3_3"'
if python use flag or PYTHON targets are set, python should have been emerged, in fact, as best I know, should have been in the stage3.
emerging the packages should do no harm, and may be of help.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
naadavan
n00b
n00b


Joined: 23 Oct 2012
Posts: 4

PostPosted: Thu Feb 13, 2014 5:36 am    Post subject: Reply with quote

Hi,

this is the result of: emerge -1av eselect-python python-updater python python-exec dbus-python gconf-python gnome-python-base python-exec virtual/python-argparse


!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
default/linux/x86/13.0


* IMPORTANT: 18 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies -

[ Results for search key : python-exec ]
[ Applications found : 2 ]

* dev-lang/python-exec [ Masked ]
Latest version available: 2.9999
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'dev-lang/python-exec-2.9999' has unsupported EAPI: '5')
Homepage:
Description:
License:

* dev-python/python-exec [ Masked ]
Latest version available: 10000.2
Latest version installed: [ Not Installed ]
Size of files: Unknown (getFetchMap(): 'dev-python/python-exec-10000.2' has unsupported EAPI: '5')
Homepage:
Description:
License:

!!! The short ebuild name "python-exec" is ambiguous. Please specify
!!! one of the above fully-qualified ebuild names instead.
... done!
_________________
Thanks and God Bless,
Neil
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Thu Feb 13, 2014 1:54 pm    Post subject: Reply with quote

It has been a while since you updated the system. The update is going to be painful. First item of business should be to back up your personal files. Or the entire system. See http://wiki.gentoo.org/wiki/Backup and then https://wiki.gentoo.org/wiki/Upgrading_Gentoo . The easy (sleezy) way, from where you are, is: backup personal files, backup data for any web servers, dns servers, etc, and do a clean install. The hard but more instructive and instructive way is the upgrade. Good luck. If you run into problems you may want to post new more specific threads.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum