Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hilfe! system Update unmöglich -> ABI_X86 Chaos
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
obo68
n00b
n00b


Joined: 12 Jun 2005
Posts: 14
Location: Magdeburg, Germany

PostPosted: Wed Feb 12, 2014 11:12 pm    Post subject: Hilfe! system Update unmöglich -> ABI_X86 Chaos Reply with quote

Hallo,

ich habe zum ersten Mal seid letzten Juni wieder ein Update machen wollen. Daß es mittlerweile regelmäßig „Hänger”
gibt (Anbhängigkeiten, die Portage nicht lösen kann), daran habe ich mich schon gewöhnt. Doch diesmal bin ich echt
verloren!

Ich versuche seid Montag vergeblich über dieses 'abi_x86_32(-)?,abi_x86_64(-)?' hinweg zukommen. Ich habe zwar
schon im Forum gesucht, aber das hat alles nichts gebracht!

Soweit ich verstanden habe, geht es um 32bit-Bibliotheken auf 64bit-Systemen, oder? Also ich benutzte eigentlich nur
64bit, welche Anwendungen sind denn konkret noch in 32bit? Zumindest bin ich mir nicht bewußt, 32bit-Programme zu
benutzten.

Des weiteren ist mir aufgefallen, das sich die Verzeichnis-Struktur bei '/etc/portage' geändert hat. Dort liegen doch
eigentlich nur Dateien, wie 'package.keywords' oder? In einigen Postings habe ich gesehen, das es mittlerweile ein
'package' Unterverzeichnis gibt, was hat es damit auf sich?

Aber mein größtes Problem ist das nicht funktionierende Update:

Code:
 # emerge -uD system

 * IMPORTANT: 13 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     U  ] sys-libs/glibc-2.17 [2.15-r3] USE="-nscd% -suid% -systemtap%"
[ebuild     U  ] dev-libs/gmp-5.1.2 [5.0.2_p1] USE="-pgo%"
[ebuild     U  ] dev-libs/mpfr-3.1.2-r1 [3.1.1]
[ebuild     U  ] dev-lang/perl-5.16.3 [5.12.4-r1]
[ebuild     U  ] sys-devel/libtool-2.4.2 [2.4-r1] USE="-static-libs%"
[ebuild  r  U  ] dev-libs/icu-51.2-r1 [51.1]
[ebuild     U  ] x11-proto/xproto-7.0.24 [7.0.23-r1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-proto/xextproto-7.2.1-r1 [7.2.1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libICE-1.0.8-r1 [1.0.8] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXau-1.0.8 [1.0.7] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-proto/inputproto-2.3 [2.2] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-proto/kbproto-1.0.6-r1 [1.0.6] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXdmcp-1.1.1-r1 [1.1.1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/pixman-0.32.4 [0.30.0] USE="-ssse3%" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] dev-libs/libpthread-stubs-0.3-r1 [0.3] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-proto/renderproto-0.11.1-r1 [0.11.1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-proto/xf86vidmodeproto-2.3.1-r1 [2.3.1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libdrm-2.4.46 [2.4.45]
[ebuild     U  ] x11-proto/videoproto-2.3.2 [2.3.1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-proto/xf86bigfontproto-1.2.0-r1 [1.2.0] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-proto/scrnsaverproto-1.2.2-r1 [1.2.2] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] dev-util/desktop-file-utils-0.22 [0.21]
[ebuild     U  ] x11-proto/randrproto-1.4.0-r1 [1.4.0] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-proto/recordproto-1.14.2-r1 [1.14.2] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-proto/fixesproto-5.0-r1 [5.0] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-proto/compositeproto-0.4.2-r1 [0.4.2] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] sys-kernel/linux-headers-3.9 [3.7]
[uninstall     ] media-sound/alsa-headers-1.0.25
[blocks b      ] media-sound/alsa-headers ("media-sound/alsa-headers" is blocking sys-kernel/linux-headers-3.9)
[ebuild     U  ] sys-libs/gpm-1.20.7-r1 [1.20.6] USE="-static-libs%"
[ebuild     U  ] dev-db/sqlite-3.8.2 [3.7.16.2]
[ebuild     U  ] x11-libs/libSM-1.2.2 [1.2.1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] dev-libs/libgpg-error-1.12 [1.10]
[ebuild     U  ] x11-misc/shared-mime-info-1.2-r1 [1.0] USE="{-test%}"
[ebuild     U  ] dev-libs/libassuan-2.1.1 [2.1.0]
[ebuild  r  U  ] media-libs/harfbuzz-0.9.23 [0.9.12] USE="cairo%* glib%* graphite%* icu%* introspection%* truetype%*"
[ebuild     U ~] app-admin/eselect-python-20140125 [20111108]
[ebuild     U  ] app-crypt/gnupg-2.0.22 [2.0.20]
[ebuild     U  ] x11-proto/xcb-proto-1.8-r3 [1.8-r1] ABI_X86="(64%*) (-32) (-x32)" PYTHON_TARGETS="python3_3* -python3_2*"
[ebuild     U  ] x11-libs/libxcb-1.9.1 [1.9] USE="-xkb%" ABI_X86="(64%*) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7%* -python2_6% -python3_2% -python3_3%" PYTHON_TARGETS="python2_7%* python3_3%* -python2_6% -python3_2%"
[ebuild     U  ] x11-libs/libX11-1.6.2 [1.5.0] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXext-1.3.2 [1.3.1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXt-1.1.4 [1.1.3] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXrender-0.9.8 [0.9.7] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXfixes-5.0.1 [5.0] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-apps/xprop-1.2.2 [1.2.1]
[ebuild     U  ] x11-libs/libXi-1.7.2 [1.6.1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXmu-1.1.2 [1.1.1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXrandr-1.4.2 [1.4.0] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXdamage-1.1.4-r1 [1.1.3] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXft-2.3.1-r1 [2.3.1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXcomposite-0.4.4-r1 [0.4.3-r1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXcursor-1.1.14 [1.1.13] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXxf86vm-1.1.3 [1.1.2] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXv-1.0.10 [1.0.7] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXScrnSaver-1.2.2-r1 [1.2.2] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXpm-3.5.11 [3.5.10] ABI_X86="(64%*) (-32) (-x32)"
[ebuild  rR    ] x11-libs/pango-1.34.1
[ebuild     U  ] x11-libs/libXtst-1.2.2 [1.2.1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-apps/xset-1.2.3 [1.2.2]
[ebuild     U  ] x11-libs/libXvMC-1.0.8 [1.0.7] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] x11-libs/libXaw-1.0.12 [1.0.11-r1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] media-libs/mesa-9.1.6 [9.1.2-r1] USE="vdpau*"
[ebuild     U  ] x11-misc/xdg-utils-1.1.0_rc1_p20130921 [1.1.0_rc1_p20120319]
[ebuild     U  ] media-libs/freeglut-2.8.1 [2.8.0-r1]
[ebuild     U  ] sys-auth/pambase-20120417-r3 [20120417-r2]
[ebuild     U  ] net-misc/openssh-6.4_p1-r1 [5.9_p1-r4] USE="-ldns%"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-lang/perl-5.16 required by (dev-perl/Digest-Perl-MD5-1.800.0::gentoo, installed)
    =dev-lang/perl-5.16* required by (virtual/perl-digest-base-1.170.0-r1::gentoo, installed)
    (and 44 more with the same problems)

  (dev-lang/perl-5.12.4-r1::gentoo, installed) pulled in by
    dev-lang/perl[-build] required by (dev-perl/libintl-perl-1.210.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/PlRPC-0.202.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Negotiate-6.0.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/Net-Daemon-0.480.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/WWW-RobotRules-6.10.0::gentoo, installed)

dev-libs/icu:0

  (dev-libs/icu-51.1::gentoo, installed) pulled in by
    dev-libs/icu:0/51.1= required by (media-libs/harfbuzz-0.9.12::gentoo, installed)
    dev-libs/icu:0/51.1= required by (media-libs/raptor-2.0.9::gentoo, installed)
    dev-libs/icu:0/51.1= required by (sys-apps/gptfdisk-0.8.6::gentoo, installed)
    >=dev-libs/icu-3.8.1-r1:0/51.1= required by (net-libs/webkit-gtk-2.0.4::gentoo, installed)

  (dev-libs/icu-51.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/harfbuzz:0

  (media-libs/harfbuzz-0.9.23::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/harfbuzz-0.9.12::gentoo, installed) pulled in by
    media-libs/harfbuzz:0/0=[icu(+)] required by (net-libs/webkit-gtk-2.0.4::gentoo, installed)

x11-proto/xcb-proto:0

  (x11-proto/xcb-proto-1.8-r3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/xcb-proto-1.7-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?,python_single_target_python3_2(+)?,python_single_target_python3_3(+)?] required by (x11-libs/libxcb-1.9.1::gentoo, ebuild scheduled for merge)

  (x11-proto/xcb-proto-1.8-r1::gentoo, installed) pulled in by
    >=x11-proto/xcb-proto-1.7.1[python_targets_python2_7(-),python_targets_python3_2(-),python_single_target_python2_7(+)] required by (x11-libs/xpyb-1.3.1-r1::gentoo, installed)




Für eine verständliche Erklärung wär ich echt dankbar!

Oliver.
_________________
Gentoo Linux 2013.0 (3.6.11-r1)
AMD Phenom 9950 @ 2800 MHz, watercooled
4GB RAM, 146+74GB SCSI U320, 2x500GB SATA raid1
GeForce 9600 GT
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1188

PostPosted: Thu Feb 13, 2014 9:53 am    Post subject: Reply with quote

auf den ersten blick sieht es nicht nach einem abi_x86_[32,64] problem aus.
soweit ich das sehen kann, wird überall nur abi_x86_64 aktiviert, was ja das ist, was du willst.

abi_x86_32 braucht man für manche binäre pakete die man nicht selbst kompiliert. z.B. google-earth oder skype möglicherweise, aber ich weiß nicht ob die 32 oder 64 bittig sind, weil ich sie nicht verwende.

bei deinem updatet solltest du ein --newuse (-N) anfügen. damit werden auch pakete neu gebaut, die nur eine useflage änderung erfahren haben. ich glaube, das ist eines der probleme. es wäre auch hilfreich, wenn du --verbose noch verwendest, da sieht man dann bei den ausgaben alle useflags der pakete.
du kannst das ganze auch mal stückchenweise probieren zu reduzieren. also pakete, die keine probleme machen einzeln emergen. z.B.
Code:
emerge -1 glibc gmp libtool

und so weiter, manchmal hilft das, oder aber zumindest wird es dann übersichtlicher.

also ein /etc/portage/package verzeichnis habe ich nicht. es gibt aber (schon ewigkeiten) die möglichkeit, dass ide /etc/portage/package.* Dateien Verzeichnisse sein können. oder was genau meinst du?


Last edited by Christian99 on Thu Feb 13, 2014 9:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
obo68
n00b
n00b


Joined: 12 Jun 2005
Posts: 14
Location: Magdeburg, Germany

PostPosted: Thu Feb 13, 2014 8:08 pm    Post subject: Reply with quote

So, erstmal herzlichen Dank, über das 'ABI_X86' und 'python_targets' Problem bin ich jetzt weg!
Das Problem war nicht 'ABI_X86', sondern die richtige Kombination von Python Targets. Das sieht
jetzt bei mir in 'make.conf' so aus:

Code:
ABI_X86="64"

PHP_TARGETS="php5.5"

PYTHON_TARGETS="python2_7 python3_2 python3_3"
PYTHON_SINGLE_TARGET="python2_7"


Ach ja, das Newuse-Flag hatte ich vergessen, Danke!

Damit habe ich mein 'update -uDN system' endlich durchbekommen.

Eigentlich käme jetzt das world-Update, aber was ich da so über systemd lese, schreckt mich echt ab!
Vor allem, das man an der initrd rumbasteln muß — wobei ich bisher noch kein vernünftiges HOWTO
dazu gefunden habe.
Mein System hat — wie bei Unix üblich (oder sollte ich sagen, früher??) — /usr auf einer separaten
Partition unter lvm.
Und, was soll ich sagen, lvm2-2.02.103 will 'udev-208' mit static-libs Flag, cinnamon/gnome 3.8 wollen
-static-libs USE-Flag???

Ich bin ratlos ...
_________________
Gentoo Linux 2013.0 (3.6.11-r1)
AMD Phenom 9950 @ 2800 MHz, watercooled
4GB RAM, 146+74GB SCSI U320, 2x500GB SATA raid1
GeForce 9600 GT
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3723
Location: Hamburg

PostPosted: Sat Feb 15, 2014 8:00 pm    Post subject: Reply with quote

Quote:
Eigentlich käme jetzt das world-Update, aber was ich da so über systemd lese, schreckt mich echt ab!
systemd kommt doch nicht zwangsläufig auf Deine Kiste bei einem world update, oder ?
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 431
Location: LB

PostPosted: Mon Mar 31, 2014 3:31 pm    Post subject: Reply with quote

Bei mir so ähnlicher Vorgang
:cry:
irgendwie versteh ich nicht was da grad los ist
wenn ich
emerge -uDN net-misc/curl
oder
emerge -uDN x11-proto/xcb-proto

so ausführe klappt alles ABER
bei emerge -uDN x11-libs/libdrm

fängt das Problem an :
Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-misc/curl:0

  (net-misc/curl-7.35.0::gentoo, installed) pulled in by
    net-misc/curl[curl_ssl_gnutls=,curl_ssl_nss=,curl_ssl_openssl=,-curl_ssl_axtls,-curl_ssl_cyassl,-curl_ssl_polarssl] required by (dev-python/pycurl-7.19.0-r3::gentoo, installed)

  (net-misc/curl-7.35.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-proto/xcb-proto:0

  (x11-proto/xcb-proto-1.10::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/xcb-proto-1.10[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,python_targets_python3_3(-),python_single_target_python3_3(+)] required by (x11-libs/libxcb-1.10::gentoo, ebuild scheduled for merge)

  (x11-proto/xcb-proto-1.8-r3::gentoo, installed) pulled in by
    <x11-proto/xcb-proto-1.9 required by (x11-libs/xpyb-1.3.1-r2::gentoo, installed)



package.use
Code:

>=x11-proto/xcb-proto-1.10 abi_x86_64 python_single_target_python3_3 python_targets_python3_3

>=net-misc/curl-7.10   curl_ssl_nss -curl_ssl_openssl


Den Part von oben hab ich mal in die make.conf geschrieben, allerdings hat es dann an anderen Paketen rumgemosert. deshalb PYTHON_SINGLE_TARGET auch alle eingetragen
Python3.3 ist aktiv
Code:
 eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.2
  [3]   python3.3 *

make.conf
Code:
ABI_X86="64"

#PHP_TARGETS="php5.5"

PYTHON_TARGETS="python2_7 python3_2 python3_3"
#PYTHON_TARGETS="python2_7"
PYTHON_SINGLE_TARGET="python2_7 python3_2 python3_3"


so jetzt hab ich einfach mal das hier versucht x11-libs/libxcb (required by (x11-libs/libxcb-1.10::gentoo, ebuild scheduled for merge))
Code:
 emerge -uDN x11-libs/libxcb

 * IMPORTANT: 12 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies |

!!! Problem resolving dependencies for x11-libs/libxcb
... done!
[ebuild   R    ] sys-apps/file-5.17  PYTHON_TARGETS="python3_2*"
[ebuild     U  ] x11-proto/xproto-7.0.25 [7.0.24]
[ebuild   R    ] dev-lang/python-3.2.5-r3  USE="sqlite*"
[ebuild   R    ] dev-libs/libxml2-2.9.1-r1  PYTHON_TARGETS="python3_2*"
[ebuild   R    ] sys-apps/portage-2.2.8-r1  PYTHON_TARGETS="python3_2*"
[ebuild     U  ] x11-proto/xcb-proto-1.10 [1.8-r3] PYTHON_TARGETS="python3_2*"
[ebuild     U  ] x11-libs/libxcb-1.10 [1.9.1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-proto/xcb-proto:0

  (x11-proto/xcb-proto-1.8-r3::gentoo, installed) pulled in by
    <x11-proto/xcb-proto-1.9 required by (x11-libs/xpyb-1.3.1-r2::gentoo, installed)

  (x11-proto/xcb-proto-1.10::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/xcb-proto-1.10[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,python_targets_python3_3(-),python_single_target_python3_3(+)] required by (x11-libs/libxcb-1.10::gentoo, ebuild scheduled for merge)


:oops:

wäre toll wenn da jemand ein Tip hat
_________________
Never give up
WM : E16 layman -o https://raw.githubusercontent.com/mcclung/e16-overlay/master/repositories.xml -f -a e16-overlay
achim
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 269

PostPosted: Mon Mar 31, 2014 4:37 pm    Post subject: Reply with quote

Ich würde zunächst x11-libs/xpyb-1.3.1-r2 auf r3 updaten. Das benötigt
Quote:
>=x11-proto/xcb-proto-1.7.1]
<x11-proto/xcb-proto-1.9
(was du installiert hast), während r3 nur
Quote:
>=x11-proto/xcb-proto-1.7.1
benötigt. Kurz gesagt, xcb-proto > 1.9 passt nicht zu xpyb-xx.r2.

Dann würde ich dies entfernen
Quote:
>=x11-proto/xcb-proto-1.10 abi_x86_64 python_single_target_python3_3 python_targets_python3_3


Und dann schau mal ob sich x11-proto/xcb-proto updaten läßt

EDIT:
Also erstmal sorry für das Kauderwelsch - man soll einfach keine zwei Sachen gleichzeitig machen.
Was ich meinte war:
x11-libs/xpyb-1.3.1-r2 benötigt ein x11-proto/xcb-proto größer/gleich 1.7.1 und kleiner 1.9 - das hast du installiert, nämlich 1.8-r3.
x11-libs/xpyb-1.3.1-r3 benötigt lediglich >=x11-proto/xcb-proto-1.7.1.

Also zuerst x11-libs/xpyb-1.3.1-r2 auf r3 updaten, dann läßt sich evtl. schon x11-proto/xcb-proto updaten.

Ich hoffe, das war verständlicher.
_________________
”Everything should be made as simple as possible, but no simpler.” – Albert Einstein
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum