Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] emerge ati-drivers -> emake failure.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Zazzman
n00b
n00b


Joined: 09 May 2012
Posts: 32

PostPosted: Tue Feb 18, 2014 10:32 pm    Post subject: [SOLVED] emerge ati-drivers -> emake failure. Reply with quote

So I go to install this:

Code:
[ebuild  N    ] x11-drivers/ati-drivers-13.9  USE="modules (multilib) qt4 -debug -pax_kernel -static-libs"


On this:

Code:
emerge --info '=x11-drivers/ati-drivers-13.9::gentoo'
Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.8.2, glibc-2.17, 3.2.33-std311-amd64 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.2.33-std311-amd64-x86_64-AMD_FX-tm-8350_Eight-Core_Processor-with-gentoo-2.2
KiB Mem:    16332508 total,   7993064 free
KiB Swap:   17825788 total,  17825788 free
Timestamp of tree: Tue, 18 Feb 2014 22:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5-r3, 3.3.3
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
USE="3dnow X a52 aac aalib acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cddb cdinstall cdparanoia cdr cgi cli consolekit cracklib crypt css cups curl curlwrappers custom-cflags cvs cxx dbus dga djvu dri dts dvb dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran ftp gdbm gif gphoto2 gpm gsteamer gtk gzip iconv ipv6 joystick jpeg jpeg2k lame lcms ldap libass libnotify libsamplerate lm_sensors lua lzma lzo mad matroska mms mmx mmxext mng modules mozilla mp3 mp4 mpeg mplayer multilib musepack ncurses networkmanager nls nocd nptl offensive ogg openal openexr opengl openmp pam pango pcre pdf png policykit posix ppds profile pulseaudio qt3support readline rss sasl savedconfig scanner sdl session smp socks5 sound spell sse sse2 sse3 sse4_1 sse4_2 sse4a ssl ssse3 startup-notification svg syslog szip tcpd theora threads tiff truetype udev udisks unicode upnp upnp-av upower usb v4l vcd vdpau videos vorbis wxwidgets x264 xcb xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc efi-64" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="EN-US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON


And here's what happens:

Code:
 * Preparing fglrx module
make HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' GCC_VER_MAJ=4 KVER=3.13.3-gentoo KDIR=/usr/src/linux 'CFLAGS_MODULE+=-DMODULE -DATI -DFGL' CFLAGS_MODULE+=-DCOMPAT_ALLOC_USER_SPACE=arch_compat_alloc_user_space kmod_build
make -C /usr/src/linux M=/var/tmp/portage/x11-drivers/ati-drivers-13.9/work/common/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-3.13.3-gentoo'
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.9/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
/var/tmp/portage/x11-drivers/ati-drivers-13.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.c: In function 'KCL_ACPI_GetHandles':
/var/tmp/portage/x11-drivers/ati-drivers-13.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.c:796:59: error: 'struct acpi_dev_node' has no member named 'handle'
         pInfo->video_handle = pInfo->pcidev->dev.acpi_node.handle;
                                                           ^
make[2]: *** [/var/tmp/portage/x11-drivers/ati-drivers-13.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o] Error 1
make[1]: *** [_module_/var/tmp/portage/x11-drivers/ati-drivers-13.9/work/common/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-3.13.3-gentoo'
make: *** [kmod_build] Error 2
 * ERROR: x11-drivers/ati-drivers-13.9::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/ati-drivers-13.9::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/ati-drivers-13.9::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-13.9/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-13.9/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/ati-drivers-13.9/work/common/lib/modules/fglrx/build_mod/2.6.x'
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-13.9/work'


IE: nothing happens.

What is
Code:
error: 'struct acpi_dev_node' has no member named 'handle'
about?

Last edited by Zazzman on Tue Feb 18, 2014 11:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
Zazzman
n00b
n00b


Joined: 09 May 2012
Posts: 32

PostPosted: Tue Feb 18, 2014 11:55 pm    Post subject: Reply with quote

unmasking the next version of ati-drivers (14.1 Beta) allows a clean install. /etc/portage/package.keywords, HOOOO!!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum