Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
CUPS 1.7.1 weird symbols [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
sgobbo
n00b
n00b


Joined: 06 Jan 2011
Posts: 4

PostPosted: Mon Feb 24, 2014 11:22 pm    Post subject: CUPS 1.7.1 weird symbols [SOLVED] Reply with quote

Hello,
after upgrading CUPS from 1.6.4 to 1.7.1 can't print anymore.

I have an old hp c3180 connected to a qnap nas running CUPS 1.4 and from my notebook (gentoo CUPS 1.6.4) can print without problems.

On my desktop (gentoo CUPS 1.7.1) when try to print text file,pdf or test page i got only one line with weird symbols and then the printer goes in error state.

The same behaviour trying to print with another notebook with archlinux and CUPS 1.7.1.

Can't find any errors in cups error.log:
http://pastebin.com/0xqrmfSR

I tried setting ServerName IP in client.conf, change ipp version 1.0/1.1, change from *LanguageLevel: "3" to *LanguageLevel: "2", apply this patch http://www.linuxfromscratch.org/patches/blfs/svn/cups-1.7.1-content_type-1.patch without success.

emerge --info:
Code:
Portage 2.2.7 (default/linux/amd64/13.0, gcc-4.7.3, glibc-2.17, 3.12.11-gentoo x86_64)
=================================================================
System uname: Linux-3.12.11-gentoo-x86_64-Intel-R-_Core-TM-_i5-4570S_CPU_@_2.90GHz-with-gentoo-2.2
KiB Mem:     8109480 total,   5276148 free
KiB Swap:    1048572 total,   1048572 free
Timestamp of tree: Tue, 25 Feb 2014 17:15:01 +0000
ld ld di GNU (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.3.3
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo angelos
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core-avx2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core-avx2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/"
LANG="it_IT.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/angelos"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 avx avx2 berkdb bzip2 cairo cdda cli consolekit cracklib crypt cups cxx dbus device-mapper dri dvb dvd extensions extras ffmpeg flac fortran gdbm gdu gstreamer gtk iconv ipv6 jpeg jpeg2k lame libass libnotify mad matroska mmx modules mp3 mpeg multilib musepack ncurses nls nptl ogg opengl openmp pam pcre pdf png policykit qt3support readline session sse sse2 sse4_1 ssl ssse3 startup-notification svg tcpd udev unicode vdpau vorbis wavpack x264 xosd xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev keyboard mouse roccat_konepure roccat_ryos" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="it" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


emerge -pv cups cups-filters ghostscript-gpl[/code]
Code:

[ebuild   R    ] net-print/cups-1.7.1  USE="X acl dbus pam ssl threads -debug -gnutls -java -kerberos -lprng-compat -python (-selinux) -static-libs -usb -xinetd -zeroconf" LINGUAS="it -ca -es -fr -ja -ru" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" 0 kB
[ebuild   R    ] app-text/ghostscript-gpl-9.10-r2  USE="X cups dbus gtk -bindist -djvu -idn -static-libs" LINGUAS="-de -ja -ko -zh_CN -zh_TW" 30,263 kB
[ebuild   R    ] net-print/cups-filters-1.0.43-r1  USE="dbus foomatic jpeg png -perl -static-libs -tiff -zeroconf" 1,074 kB
[ebuild   R    ] net-print/hplip-3.14.1  USE="X hpcups libnotify policykit scanner -doc -fax -hpijs -kde -libusb0 -minimal -parport -qt4 -snmp -static-ppds" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" 0 kB


Any help would be really appreciated.
Thank you


SOLVED:
cups 1.7.1 enable compression by default but the remote raw queue doesn't apply decompression before sending to printer.

Adding ipp://ip:port/printers/queue?compression=none
fix the problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum