Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Asus sabertooth 990fx woes.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
truekaiser
l33t
l33t


Joined: 05 Mar 2004
Posts: 753

PostPosted: Sun Mar 02, 2014 12:13 am    Post subject: Asus sabertooth 990fx woes. Reply with quote

Okay i have been hitting my head for the past couple of days trying to figure this out.
i just upgraded to an amd 8350 on a sabertooth 990fx and i am running into this problem.
With iommu ON in the settings and activated in the kernel. everything works but when i try to start x it just freezes at a blank screen and i can't find anything wrong.
With it off Most of the usb ports don't work, the network driver 'r8169' seems to ignore dhcp. but video works!
I a not booting into uefi, could that be the issue?
_________________
"My father rode a camel. I drive a car. My son flies a jet-plane. His son will ride a camel."
—Saudi saying
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3927
Location: Dallas area

PostPosted: Sun Mar 02, 2014 12:54 am    Post subject: Reply with quote

Try adding "iommu=pt" to the grub cmd line (or whatever loader you are using)
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
truekaiser
l33t
l33t


Joined: 05 Mar 2004
Posts: 753

PostPosted: Sun Mar 02, 2014 1:07 am    Post subject: Reply with quote

Anon-E-moose wrote:
Try adding "iommu=pt" to the grub cmd line (or whatever loader you are using)


usb bugs out.
the network driver says it's a not registered mmio device.
_________________
"My father rode a camel. I drive a car. My son flies a jet-plane. His son will ride a camel."
—Saudi saying
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3927
Location: Dallas area

PostPosted: Sun Mar 02, 2014 1:12 am    Post subject: Reply with quote

I have an asus m5a99fx and when I turned on iommu I had to pass the parameter mentioned to get it to recognize some of the devices.

"pt" means passthrough, and some amd boards need it.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
truekaiser
l33t
l33t


Joined: 05 Mar 2004
Posts: 753

PostPosted: Sun Mar 02, 2014 1:24 am    Post subject: Reply with quote

Anon-E-moose wrote:
I have an asus m5a99fx and when I turned on iommu I had to pass the parameter mentioned to get it to recognize some of the devices.

"pt" means passthrough, and some amd boards need it.


well i tried again after enabling the 64mb option in the uefi/bios settings and it boots normally, usb seems to work, network works but it gets the wrong address from the router 192.168.0.143 instead of 192.168.0.100.
but fglrx bugs out upon loading X with a kernel panic of a null pointer.

the problem with the usb was it was getting 'did not accept address'' or device reset errors.
_________________
"My father rode a camel. I drive a car. My son flies a jet-plane. His son will ride a camel."
—Saudi saying
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum