Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] 2GB DMA BUS causing write errors with large files
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
vexatious
Tux's lil' helper
Tux's lil' helper


Joined: 24 Aug 2010
Posts: 77

PostPosted: Wed Mar 05, 2014 7:31 am    Post subject: [SOLVED] 2GB DMA BUS causing write errors with large files Reply with quote

Recently patched kernel-3.11.0 dma bus to be 2GB instead of the usual 4GB. Reason is I use a Sound Blaster Live! 5.1 card and wihout patching, I'm unable to load soundfonts (have 16gb of ram with 64-bit kernel). I've loaded 1.6GB+ soundfonts and card is pretty amazing considering it's from 1998-1999 (it's basically 1000MIPS for free, free's up my CPU and does midi and multiple sound mixing in hardware. Top notch Linux support and there's even an emu10k1 assembler=WHOA). Anyway...

Everything seems fine, but when I try transcoding video files via mplayer, I get the following stdout
Code:
bash-4.2$ mplayer -rawvideo format=hm12:h=480:w=720 -demuxer 26 *hm12 -vo yuv4mpeg
MPlayer 1.1-4.8.2 (C) 2000-2012 MPlayer Team

Playing side2.video.hm12.
rawvideo file format detected.
Load subtitles in ./
Using (default) progressive frame mode.
==========================================================================
Opening video decoder: [hmblck] Hauppauge Macroblock/NV12/NV21 Decoder
Movie-Aspect is undefined - no prescaling applied.
VO: [yuv4mpeg] 720x480 => 720x480 Planar YV12
Selected video codec: [rawhm12] vfm: hmblck (RAW HM12)
==========================================================================
Audio: no sound
Starting playback...
V: 130.6 3266/3266  0%  6%  0.0% 0 0
Error writing image to output!V: 130.6 3267/3267  0%  6%  0.0% 0 0
Error writing image to output!V: 130.7 3268/3268  0%  6%  0.0% 0 0
Error writing image to output!V: 130.7 3269/3269  0%  6%  0.0% 0 0
Error writing image to output!V: 130.8 3270/3270  0%  6%  0.0% 0 0
Error writing image to output!V: 130.8 3271/3271  0%  6%  0.0% 0 0
Error writing image to output!V: 130.8 3272/3272  0%  6%  0.0% 0 0
Error writing image to output!V: 130.9 3273/3273  0%  6%  0.0% 0 0
Error writing image to output!V: 130.9 3274/3274  0%  6%  0.0% 0 0
Error writing image to output!V: 131.0 3275/3275  0%  6%  0.0% 0 0
Error writing image to output!V: 131.0 3276/3276  0%  6%  0.0% 0 0
Error writing image to output!V: 131.0 3277/3277  0%  6%  0.0% 0 0
Error writing image to output!V: 131.1 3278/3278  0%  6%  0.0% 0 0
Error writing image to output!V: 131.1 3279/3279  0%  6%  0.0% 0 0
Error writing image to output!V: 131.2 3280/3280  0%  6%  0.0% 0 0
Error writing image to output!V: 131.2 3281/3281  0%  6%  0.0% 0 0
Error writing image to output!V: 131.2 3282/3282  0%  6%  0.0% 0 0
Error writing image to output!V: 131.3 3283/3283  0%  6%  0.0% 0 0
Error writing image to output!V: 131.3 3284/3284  0%  6%  0.0% 0 0
Error writing image to output!V: 131.4 3285/3285  0%  6%  0.0% 0 0
Error writing image to output!V: 131.4 3286/3286  0%  6%  0.0% 0 0
Error writing image to output!V: 131.4 3287/3287  0%  6%  0.0% 0 0
Error writing image to output!V: 131.5 3288/3288  0%  6%  0.0% 0 0
Error writing image to output!V: 131.5 3289/3289  0%  6%  0.0% 0 0
Error writing image to output!V: 131.6 3290/3290  0%  6%  0.0% 0 0
Error writing image to output!V: 131.6 3291/3291  0%  6%  0.0% 0 0
Error writing image to output!V: 131.6 3292/3292  0%  6%  0.0% 0 0
Error writing image to output!V: 131.7 3293/3293  0%  6%  0.0% 0 0
Error writing image to output!V: 131.7 3294/3294  0%  6%  0.0% 0 0
Error writing image to output!V: 131.8 3295/3295  0%  6%  0.0% 0 0
Error writing image to output!V: 131.8 3296/3296  0%  6%  0.0% 0 0
Error writing image to output!V: 131.8 3297/3297  0%  6%  0.0% 0 0
Error writing image to output!V: 131.9 3298/3298  0%  6%  0.0% 0 0
Error writing image to output!V: 131.9 3299/3299  0%  6%  0.0% 0 0
Error writing image to output!V: 132.0 3300/3300  0%  6%  0.0% 0 0
Error writing image to output!V: 132.0 3301/3301  0%  6%  0.0% 0 0
Error writing image to output!V: 132.0 3302/3302  0%  6%  0.0% 0 0
Error writing image to output!V: 132.1 3303/3303  0%  6%  0.0% 0 0
Error writing image to output!V: 132.1 3304/3304  0%  6%  0.0% 0 0
Error writing image to output!V: 132.2 3305/3305  0%  6%  0.0% 0 0
Error writing image to output!V: 132.2 3306/3306  0%  6%  0.0% 0 0
Error writing image to output!V: 132.2 3307/3307  0%  6%  0.0% 0 0
Error writing image to output!V: 132.3 3308/3308  0%  6%  0.0% 0 0
Error writing image to output!V: 132.3 3309/3309  0%  6%  0.0% 0 0
Error writing image to output!V: 132.4 3310/3310  0%  6%  0.0% 0 0
Error writing image to output!V: 132.4 3311/3311  0%  6%  0.0% 0 0
Error writing image to output!V: 132.4 3312/3312  0%  6%  0.0% 0 0
Error writing image to output!V: 132.5 3313/3313  0%  6%  0.0% 0 0
Error writing image to output!V: 132.5 3314/3314  0%  6%  0.0% 0 0
Error writing image to output!V: 132.6 3315/3315  0%  6%  0.0% 0 0
Error writing image to output!V: 132.6 3316/3316  0%  6%  0.0% 0 0
Error writing image to output!V: 132.6 3317/3317  0%  6%  0.0% 0 0
Error writing image to output!V: 132.7 3318/3318  0%  6%  0.0% 0 0
Error writing image to output!V: 132.7 3319/3319  0%  6%  0.0% 0 0
Error writing image to output!V: 132.8 3320/3320  0%  6%  0.0% 0 0
Error writing image to output!V: 132.8 3321/3321  0%  6%  0.0% 0 0
Error writing image to output!V: 132.8 3322/3322  0%  6%  0.0% 0 0
Error writing image to output!V: 132.9 3323/3323  0%  6%  0.0% 0 0
Error writing image to output!V: 132.9 3324/3324  0%  6%  0.0% 0 0
Error writing image to output!V: 133.0 3325/3325  0%  6%  0.0% 0 0
Error writing image to output!V: 133.0 3326/3326  0%  6%  0.0% 0 0
Error writing image to output!V: 133.0 3327/3327  0%  6%  0.0% 0 0


Not exactly sure if this is due to the DMA bus patch or directly with mplayer, but recently did emerge e world and VLC stopped working with my raw video capture device (screen stays black) so I don't know (it works fine with mplayer so I'm guessing a library update caused a glitch or something).

Is there any way to know for sure if the DMA bus patch is/isn't causing problems? If so, how do I fix it?
_________________
Gentoo
Slackware


Last edited by vexatious on Wed Mar 05, 2014 9:56 am; edited 3 times in total
Back to top
View user's profile Send private message
TomWij
Retired Dev
Retired Dev


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Wed Mar 05, 2014 8:06 am    Post subject: Reply with quote

Memory access patches might be able to affect this; so, I suggest to try some time without the patch in order to determine if the patch is the cause. In case that doesn't make a change, you can go a step further and try to troubleshoot with strace and/or ltrace to see more exactly what kind of error comes up trying to write the file. Because "Error writing image to output!" is somewhat vague...
Back to top
View user's profile Send private message
vexatious
Tux's lil' helper
Tux's lil' helper


Joined: 24 Aug 2010
Posts: 77

PostPosted: Wed Mar 05, 2014 9:51 am    Post subject: Reply with quote

Truly grateful for your help (this forum is very energetic, supportive and intelligent!)!

From my mistake, I found out my HDD was indeed full. Never though that'd happen. Now I know what happens when I force oMGNeEUW200giGzFii!!lEz on a full hard drive. Linux never ceazes to amaze me with its stability... Neither does this forum!

Many great thanks and blessings!

Regards
_________________
Gentoo
Slackware
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum