Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED-ish] Intel i915 screen misaligned
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
CaptainBland
n00b
n00b


Joined: 05 Mar 2014
Posts: 1

PostPosted: Wed Mar 05, 2014 4:19 pm    Post subject: [SOLVED-ish] Intel i915 screen misaligned Reply with quote

Hi,

I have been trying to set up a Gentoo system on a system with an Intel Atom D525 requiring an i915 driver.

I'm experiencing an issue where on a VGA connection, the screen resolution is set correctly at the terminal and in X to 1280x800 (the native resolution of our monitor), however the image on the screen appears to be shifted to the left by maybe 100 pixels or so (so there's a black border that thick on the right side). The monitor unfortunately has no options for manual calibration. Trying it on a Windows laptop, the display seems to be set properly.

On a DVI connection, the image is still shifted to the left but the screen resolution is set at 1024x768.

Using a vesa driver and a kernel without the i915 kernel drivers over VGA or DVI, the entire display is used and aligned properly, but the maximum resolution X will set to is 1024x768.

Ideally I'd like to be able to set the resolution to 1280x800 under X (I'm not worried about the terminal) on my monitor using either VGA or DVI, and have the display be correct.

Any help would be appreciated!

Thanks.

Edit: I should add: Kernel version is 3.6.12, patched for AUFS support.

Edit again: For curious onlookers, the problem was solved. Regretfully it's unclear as to how exactly, but we tried the monitor on a similarly set up system and it just kind of worked. Given that most of the system files should have only been writtable to a copy-up RAM disk (using AUFS) on most of the writable system files, it's unclear as to how an apparently permanent difference occurred there. My speculation is that it has something to do with the graphics chip on the board I was using possibly caching EDID information from another monitor. The issue is confusing, though.

Edit: There was a BIOS setting for screen resolution. Did not see that one coming.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum