Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wireless networking with wpa2
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
jls7884
n00b
n00b


Joined: 14 Mar 2014
Posts: 21

PostPosted: Mon Mar 24, 2014 12:32 am    Post subject: Reply with quote

Profile is: default/linux/amd64/13.0/desktop/kde/systemd

emerge -uND --keep-going wpa_supplicant linux-frmware dhcpcd wireless-tools iw

returns: emerge: there are no ebuilds to satisfy "linux-frmware".

emerge: searching for similar names...
emerge: Maybe you meant any of these: sys-kernel/linux-firmware, sec-policy/selinux-vmware, media-tv/linuxtv-dvb-firmware?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Mon Mar 24, 2014 12:35 am    Post subject: Reply with quote

my typo linux-firmware sorry
_________________
Defund the FCC.
Back to top
View user's profile Send private message
jls7884
n00b
n00b


Joined: 14 Mar 2014
Posts: 21

PostPosted: Mon Mar 24, 2014 12:40 am    Post subject: Reply with quote

Got it. Still need use changes and along with that it returns:

!!! The ebuild selected to satisfy "dev-libs/libpcre" has unmet requirements.
- dev-libs/libpcre-8.33::gentoo USE="bzip2 cxx jit libedit (policykit) readline recursion-limit static-libs (unicode) zlib -pcre16 -pcre32" ABI_X86="64"

The following REQUIRED_USE flag constraints are unsatisfied:
readline? ( !libedit ) libedit? ( !readline )

(dependency required by "app-text/qpdf-4.1.0" [ebuild])
(dependency required by "net-print/cups-filters-1.0.43-r1" [ebuild])
(dependency required by "net-print/cups-1.7.1" [ebuild])
(dependency required by "dev-qt/qtgui-4.8.5-r1[cups]" [ebuild])
(dependency required by "app-doc/doxygen-1.8.3.1[qt4]" [ebuild])
(dependency required by "media-libs/libcaca-0.99_beta17[doc]" [ebuild])
(dependency required by "media-libs/libsdl-1.2.15-r4[libcaca]" [ebuild])
(dependency required by "dev-libs/zziplib-0.13.60-r1[sdl]" [ebuild])
(dependency required by "dev-tex/luatex-0.70.1-r2" [ebuild])
(dependency required by "dev-texlive/texlive-latex-2012" [ebuild])
(dependency required by "dev-tex/xcolor-2.11" [ebuild])

How do I satisfy the use flag constraints?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Mon Mar 24, 2014 12:48 am    Post subject: Reply with quote

in package.use: dev-libs/libpcre -libedit readline

meaning don't compile libpcre with libedit support; do compile with readline support

I favored readline because I have it that way, not for any good reason, YMMV
_________________
Defund the FCC.
Back to top
View user's profile Send private message
jls7884
n00b
n00b


Joined: 14 Mar 2014
Posts: 21

PostPosted: Mon Mar 24, 2014 1:36 am    Post subject: Reply with quote

I was able to fix the constraints by setting libedit to -libedit in make.conf and I made the use changes by adding:

>=app-text/docbook-sgml-utils-0.6.14-r1 jadetex
=net-dns/avahi-0.6.31-r2 mdnsresponder-compat
>=dev-scheme/guile-1.8.8-r1:12 networking
>=dev-lang/spidermonkey-17.0.0-r3:17 -debug
=app-doc/doxygen-1.8.3.1 dot

to package.use.

I kept running into circular dependencies but was able to work around it by making the recommended use changes.

After running emerge wpa_supplicant I now run into:

>>> Emerging (8 of 75) dev-db/oracle-instantclient-basic-11.2.0.3

!!! dev-db/oracle-instantclient-basic-11.2.0.3 has fetch restriction turned on.
!!! This probably means that this ebuild's files must be downloaded
!!! manually. See the comments in the ebuild for more information.

* Fetch failed for 'dev-db/oracle-instantclient-basic-11.2.0.3', Log file:
* '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/temp/build.log'
* Please go to
* http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html
* and download
* Instant Client for Linux x86
* Basic: (still absent) instantclient-basic-linux-11.2.0.3.0.zip
* Instant Client for Linux x86-64
* Basic: (still absent) instantclient-basic-linux.x64-11.2.0.3.0.zip
* SDK: (still absent) instantclient-sdk-linux.x64-11.2.0.3.0.zip
* After downloading these files (for *all* shown architectures), put them in:
* /usr/portage/distfiles/

>>> Failed to emerge dev-db/oracle-instantclient-basic-11.2.0.3, Log file:

>>> '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/temp/build.log'

* Messages for package dev-db/oracle-instantclient-basic-11.2.0.3:

* Fetch failed for 'dev-db/oracle-instantclient-basic-11.2.0.3', Log file:
* '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/temp/build.log'
* Please go to
* http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html
* and download
* Instant Client for Linux x86
* Basic: (still absent) instantclient-basic-linux-11.2.0.3.0.zip
* Instant Client for Linux x86-64
* Basic: (still absent) instantclient-basic-linux.x64-11.2.0.3.0.zip
* SDK: (still absent) instantclient-sdk-linux.x64-11.2.0.3.0.zip
* After downloading these files (for *all* shown architectures), put them in:
* /usr/portage/distfiles/

* GNU info directory index is up-to-date.

Do I need to cd /usr/portage/distfiles/ and then use links to download them to that directory or can I use the browser in ubuntu.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Mon Mar 24, 2014 1:48 am    Post subject: Reply with quote

oracle makes each client browse to their website http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html , accept license, and download their database (and java) products individually. after the downloads, put the packages in /usr/portage/distfiles and then repeat the emerge. if you use the gui browser in ubuntu note that it is outside the chroot so the move will be to /mnt/gentoo/usr/portage/distfiles from the ubuntu download location
_________________
Defund the FCC.
Back to top
View user's profile Send private message
jls7884
n00b
n00b


Joined: 14 Mar 2014
Posts: 21

PostPosted: Mon Mar 24, 2014 2:43 am    Post subject: Reply with quote

Now I get failure unpacking

Output:

Code:
(chroot) jacob-VGN-TZ150N init.d # emerge wpa_supplicant

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 66) dev-db/oracle-instantclient-basic-11.2.0.3
 * Fetching files in the background. To view fetch progress, run
 * `tail -f /var/log/emerge-fetch.log` in another terminal.
 * instantclient-basic-linux.x64-11.2.0.3.0.zip SHA256 SHA512 WHIRLPOOL size ;-) ...                                                            [ ok ]
 * instantclient-sdk-linux.x64-11.2.0.3.0.zip SHA256 SHA512 WHIRLPOOL size ;-) ...                                                              [ ok ]

!!! dev-db/oracle-instantclient-basic-11.2.0.3 has fetch restriction turned on.
!!! This probably means that this ebuild's files must be downloaded
!!! manually.  See the comments in the ebuild for more information.

 * Fetch failed for 'dev-db/oracle-instantclient-basic-11.2.0.3', Log file:
 *  '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/temp/build.log'
 * Please go to
 *   http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html
 *   and download
 * Instant Client for Linux x86
 *     Basic: (still absent) instantclient-basic-linux-11.2.0.3.0.zip
 * Instant Client for Linux x86-64
 *     Basic: (already here) instantclient-basic-linux.x64-11.2.0.3.0.zip
 *     SDK:   (already here) instantclient-sdk-linux.x64-11.2.0.3.0.zip
 * After downloading these files (for *all* shown architectures), put them in:
 *     /usr/portage/distfiles/

>>> Failed to emerge dev-db/oracle-instantclient-basic-11.2.0.3, Log file:

>>>  '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/temp/build.log'

 * Messages for package dev-db/oracle-instantclient-basic-11.2.0.3:

 * Fetch failed for 'dev-db/oracle-instantclient-basic-11.2.0.3', Log file:
 *  '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/temp/build.log'
 * Please go to
 *   http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html
 *   and download
 * Instant Client for Linux x86
 *     Basic: (still absent) instantclient-basic-linux-11.2.0.3.0.zip
 * Instant Client for Linux x86-64
 *     Basic: (already here) instantclient-basic-linux.x64-11.2.0.3.0.zip
 *     SDK:   (already here) instantclient-sdk-linux.x64-11.2.0.3.0.zip
 * After downloading these files (for *all* shown architectures), put them in:
 *     /usr/portage/distfiles/
(chroot) jacob-VGN-TZ150N init.d # emerge wpa_supplicant

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 66) dev-db/oracle-instantclient-basic-11.2.0.3
 * instantclient-basic-linux.x64-11.2.0.3.0.zip SHA256 SHA512 WHIRLPOOL size ;-) ...                                                            [ ok ]
 * instantclient-sdk-linux.x64-11.2.0.3.0.zip SHA256 SHA512 WHIRLPOOL size ;-) ...                                                              [ ok ]
 * instantclient-basic-linux-11.2.0.3.0.zip SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                [ ok ]
>>> Unpacking source...
>>> Unpacking instantclient-basic-linux-11.2.0.3.0.zip to /var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/work/x86
error:  cannot open zipfile [ /var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/distdir/instantclient-basic-linux-11.2.0.3.0.zip ]
        Permission denied
unzip:  cannot find or open /var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/distdir/instantclient-basic-linux-11.2.0.3.0.zip, /var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/distdir/instantclient-basic-linux-11.2.0.3.0.zip.zip or /var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/distdir/instantclient-basic-linux-11.2.0.3.0.zip.ZIP.
 * ERROR: dev-db/oracle-instantclient-basic-11.2.0.3::gentoo failed (unpack phase):
 *   failure unpacking instantclient-basic-linux-11.2.0.3.0.zip
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_unpack
 *        environment, line 1971:  Called unpack 'instantclient-basic-linux-11.2.0.3.0.zip'
 *   phase-helpers.sh, line  348:  Called die
 * The specific snippet of code:
 *               ( set +x ; while true ; do echo n || break ; done ) | \
 *               unzip -qo "${srcdir}${x}" || die "$myfail"
 *
 * If you need support, post the output of `emerge --info '=dev-db/oracle-instantclient-basic-11.2.0.3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-db/oracle-instantclient-basic-11.2.0.3::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/work/x86'
 * S: '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/work/x86/instantclient_11_2'

>>> Failed to emerge dev-db/oracle-instantclient-basic-11.2.0.3, Log file:

>>>  '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/temp/build.log'

 * Messages for package dev-db/oracle-instantclient-basic-11.2.0.3:

 * ERROR: dev-db/oracle-instantclient-basic-11.2.0.3::gentoo failed (unpack phase):
 *   failure unpacking instantclient-basic-linux-11.2.0.3.0.zip
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_unpack
 *        environment, line 1971:  Called unpack 'instantclient-basic-linux-11.2.0.3.0.zip'
 *   phase-helpers.sh, line  348:  Called die
 * The specific snippet of code:
 *               ( set +x ; while true ; do echo n || break ; done ) | \
 *               unzip -qo "${srcdir}${x}" || die "$myfail"
 *
 * If you need support, post the output of `emerge --info '=dev-db/oracle-instantclient-basic-11.2.0.3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-db/oracle-instantclient-basic-11.2.0.3::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/work/x86'
 * S: '/var/tmp/portage/dev-db/oracle-instantclient-basic-11.2.0.3/work/x86/instantclient_11_2'
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Mon Mar 24, 2014 2:55 am    Post subject: Reply with quote

Code:
emerge unzip

_________________
Defund the FCC.
Back to top
View user's profile Send private message
kurly
Apprentice
Apprentice


Joined: 02 Apr 2012
Posts: 253

PostPosted: Mon Mar 24, 2014 3:12 am    Post subject: Reply with quote

This is probably going to wind up being a permission issue, not a problem with unzip.

Make sure the file/files in /usr/portage/distfiles is/are owned by portage:portage and 664 (not a typo).
Back to top
View user's profile Send private message
jls7884
n00b
n00b


Joined: 14 Mar 2014
Posts: 21

PostPosted: Mon Mar 24, 2014 5:00 am    Post subject: Reply with quote

Still getting unpacking failure.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Mon Mar 24, 2014 5:04 am    Post subject: Reply with quote

use emerge -uND --keep-going to bypass the instantclient nonsense for the moment
with respect to permissions
Code:
ls -l /usr/portage/distfiles/instantclient-basic-linux.x64-11.2.0.3.0.zip
should yield
Quote:
-rw-rw-r-- 1 root portage 60331694 Mar 23 23:53 /usr/portage/distfiles/instantclient-basic-linux.x64-11.2.0.3.0.zip
with variation in date, similar for the other files
_________________
Defund the FCC.
Back to top
View user's profile Send private message
jls7884
n00b
n00b


Joined: 14 Mar 2014
Posts: 21

PostPosted: Mon Mar 24, 2014 3:08 pm    Post subject: Reply with quote

Code:
(chroot) jacob-VGN-TZ150N init.d # ls -l /usr/portage/distfiles/instantclient-basic-linux-11.2.0.3.0.zip


Output:
Quote:
-rw------- 1 root root 58502865 Mar 23 20:37 /usr/portage/distfiles/instantclient-basic-linux-11.2.0.3.0.zip


Not sure what I need to do here:

Quote:
check that net.lo is in boot runlevel, net.wlp3so is in default run level, dhcpcd and wpa_supplicant are not in any run level. correct if necessary.


Code:
(chroot) jacob-VGN-TZ150N init.d # rc-update show


Yields:

Quote:

bootmisc | boot
devfs | sysinit
dmesg | sysinit
fsck | boot
hostname | boot
hwclock | boot
keymaps | boot
killprocs | shutdown
local | default
localmount | boot
loopback | boot
modules | boot
mount-ro | shutdown
mtab | boot
netmount | default
procfs | boot
root | boot
savecache | shutdown
swap | boot
swapfiles | boot
sysctl | boot
sysfs | sysinit
termencoding | boot
tmpfiles.dev | sysinit
tmpfiles.setup | boot
udev | sysinit
udev-mount | sysinit
urandom | boot
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Mon Mar 24, 2014 5:24 pm    Post subject: Reply with quote

from the chroot:
Code:
chown portage /usr/portage/distfiles/instantclient-basic-linux-11.2.0.3.0.zip
chgrp portage /usr/portage/distfiles/instantclient-basic-linux-11.2.0.3.0.zip
chmod 664 /usr/portage/distfiles/instantclient-basic-linux-11.2.0.3.0.zip


chown portage /usr/portage/distfiles/instantclient-sdk-linux.x64-11.2.0.3.0.zip
chgrp portage /usr/portage/distfiles/instantclient-sdk-linux.x64-11.2.0.3.0.zip
chmod 664 /usr/portage/distfiles/instantclient-sdk-linux.x64-11.2.0.3.0.zip
and repeat the emerge; good catch kurly
If the output of
Code:
grep -i init=/usr  /usr/src/linux/.config
includes
Quote:
init=/usr/lib/systemd/systemd
you and your kernel intend to run systemd. That will take us in a direction that does not require
Code:
rc-update add net.w3lps0 default
however running
Code:
rc-update add net.w3lps0 default
should be harmless to systemd and necessary in openrc. you do not have dhcpcd, dhcp, or wpa_supplicant in any run level which is good.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
jls7884
n00b
n00b


Joined: 14 Mar 2014
Posts: 21

PostPosted: Tue Mar 25, 2014 12:35 am    Post subject: Reply with quote

I now get this:

Quote:


Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 7) dev-qt/qtcore-4.8.5-r1
* qt-everywhere-opensource-src-4.8.5.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ... [ ok ]
>>> Unpacking source...
* Unpacking parts of qt-everywhere-opensource-src-4.8.5.tar.gz: configure LICENSE.GPL3 LICENSE.LGPL projects.pro src/qbase.pri src/qt_targets.pri src/qt_install.pri bin config.tests mkspecs qmake src/tools/bootstrap src/tools/moc src/tools/rcc src/tools/uic src/corelib src/xml src/network src/plugins/codecs tools/linguist/lconvert tools/linguist/lrelease tools/linguist/lupdate include src/plugins/plugins.pro src/plugins/qpluginbase.pri src/src.pro src/3rdparty/des src/3rdparty/harfbuzz src/3rdparty/md4 src/3rdparty/md5 src/3rdparty/sha1 src/3rdparty/easing src/3rdparty/zlib_dependency.pri src/declarative src/gui src/script tools/shared tools/linguist/shared translations ... [ ok ]
>>> Source unpacked in /var/tmp/portage/dev-qt/qtcore-4.8.5-r1/work
>>> Preparing source in /var/tmp/portage/dev-qt/qtcore-4.8.5-r1/work/qt-everywhere-opensource-src-4.8.5 ...
* Applying moc-boost-lexical-cast.patch ... [ ok ]
* Applying CVE-2013-4549-01-disallow-deep-or-widely-nested-entity-refs.patch ... [ ok ]
* Applying CVE-2013-4549-02-fully-expand-entities.patch ... [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-qt/qtcore-4.8.5-r1/work/qt-everywhere-opensource-src-4.8.5 ...
./configure -prefix /usr -bindir /usr/bin -libdir /usr/lib64/qt4 -docdir /usr/share/doc/qt-4.8.5 -headerdir /usr/include/qt4 -plugindir /usr/lib64/qt4/plugins -importdir /usr/lib64/qt4/imports -datadir /usr/share/qt4 -translationdir /usr/share/qt4/translations -sysconfdir /etc/qt4 -examplesdir /usr/share/qt4/examples -demosdir /usr/share/qt4/demos -opensource -confirm-license -shared -fast -largefile -stl -verbose -nomake examples -nomake demos -arch x86_64 -platform linux-g++ -L/usr/lib64 -debug -no-separate-debug-info -exceptions -no-rpath -no-pch -reduce-relocations -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -lgthread-2.0 -lglib-2.0 -I/usr/include/freetype2 -no-accessibility -no-xmlpatterns -no-multimedia -no-audio-backend -no-phonon -no-phonon-backend -no-svg -no-webkit -no-script -no-scripttools -no-declarative -system-zlib -no-gif -no-libtiff -no-libpng -no-libmng -no-libjpeg -no-cups -no-dbus -no-gtkstyle -no-nas-sound -no-opengl -no-openvg -no-sm -no-xshape -no-xvideo -no-xsync -no-xinerama -no-xcursor -no-xfixes -no-xrandr -no-xrender -no-mitshm -no-fontconfig -no-freetype -no-xinput -no-xkb -glib -iconv -no-icu -openssl-linked -qt3support
Determining system architecture... (Linux:3.11.0-12-generic:x86_64)
64-bit AMD 80x86 (x86_64)
'x86_64' is supported
System architecture: 'x86_64'
gcc-config: error: could not run/locate 'x86_64-pc-linux-gnu-g++'
Symbol visibility control disabled.
Symbolic function binding disabled.

This is the Open Source Edition.

You are licensed to use this software under the terms of
the Lesser GNU General Public License (LGPL) versions 2.1.
You are also licensed to use this software under the terms of
the GNU General Public License (GPL) versions 3.

You have already accepted the terms of the license.

Creating qmake. Please wait...
x86_64-pc-linux-gnu-g++ -c -o project.o -O2 -pipe -pipe -DQMAKE_OPENSOURCE_EDITION -g -I. -Igenerators -Igenerators/unix -Igenerators/win32 -Igenerators/mac -Igenerators/symbian -Igenerators/integrity -I/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/work/qt-everywhere-opensource-src-4.8.5/include -I/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/work/qt-everywhere-opensource-src-4.8.5/include/QtCore -I/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/work/qt-everywhere-opensource-src-4.8.5/src/corelib/global -I/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/work/qt-everywhere-opensource-src-4.8.5/src/corelib/xml -I/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/work/qt-everywhere-opensource-src-4.8.5/tools/shared -DQT_NO_PCRE -DQT_BUILD_QMAKE -DQT_BOOTSTRAPPED -DQLIBRARYINFO_EPOCROOT -DQT_NO_TEXTCODEC -DQT_NO_UNICODETABLES -DQT_NO_COMPONENT -DQT_NO_STL -DQT_NO_COMPRESS -I/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/work/qt-everywhere-opensource-src-4.8.5/mkspecs/linux-g++ -DHAVE_QCONFIG_CPP -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VARIANT -DQT_NO_DEPRECATED project.cpp
gcc-config: error: could not run/locate 'x86_64-pc-linux-gnu-g++'
gmake: *** [project.o] Error 1
* ERROR: dev-qt/qtcore-4.8.5-r1::gentoo failed (configure phase):
* ./configure failed
*
* Call stack:
* ebuild.sh, line 93: Called src_configure
* environment, line 2898: Called qt4-build_src_configure
* environment, line 2547: Called die
* The specific snippet of code:
* ./configure ${conf} || die "./configure failed";
*
* If you need support, post the output of `emerge --info '=dev-qt/qtcore-4.8.5-r1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=dev-qt/qtcore-4.8.5-r1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/temp/environment'.
* Working directory: '/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/work/qt-everywhere-opensource-src-4.8.5'
* S: '/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/work/qt-everywhere-opensource-src-4.8.5'

>>> Failed to emerge dev-qt/qtcore-4.8.5-r1, Log file:

>>> '/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/temp/build.log'

* Messages for package dev-qt/qtcore-4.8.5-r1:

* ERROR: dev-qt/qtcore-4.8.5-r1::gentoo failed (configure phase):
* ./configure failed
*
* Call stack:
* ebuild.sh, line 93: Called src_configure
* environment, line 2898: Called qt4-build_src_configure
* environment, line 2547: Called die
* The specific snippet of code:
* ./configure ${conf} || die "./configure failed";
*
* If you need support, post the output of `emerge --info '=dev-qt/qtcore-4.8.5-r1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=dev-qt/qtcore-4.8.5-r1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/temp/environment'.
* Working directory: '/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/work/qt-everywhere-opensource-src-4.8.5'
* S: '/var/tmp/portage/dev-qt/qtcore-4.8.5-r1/work/qt-everywhere-opensource-src-4.8.5'

Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Tue Mar 25, 2014 1:49 am    Post subject: Reply with quote

in the chroot: does the output of
Code:
ls -l /usr/bin/x86_64-pc-linux-gnu-g++
resemble
Quote:
-rwxr-xr-x 1 root root 10424 Mar 6 02:17 /usr/bin/x86_64-pc-linux-gnu-g++

does
Code:
gcc-config -l
produce
Quote:
[1] x86_64-pc-linux-gnu-4.8.2 *

does
Code:
equery list gcc
produce
Quote:
sys-devel/gcc-4.8.2:4.8

Code:
equery check gcc
produces ??
_________________
Defund the FCC.
Back to top
View user's profile Send private message
jls7884
n00b
n00b


Joined: 14 Mar 2014
Posts: 21

PostPosted: Tue Mar 25, 2014 4:13 pm    Post subject: Reply with quote

Code:
ls -l /usr/bin/x86_64-pc-linux-gnu-g++


Produces the same output

Code:
gcc-config -l


Produces version 4.7.3.

equery command not found.
Back to top
View user's profile Send private message
TomWij
Retired Dev
Retired Dev


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Tue Mar 25, 2014 6:49 pm    Post subject: Reply with quote

jls7884 wrote:
equery command not found.


You can obtain it by executing `emerge app-portage/gentoolkit`
Back to top
View user's profile Send private message
jls7884
n00b
n00b


Joined: 14 Mar 2014
Posts: 21

PostPosted: Wed Mar 26, 2014 3:22 am    Post subject: Reply with quote

Code:
equery list gcc


Returns:

Quote:
[IP-] [ ] sys-devel/gcc-4.7.3-r1:4.7


Code:
equery check gcc


Returns:

Quote:

!!! /etc/env.d/gcc/x86_64-PC-linux-gnu-4.7.3 has incorrect MD5sum
* Checking sys-devel/gcc-4.7.3-r1 ...
442 out of 443 files passed
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Wed Mar 26, 2014 7:09 pm    Post subject: Reply with quote

Not making sense to me. Usually if gcc or gcc-config are failing nothing emerges
Code:
emerge python python-updater
eselect python list
eselect python set python2.7 # if not set already to 2.7
# if it was set to 2.7 already set it to 3.3
env-update
source /etc/profile
python-updater
emerge gcc gcc-config
gcc-config -l # asterisk at 4.7.3??
env-update
source /etc/profile
emerge libtool
emerge -1 qtcore

I have the same file with an md5sum error as you and qtcore emerges no problems so that is likely not relevant.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
jls7884
n00b
n00b


Joined: 14 Mar 2014
Posts: 21

PostPosted: Wed Mar 26, 2014 7:21 pm    Post subject: Reply with quote

For:
Code:
emerge python python-updater

I get broken sem_open function (bug 496328)
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Wed Mar 26, 2014 7:28 pm    Post subject: Reply with quote

you should be able to read it at https://bugs.gentoo.org/show_bug.cgi?id=496328
_________________
Defund the FCC.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Wed Mar 26, 2014 8:11 pm    Post subject: Reply with quote

Code:
mount
from chroot, output should include tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev) . Should have received /dev/shm from the line " mount --rbind /dev /mnt/gentoo/dev " unless ubuntu is doing something differently or some typo intervenes occasionally.
Code:
mount
from ubuntu, output should include tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev) also. If not you may need to use sysresccd.

short form for chroot, nominal:
Code:
mount /dev/sda3 /mnt/gentoo
mount /dev/sda1 /mnt/gentoo/boot
mount -t proc none /mnt/gentoo/proc
mount --rbind /sys /mnt/gentoo/sys
mount --rbind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash
source /etc/profile
export PS1="(chroot) $PS1"


graceful exit:

Code:
exit
cd
umount -l /mnt/gentoo/dev{/shm,/pts,}
umount -l /mnt/gentoo{/boot,/proc,}
reboot

_________________
Defund the FCC.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Wed Mar 26, 2014 8:38 pm    Post subject: Reply with quote

If nothing has worked:

Code:
ls -ld /dev/shm


If the permissions are not 1777 ... then as a temporary work around, you can just

Code:
chmod 1777 /dev/shm


and then the 'emerge python' should work.

quoting last line of bug
_________________
Defund the FCC.
Back to top
View user's profile Send private message
dr_vic
n00b
n00b


Joined: 04 Apr 2014
Posts: 14

PostPosted: Fri Apr 04, 2014 10:11 pm    Post subject: Re: Wireless networking with wpa2 Reply with quote

jls7884 wrote:
...My /etc/conf.d/net is written:
...wpa_supplicant_wl3ps0="-Dwext"...

...ifconfig returns enp2s0, lo, and wlp3s0...


Maybe I am wrong but wl3ps0 and wlp3s0 are not the same.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Fri Apr 04, 2014 11:08 pm    Post subject: Reply with quote

very right, good eye dr_vlc
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum