Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Atheros AR9227 driver crashing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
KintaroBC
n00b
n00b


Joined: 15 Feb 2014
Posts: 54
Location: Australia

PostPosted: Sat Mar 15, 2014 3:48 pm    Post subject: Atheros AR9227 driver crashing Reply with quote

I am trying to get a PCI Atheros AR9227 adapter to work. I've built the ath9k kernel module and loaded it, but it doesn't show up in ifconfig or iwconfig. In the dmesg output it seems to crash.

Here is it's entry from lspci -v
Code:

01:08.0 Network controller: Qualcomm Atheros AR9227 Wireless Network Adapter (rev 01)
        Subsystem: Qualcomm Atheros Device 0301
        Flags: 66MHz, medium devsel, IRQ 17
        Memory at fcff0000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2
        Kernel modules: ath9k


I noticed this in the dmesg output...

Code:

   6.212086] ------------[ cut here ]------------
[    6.212116] WARNING: CPU: 0 PID: 958 at net/mac80211/main.c:506 ieee80211_alloc_hw+0x5b/0x580()
[    6.212121] Modules linked in: ath9k(+) ath9k_common ath9k_hw ath
[    6.212141] CPU: 0 PID: 958 Comm: udevd Not tainted 3.11.7-hardened-r1-kabwall #3
[    6.212148] Hardware name: Dell Computer Corporation OptiPlex GX150               /OptiPlex GX150               , BIOS A06 06/26/2001
[    6.212153]  00000000 00000000 de05bb94 007adebf 00000000 de05bbc4 0004143f c1d70a00
[    6.212166]  00000000 000003be c1e0d37b 000001fa 0075a6ab 0075a6ab 008419c0 00842820
[    6.212178]  00843f40 de05bbd4 0004147b 00000009 00000000 de05bbf0 0075a6ab c185d58e
[    6.212190] Call Trace:
[    6.212209]  [<007adebf>] dump_stack+0x41/0x52
[    6.212222]  [<0004143f>] warn_slowpath_common+0x7f/0xa0
[    6.212231]  [<0075a6ab>] ? ieee80211_alloc_hw+0x5b/0x580
[    6.212239]  [<0075a6ab>] ? ieee80211_alloc_hw+0x5b/0x580
[    6.212299]  [<008419c0>] ? ath9k_sta_notify+0x50/0x50 [ath9k]
[    6.212320]  [<00842820>] ? ath9k_set_key+0x190/0x190 [ath9k]
[    6.212340]  [<00843f40>] ? ath9k_calculate_summary_state+0x140/0x140 [ath9k]
[    6.212348]  [<0004147b>] warn_slowpath_null+0x1b/0x20
[    6.212357]  [<0075a6ab>] ieee80211_alloc_hw+0x5b/0x580
[    6.212384]  [<0084f35a>] ath_pci_probe+0xea/0x300 [ath9k]
[    6.212403]  [<001964c5>] ? sysfs_addrm_finish+0x15/0xd0
[    6.212412]  [<001961cc>] ? sysfs_new_dirent+0x7c/0x110
[    6.212422]  [<00008080>] ? setup_data_read+0x250/0x350
[    6.212432]  [<00196ffe>] ? sysfs_do_create_link_sd+0xce/0x1d0
[    6.212443]  [<00067236>] ? __blocking_notifier_call_chain+0x46/0x70
[    6.212453]  [<0030d51e>] ? pci_match_device+0x9e/0xb0
[    6.212460]  [<0030d5c7>] pci_device_probe+0x67/0x90
[    6.212476]  [<00423a15>] driver_probe_device+0x65/0x200
[    6.212484]  [<0030d51e>] ? pci_match_device+0x9e/0xb0
[    6.212492]  [<00423c39>] __driver_attach+0x89/0x90
[    6.212500]  [<00423bb0>] ? driver_probe_device+0x200/0x200
[    6.212509]  [<00422212>] bus_for_each_dev+0x42/0x80
[    6.212517]  [<00423549>] driver_attach+0x19/0x20
[    6.212525]  [<00423bb0>] ? driver_probe_device+0x200/0x200
[    6.212533]  [<00423214>] bus_add_driver+0xd4/0x220
[    6.212554]  [<0030c410>] ? store_remove_id+0x140/0x140
[    6.212563]  [<004241b5>] driver_register+0x65/0x160
[    6.212578]  [<002f9f7a>] ? __list_add+0x1a/0x40
[    6.212587]  [<0030c89e>] __pci_register_driver+0x2e/0x40
[    6.212594]  [<00863000>] ? 0x862fff
[    6.212616]  [<0084f707>] ath_pci_init+0x17/0x20 [ath9k]
[    6.212635]  [<00863059>] ath9k_init+0x59/0xc0ff5940 [ath9k]
[    6.212649]  [<000c5465>] ? tracepoint_module_notify+0xc5/0x180
[    6.212656]  [<00863000>] ? 0x862fff
[    6.212665]  [<000014c2>] mce_timer+0x2/0x20
[    6.212673]  [<00067236>] ? __blocking_notifier_call_chain+0x46/0x70
[    6.212689]  [<0009f949>] load_module+0x1f99/0x2490
[    6.212700]  [<00002d00>] ? do_signal+0x410/0x710
[    6.212711]  [<000603f7>] ? __lock_timer+0x57/0xb0
[    6.212743]  [<00800004>] ? ath9k_exit+0xca6c/0xc103a0c7 [ath9k_hw]
[    6.212752]  [<000a00b8>] SyS_finit_module+0x68/0x80
[    6.212767]  [<0002e294>] ? setup_local_APIC+0x324/0x470
[    6.212779]  [<00020a18>] ? uncore_pci_probe+0x8/0x160
[    6.212789]  [<00021bd8>] ? quirk_sandybridge_ifu+0x48/0x80
[    6.212802]  [<007b7d84>] syscall_call+0x7/0xb
[    6.212812]  [<0002007b>] ? uncore_pmu_event_add+0xcb/0x3c0
[    6.212822]  [<007b7d9f>] ? restore_all_pax+0x7/0x7
[    6.212830] ---[ end trace 122740e4a6d03af6 ]---
[    6.212840] ath9k 0000:01:08.0: No memory for ieee80211_hw
[    6.215623] ath9k: probe of 0000:01:08.0 failed with error -12
Back to top
View user's profile Send private message
KintaroBC
n00b
n00b


Joined: 15 Feb 2014
Posts: 54
Location: Australia

PostPosted: Sat Mar 15, 2014 8:40 pm    Post subject: Reply with quote

Building a new kernel fixed the problem, the modules and binary image must have been out of sync.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum