Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Black Screen on Boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Atomic Beef
n00b
n00b


Joined: 17 Mar 2014
Posts: 37

PostPosted: Mon Mar 17, 2014 11:46 pm    Post subject: Black Screen on Boot Reply with quote

Hello everyone! This is my first post to the Gentoo community, and I'm really looking forward to finally setting up my first Gentoo system. Anyways, the problem that I'm having is that I just installed Gentoo and when I try to boot into Gentoo through GRUB, I get a couple of seconds of the boot up screen and then black. It happens right at the point where the live CD would change to the proper resolution, so I suspect that it's something to do with Framebuffer. I'm running a Radeon HD 7970 as a GPU and I built the Radeon kernel driver as a module, set it to be loaded on boot, and then enabled support for VESA and Framebuffer. I would post my kernel config, but I have no idea where it's stored :(
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13831

PostPosted: Tue Mar 18, 2014 2:09 am    Post subject: Reply with quote

Is the screen displaying all black pixels or is it in powersave mode? A common mistake for new users is to enable KMS, exclude a framebuffer, and not start X11. When neither the framebuffer nor X11 is running, the system produces no video signal, so the monitor switches to powersave mode.
Back to top
View user's profile Send private message
kurisu
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2011
Posts: 147
Location: Munich, Germany

PostPosted: Tue Mar 18, 2014 7:28 pm    Post subject: Reply with quote

Linux 3.13 has introduced issues like that for several ATI GPUs when using xf86-video-ati. That is related to dpm (Dynamic Power Management). See kernel.bugzilla.org. Falling back to kernel 3.12 or 3.11 should fix it for now.

Your kernel config is located here:

Code:
/usr/src/linux/.config


In case you want to make it public for us, simply do:

Code:
emerge wgetpaste && wgetpaste /usr/src/linux/.config


within a root shell and post the URL here.
Back to top
View user's profile Send private message
Atomic Beef
n00b
n00b


Joined: 17 Mar 2014
Posts: 37

PostPosted: Tue Mar 18, 2014 11:42 pm    Post subject: Reply with quote

Hu wrote:
Is the screen displaying all black pixels or is it in powersave mode? A common mistake for new users is to enable KMS, exclude a framebuffer, and not start X11. When neither the framebuffer nor X11 is running, the system produces no video signal, so the monitor switches to powersave mode.


Hi Hu, thanks for the reply, but I don't think you understand where I am in the install process (either that or I wasn't clear enough.) I have just got passed the part in the handbook where you finished installing the bootloader, unmounted all partitions, and rebooted. I can't see what's on my screen if I try to boot into the freshly installed system, as the screen doesn't detect any video input after a couple of seconds.

kurisu wrote:
Linux 3.13 has introduced issues like that for several ATI GPUs when using xf86-video-ati. That is related to dpm (Dynamic Power Management). See kernel.bugzilla.org. Falling back to kernel 3.12 or 3.11 should fix it for now.

Your kernel config is located here:

Code:
/usr/src/linux/.config


In case you want to make it public for us, simply do:

Code:
emerge wgetpaste && wgetpaste /usr/src/linux/.config


within a root shell and post the URL here.


Thanks for the reply kurisu! I decided to go for a fresh install because I messed up a bunch of files on my original Gentoo install when I was trying to fix my problem. What options should I include in the kernel so I don't get a black screen on bootup?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13831

PostPosted: Wed Mar 19, 2014 1:40 am    Post subject: Reply with quote

Atomic Beef wrote:
Hi Hu, thanks for the reply, but I don't think you understand where I am in the install process (either that or I wasn't clear enough.) I have just got passed the part in the handbook where you finished installing the bootloader, unmounted all partitions, and rebooted. I can't see what's on my screen if I try to boot into the freshly installed system, as the screen doesn't detect any video input after a couple of seconds.
I understood exactly where you are, and your follow up answered my question. Your monitor is in powersave mode, which is distinct from a monitor showing a picture of all black pixels.

As I said in my prior post, if you include the KMS driver, you must either start X or include a framebuffer for your device. Set CONFIG_FB=y to start. According to Documentation/fb/fbcon.txt, you should also set CONFIG_FRAMEBUFFER_CONSOLE=y.
Back to top
View user's profile Send private message
GOS
Tux's lil' helper
Tux's lil' helper


Joined: 09 Sep 2010
Posts: 93
Location: Germany

PostPosted: Wed Mar 19, 2014 8:45 am    Post subject: Reply with quote

It seems to me that setting up the OpenSource Ati-Driver included in the kernel in not a good (stable) way for your setup.

You should try to set up the proprietary Ati-drivers (x11-drivers/ati-drivers) for X. These drivers has no framebuffer support, what is what you want, because obviously the OpenSource ati-framebuffer (included in kernel) doesn't work proper. You can then overcome the missing framebuffer by using uvesafb. There is an installation instruction avaible for it: http://wiki.gentoo.org/wiki/Uvesafb

This is analogue to the possibilities for an nvidia-card
1) Use nouveau (OpenSource)
2) Use nvidia-drivers (proprietary) + uvesafb.

Both methods has advantages and disadvantages but in your case the thing seems clear.

Instead of uvesafb it is also possible to use vesafb. But in case that you use UEFI vesafb doesn't work anymore. Therefore I switched to uvesafb. Uvesafb seems to be the successor of vesafb.

Best regards GOS

PS: Don't forget to reinstall kernel-dependend packages (especially ati-drivers) if you reinstall the kernel.
PPS: Use the newest Ati-drivers with ~amd64/~x86 keyword
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5365

PostPosted: Wed Mar 19, 2014 9:06 am    Post subject: Reply with quote

take a look on this bug
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
kurisu
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2011
Posts: 147
Location: Munich, Germany

PostPosted: Wed Mar 19, 2014 2:12 pm    Post subject: Reply with quote

The open-source radeon driver is stable enough; actually more stable than fglrx. You should only use the latter one if you need maximum 3D support. To workaround the dpm related bug, you have to (1) compile
Code:
CONFIG_DRM_RADEON
as module and (2) add
Code:
radeon.dpm=0
to the kernel command line.
Back to top
View user's profile Send private message
Atomic Beef
n00b
n00b


Joined: 17 Mar 2014
Posts: 37

PostPosted: Wed Mar 19, 2014 6:57 pm    Post subject: Reply with quote

Thanks for all the replies! So after looking through all of these great posts, I came up with quite a few questions. The first one is probably the most important of them all. To successfully use uvesafb, do I have to disable "Radeon" in the kernel config? I thought I had to have that enabled so I could use my 7970, even if I was using proprietary drivers (my original intention.) Secondly, is there a special way I should reinstall the kernel after I follow the uvesafb guide on the wiki? I'm new to messing with the kernel, so I don't know much about how I should reinstall. Thirdly, how should I set my system to be ~amd64? I know it's somewhere in /etc/portage/make.conf, but I'm uncertain as to whether I should change amd64 to ~amd64 or add another keyword. Sorry if these sound like stupid questions, and once again I would like to thank all of you for your posts to this thread. It really has helped me a lot so far, and I'm thankful that all of you took the time out of your day to answer a newb's questions :)
Back to top
View user's profile Send private message
Maitreya
Guru
Guru


Joined: 11 Jan 2006
Posts: 420

PostPosted: Wed Mar 19, 2014 7:03 pm    Post subject: Reply with quote

If your screen pop ups after a long time and your monitor has gone into powersave it just might take a long time to load a firmware.
Back to top
View user's profile Send private message
Atomic Beef
n00b
n00b


Joined: 17 Mar 2014
Posts: 37

PostPosted: Wed Mar 19, 2014 7:09 pm    Post subject: Reply with quote

Maitreya wrote:
If your screen pop ups after a long time and your monitor has gone into powersave it just might take a long time to load a firmware.


I don't think it could be that. I left my PC on for 10 minutes after the blank screen to make sure that it wasn't taking a long time to load and it just stayed blank.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13831

PostPosted: Thu Mar 20, 2014 1:53 am    Post subject: Reply with quote

GOS wrote:
It seems to me that setting up the OpenSource Ati-Driver included in the kernel in not a good (stable) way for your setup.

You should try to set up the proprietary Ati-drivers (x11-drivers/ati-drivers) for X. These drivers has no framebuffer support, what is what you want, because obviously the OpenSource ati-framebuffer (included in kernel) doesn't work proper.
Citation needed. OP has provided no evidence that this is anything more than a kernel configuration mistake. Many users have made the same set of mistakes and readily obtained a working system by correcting the mistake, rather than throwing out the whole stack.

Atomic Beef wrote:
The first one is probably the most important of them all. To successfully use uvesafb, do I have to disable "Radeon" in the kernel config?
There is no need to use uvesafb. The kernel's framebuffer console works fine with the open Radeon driver.
Atomic Beef wrote:
Thirdly, how should I set my system to be ~amd64?
In my opinion, if you have to ask, you are not ready to act on the answer. Running the testing branch (~arch) can be more involved than running the stable branch (arch). You may encounter broken packages more frequently, and you will by definition receive upstream packages with less testing than if you remain in the stable branch. I strongly suggest you not switch the whole system to testing unless you are certain that you want to deal with the complexities and that you are willing to undertake the substantial effort if you decide to undo this later. If you asked this in response to the advice from GOS, you are better off using /etc/portage/package.accept_keywords to switch to testing for the specific packages you want. If you really want to switch the whole system, set ACCEPT_KEYWORDS="amd64 ~amd64" in /etc/portage/make.conf. Again, I suggest you not do that at this time, as it is overkill for your stated needs.
Back to top
View user's profile Send private message
kurisu
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2011
Posts: 147
Location: Munich, Germany

PostPosted: Thu Mar 20, 2014 2:21 am    Post subject: Reply with quote

Hu wrote:
GOS wrote:
It seems to me that setting up the OpenSource Ati-Driver included in the kernel in not a good (stable) way for your setup.

You should try to set up the proprietary Ati-drivers (x11-drivers/ati-drivers) for X. These drivers has no framebuffer support, what is what you want, because obviously the OpenSource ati-framebuffer (included in kernel) doesn't work proper.
Citation needed. OP has provided no evidence that this is anything more than a kernel configuration mistake. Many users have made the same set of mistakes and readily obtained a working system by correcting the mistake, rather than throwing out the whole stack.

Atomic Beef wrote:
The first one is probably the most important of them all. To successfully use uvesafb, do I have to disable "Radeon" in the kernel config?
There is no need to use uvesafb. The kernel's framebuffer console works fine with the open Radeon driver.
Atomic Beef wrote:
Thirdly, how should I set my system to be ~amd64?
In my opinion, if you have to ask, you are not ready to act on the answer. Running the testing branch (~arch) can be more involved than running the stable branch (arch). You may encounter broken packages more frequently, and you will by definition receive upstream packages with less testing than if you remain in the stable branch. I strongly suggest you not switch the whole system to testing unless you are certain that you want to deal with the complexities and that you are willing to undertake the substantial effort if you decide to undo this later. If you asked this in response to the advice from GOS, you are better off using /etc/portage/package.accept_keywords to switch to testing for the specific packages you want. If you really want to switch the whole system, set ACCEPT_KEYWORDS="amd64 ~amd64" in /etc/portage/make.conf. Again, I suggest you not do that at this time, as it is overkill for your stated needs.


Full Ack. You are well advised to setup your kernel as mentioned previously.
Back to top
View user's profile Send private message
Atomic Beef
n00b
n00b


Joined: 17 Mar 2014
Posts: 37

PostPosted: Thu Mar 20, 2014 7:54 pm    Post subject: Reply with quote

Well, I finally figured it out. I didn't use the Radeon kernel driver and set up uvesafb, and lo and behold it worked! My only problem was that I tried doing a system wide update, and around the 100th package my computer randomly shut off. No damage seems to have been done, but everytime I try to update, my computer shuts down at the same point. If needed I'll post my /var/log, but I think that would be deviating from the point of this thread. In the end, I want to thank you guys for helping me out, as I obtained a lot of knowledge about Linux by just installing Gentoo. :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum