Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't seem to find a driver for my webcam.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Budoka
l33t
l33t


Joined: 03 Jun 2012
Posts: 683
Location: Tokyo, Japan

PostPosted: Tue Mar 18, 2014 8:29 am    Post subject: Can't seem to find a driver for my webcam. Reply with quote

I have never been able to get my webcam to work on my laptop and it wasn't enough of a problem for me to make it a priority but I find now that for work reasons I must get it fixed. I think I have isolated it to a driver problem but not sure so would appreciate any help available. I have been using the following wiki: http://www.gentoo-wiki.info/Webcam and http://tldp.org/HOWTO/Webcam-HOWTO/intro.html with no success.

I was able to discern that my webcam is a WebCam SC-13HDL11431N on Bus 001 Device 003: ID 2232:1018.

http://bpaste.net/show/190273/

It seems to be loaded when I boot the box up but nothing utilizing a webcam sees it. ie: Skype, guvcview.

Code:
# dmesg | less |grep -i webcam
[    3.217041] usb 1-1.4: Product: WebCam SC-13HDL11431N


I have checked everywhere for a driver but can't seem to find one for "SC-13HDL11431N" or "ID 2232:1018."

The Linux UVC Database doesn't list it as supported.
http://www.ideasonboard.org/uvc/#devices

Nor does http://linuxtv.org/wiki/index.php/Category:Drivers which is a site the wiki pointed to.

Google doesn't return any useful info and I don't see anything that is obvious to me in portage so am stumped.

Any ideas?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42860
Location: 56N 3W

PostPosted: Tue Mar 18, 2014 9:13 pm    Post subject: Reply with quote

Budoka,

Build UVC support as a module - what happens now?
Google suggests that its UVC compliant.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Budoka
l33t
l33t


Joined: 03 Jun 2012
Posts: 683
Location: Tokyo, Japan

PostPosted: Sat Aug 23, 2014 5:26 pm    Post subject: Reply with quote

NeddySeagoon wrote:
Budoka,

Build UVC support as a module - what happens now?
Google suggests that its UVC compliant.


Sorry for the long delay. I was forced to use a Windows box for the webcam because it became urgent. Anyway now I can deal with this again.

I enabled UVC as a module in my kernel. I seems to have activated my webcam. I say seems because if I use gtk uvc viewer my webcam is working. However no application that uses a webcam seems to work or see it. ie: Skype, Ekiga, etc.

I added the use for v4l and v4l2 thinking that might do it but no luck. Any ideas? Should I start a separate thread? Thanks
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Wed Sep 10, 2014 8:56 pm    Post subject: Reply with quote

Any news? I have the same webcam. I tried in ubuntu 14.04 and it works! But not in Gentoo :(

I try, in ubuntu, to see which module is loaded before starting skype, and the module is loaded after started skype with video test.

The (diff) module are:

Quote:

rndis_wlan
rndis_host
cdc-ether
usbnet
cdc_phonet
phonet
cdc_acm



Could be some of these modules needed to have the webcam working in skype? I'll try it
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42860
Location: 56N 3W

PostPosted: Wed Sep 10, 2014 9:00 pm    Post subject: Reply with quote

lordalbert,

Those are all netmork related modules.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Wed Sep 10, 2014 9:31 pm    Post subject: Reply with quote

i build UVC in kernel and now it works in skype!

Budoka, have you solved?
Back to top
View user's profile Send private message
Budoka
l33t
l33t


Joined: 03 Jun 2012
Posts: 683
Location: Tokyo, Japan

PostPosted: Sat Sep 13, 2014 2:05 am    Post subject: Reply with quote

No still no luck getting it to work in webcam aware applications. I built uvc as a module should I try building it in the kernel?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42860
Location: 56N 3W

PostPosted: Sat Sep 13, 2014 7:53 am    Post subject: Reply with quote

Budoka,

You need to make sure that the output of lsmod includes uvc, if not the module didn't load.
modprobe uvc and try again.

There should be no functional difference between modules and built in - provided the module is loaded.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum