Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]mount & fix your /dev/pts settings
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 223
Location: Italia

PostPosted: Sat Mar 22, 2014 5:05 pm    Post subject: [SOLVED]mount & fix your /dev/pts settings Reply with quote

Hi,
I have this problem emerging '-uaD wolrd'

Code:
>>> Installing (1 of 368) sys-libs/glibc-2.17
 * Defaulting /etc/host.conf:multi to on
 * In order to use glibc with USE=-suid, you must make sure that
 * you have devpts mounted at /dev/pts with the gid=5 option.
 * Openrc should do this for you, so you should check /etc/fstab
 * and make sure you do not have any invalid settings there.
 * ERROR: sys-libs/glibc-2.17::gentoo failed (preinst phase):
 *   mount & fix your /dev/pts settings
 *
 * Call stack:
 *           ebuild.sh, line   93:  Called pkg_preinst
 *         environment, line 2771:  Called eblit-run 'pkg_preinst'
 *         environment, line  940:  Called eblit-glibc-pkg_preinst
 *   pkg_preinst.eblit, line   57:  Called die
 * The specific snippet of code:
 *                      die "mount & fix your /dev/pts settings"
 *
 * If you need support, post the output of `emerge --info '=sys-libs/glibc-2.17::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/glibc-2.17::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-libs/glibc-2.17/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/glibc-2.17/temp/environment'.
 * Working directory: '/'
 * S: '/var/tmp/portage/sys-libs/glibc-2.17/work/glibc-2.17'
!!! FAILED preinst: 1


/dev/pts seems mounted:

Code:
 mount | grep pts
devpts on /dev/pts type devpts (rw,relatime,mode=600)


any suggestion? regards,
Maurizio


Last edited by pigreco on Mon Mar 31, 2014 7:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7130
Location: almost Mile High in the USA

PostPosted: Sat Mar 22, 2014 5:17 pm    Post subject: Reply with quote

What's in your /etc/fstab?


You can add gid=5 in your /etc/fstab options for /dev/pts and remount /dev/pts (or reboot)

Oddly enough I don't even have a /dev/pts line in my fstab...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43182
Location: 56N 3W

PostPosted: Sat Mar 22, 2014 7:12 pm    Post subject: Reply with quote

openrc mounts /dev/pts for you, no /ets/fstab entry reqiured.
If you do have a fstab entry, glibc won't install unless its correct.

Unless you are doing something odd, comment out the fstab entry.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 223
Location: Italia

PostPosted: Sun Mar 23, 2014 10:02 am    Post subject: Reply with quote

humm, I have some problem:
Code:
openrc mounts /dev/pts
-bash: openrc: command not found


but sys-apps/openrc is installed:

Code:
sys-apps/openrc
      Latest version available: 0.12.4
      Latest version installed: 0.12.4
      Size of files: 128 kB
      Homepage:      http://www.gentoo.org/proj/en/base/openrc/
      Description:   OpenRC manages the services, startup and shutdown of a host
      License:       BSD-2
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43182
Location: 56N 3W

PostPosted: Sun Mar 23, 2014 10:25 am    Post subject: Reply with quote

igreco,

openrc mounts /dev/pts as part of the boot sequence. You need do nothing.

To mount it from /etc/fstab the entry is
Code:
devpts               /dev/pts    devpts          rw,nosuid,noexec,relatime,gid=5,mode=620 0 0

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 223
Location: Italia

PostPosted: Sun Mar 23, 2014 1:08 pm    Post subject: Reply with quote

ok, and it is mounted,
so... why I can't emerge sys-libs/glibc-2.17 !!??
Back to top
View user's profile Send private message
jonathan183
Guru
Guru


Joined: 13 Dec 2011
Posts: 309

PostPosted: Sun Mar 23, 2014 1:22 pm    Post subject: Re: mount & fix your /dev/pts settings Reply with quote

pigreco wrote:
Code:
>>> Installing (1 of 368) sys-libs/glibc-2.17
 * Defaulting /etc/host.conf:multi to on
 * In order to use glibc with USE=-suid, you must make sure that
* you have devpts mounted at /dev/pts with the gid=5 option.


/dev/pts seems mounted:
Code:
 mount | grep pts
devpts on /dev/pts type devpts (rw,relatime,mode=600)


should have ...
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=600)

Check /etc/fstab has entry as indicated in NeddySeagoon's post above
Back to top
View user's profile Send private message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 223
Location: Italia

PostPosted: Sun Mar 23, 2014 3:53 pm    Post subject: Reply with quote

I have not /dev/pts entry in fstab
Back to top
View user's profile Send private message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 223
Location: Italia

PostPosted: Mon Mar 31, 2014 3:42 pm    Post subject: Reply with quote

I apologize for the delay in response, what I do not understand is if I absolutely need a reboot to solve the problem


regards,
Maurizio
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5761

PostPosted: Mon Mar 31, 2014 4:22 pm    Post subject: Reply with quote

No need to reboot, $(mount -o remount,gid=5 /dev/pts) should fix it.
Back to top
View user's profile Send private message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 223
Location: Italia

PostPosted: Mon Mar 31, 2014 7:07 pm    Post subject: Reply with quote

Great!!! Greta!!!
Thank you very much!!!!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum