Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Qemu und USB-Passthrough – Fehler beim Ausschalten
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2328
Location: Konradsreuth (Germany)

PostPosted: Fri Mar 28, 2014 7:24 pm    Post subject: Qemu und USB-Passthrough – Fehler beim Ausschalten Reply with quote

Hallo :-)

Ich habe einen mit Qemu virtualisierten Windows-2003-Server laufen. Zwei USB-Geräte reiche ich mittels
Code:
-usbdevice host:1234:1234

beim Starten an die virtuelle Maschine weiter. Die läuft 24/7, die USB-Geräte aber nicht (sind beides Lesegeräte für Chipkarten).

Wenn ich jetzt das Gerät ausschalte oder abstecke, dann sagt der Qemu-Monitor sowas wie
Code:
libusb_release_interface: -4 [NO_DEVICE]
libusb: error [_open_sysfs_attr] open /sys/bus/usb/devices/3-9/bConfigurationValue failed ret=-1 errno=2

aber es funktioniert alles. Wenn ich das Gerät wieder einschalte, dann geht es auch wieder.

Dass das Gerät nicht mehr an den Host „zurückgegeben“ werden kann ist klar, schließlich ist es ja ausgeschaltet. Liegt das jetzt einfach daran, oder mache ich was falsch? Kann man diese Fehler einfach ignorieren? Oder kann ich irgendwas machen, damit das nicht passiert beim Ausschalten des USB-Geräts?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum