Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Slot conflict? Am I in deep doodo [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
aschueler
Tux's lil' helper
Tux's lil' helper


Joined: 09 Apr 2004
Posts: 119

PostPosted: Sun Mar 30, 2014 7:16 pm    Post subject: Slot conflict? Am I in deep doodo [solved] Reply with quote

This is a new one for me, it seems that the answer should be easy but I am confused. Here is the output when I tried to install ati drivers:

Code:

# emerge ati-drivers
Calculating dependencies... done!
[ebuild  N     ] app-emulation/emul-linux-x86-baselibs-20131008-r6  USE="development" ABI_X86="(-32)"
[ebuild  N     ] app-admin/eselect-opencl-1.1.0-r1
[ebuild  N     ] sys-power/acpid-2.0.20  USE="(-selinux)"
[ebuild  N     ] virtual/linux-sources-0
[ebuild     UD ] x11-base/xorg-server-1.14.5 [1.15.0]
[ebuild  N     ] app-emulation/emul-linux-x86-xlibs-20131008  USE="(development) opengl" ABI_X86="(-32)"
[ebuild  N     ] app-emulation/emul-linux-x86-opengl-20131008  USE="development" ABI_X86="(-32)"
[ebuild  N     ] x11-drivers/ati-drivers-13.12  USE="modules multilib qt4 -debug -pax_kernel -static-libs"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.14.5::gentoo, ebuild scheduled for merge) pulled in by
    <=x11-base/xorg-server-1.14.49[-minimal] required by (x11-drivers/ati-drivers-13.12::gentoo, ebuild scheduled for merge)

  (x11-base/xorg-server-1.15.0::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.15.0= required by (x11-libs/glamor-0.6.0::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-mouse-1.9.0::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-openchrome-0.3.3::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-evdev-2.8.2::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-vmware-13.0.1-r1::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-trident-1.3.6-r2::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-fbdev-0.4.4::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-ati-7.3.0::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-keyboard-1.7.0::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-nv-2.1.20-r1::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-tdfx-1.4.5-r1::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-intel-2.21.15::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-vesa-2.3.3::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-nouveau-1.0.10::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-dummy-0.3.7::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-glint-1.2.8-r1::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



It seems that my x11-base/xorg-server-1.14.5::gentoo is newer than the one that ati-drivers wants, and doesn't seem to want the newer version, or am I wrong?

Any ideas?


Last edited by aschueler on Thu Apr 03, 2014 12:15 am; edited 2 times in total
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13848

PostPosted: Sun Mar 30, 2014 8:27 pm    Post subject: Reply with quote

That is correct. Why are you installing ati-drivers explicitly? Do you really need all those other video drivers installed?
Back to top
View user's profile Send private message
aschueler
Tux's lil' helper
Tux's lil' helper


Joined: 09 Apr 2004
Posts: 119

PostPosted: Sun Mar 30, 2014 8:54 pm    Post subject: Reply with quote

The other drivers seem to have installed with KDE, I didn't do it myself.

I do indeed need ati-driver, I have a radeon HD 7870 video card and I want to use it.

I cannot emerge the ati drivers at this point.
Back to top
View user's profile Send private message
aschueler
Tux's lil' helper
Tux's lil' helper


Joined: 09 Apr 2004
Posts: 119

PostPosted: Sun Mar 30, 2014 10:36 pm    Post subject: Now I am really worried Reply with quote

I just tried to update world, and I am clearly missing a big picture item. If any of this makes sense please explain what is going on:

Code:
# emerge --update --deep --with-bdeps=y --newuse @world
Calculating dependencies... done!
[ebuild  N     ] dev-libs/libx86-1.1-r3  USE="-static-libs"
[ebuild     U ~] dev-libs/icu-52.1 [51.2-r1] ABI_X86="(64%*) -32% -x32%"
[ebuild  N     ] dev-libs/libnatspec-0.2.6  USE="-doc -python"
[ebuild   R    ] app-arch/unzip-6.0-r3  USE="natspec*"
[ebuild   R    ] dev-libs/boost-1.52.0-r6  USE="icu*"
[ebuild   R    ] x11-libs/libdrm-2.4.52  VIDEO_CARDS="-intel* -nouveau* -radeon* -vmware*"
[ebuild  N     ] sys-power/acpid-2.0.20  USE="(-selinux)"
[ebuild     U  ] app-misc/ca-certificates-20130906-r1 [20130906]
[ebuild   R    ] dev-qt/qtcore-4.8.5-r1  USE="icu*"
[ebuild   R    ] x11-base/xorg-drivers-1.15  VIDEO_CARDS="fglrx* -dummy* -fbdev* -glint* -intel* -mach64* -mga* -nouveau* -nv* -r128* -radeon* -savage* -tdfx* -trident* -v4l* -vesa* -via* -vmware*"
[ebuild  N     ] app-admin/eselect-opencl-1.1.0-r1
[ebuild  N     ] virtual/linux-sources-0
[ebuild   R    ] sys-libs/glibc-2.17  USE="suid*"
[ebuild   R    ] dev-db/sqlite-3.8.2  USE="icu*"
[ebuild     U  ] sys-apps/hwids-20140317 [20130915.1]
[ebuild  N     ] sys-apps/vbetool-1.1
[ebuild   R    ] sys-auth/pambase-20120417-r3  USE="consolekit*"
[ebuild   R    ] media-libs/harfbuzz-0.9.23  USE="icu*"
[ebuild     U ~] dev-libs/libxml2-2.9.1-r2 [2.9.1-r1] USE="icu*" ABI_X86="(64%*) -32% -x32%"
[ebuild   R    ] dev-qt/qtwebkit-4.8.5  USE="icu*"
[ebuild   R    ] dev-lang/R-3.0.1  USE="icu*"
[ebuild   R    ] sys-apps/groff-1.22.2  USE="X*"
[ebuild   R    ] net-nds/openldap-2.4.35-r1  USE="icu*"
[ebuild   R    ] net-misc/openssh-6.6_p1-r1  USE="X* ldap*"
[ebuild   R    ] sys-libs/ncurses-5.9-r2  USE="gpm*"
[ebuild   R    ] sys-apps/util-linux-2.22.2  USE="udev*"
[ebuild   R    ] sys-process/psmisc-22.20  USE="X*"
[ebuild   R    ] sys-power/pm-utils-1.4.1-r2  VIDEO_CARDS="-intel* -radeon*"
[ebuild   R    ] sys-devel/llvm-3.3-r3  VIDEO_CARDS="-radeon*"
[ebuild   R    ] media-libs/mesa-10.0.4  VIDEO_CARDS="-intel* -nouveau* -radeon* -vmware*"
[ebuild     UD ] x11-base/xorg-server-1.14.5 [1.15.0]
[ebuild  N     ] x11-drivers/ati-drivers-13.12  USE="modules multilib qt4 -debug -pax_kernel -static-libs"
[ebuild   R    ] app-editors/nano-2.3.2  USE="spell*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-51.2-r1::gentoo, installed) pulled in by
    dev-libs/icu:0/51.2= required by (sys-apps/gptfdisk-0.8.8::gentoo, installed)
    dev-libs/icu:0/51.2= required by (media-libs/raptor-2.0.9::gentoo, installed)

  (dev-libs/icu-52.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?] required by (dev-libs/libxml2-2.9.1-r2::gentoo, ebuild scheduled for merge)

x11-base/xorg-server:0

  (x11-base/xorg-server-1.15.0::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-evdev-2.8.2::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-mouse-1.9.0::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-keyboard-1.7.0::gentoo, installed)

  (x11-base/xorg-server-1.14.5::gentoo, ebuild scheduled for merge) pulled in by
    <=x11-base/xorg-server-1.14.49[-minimal] required by (x11-drivers/ati-drivers-13.12::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



I
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13848

PostPosted: Sun Mar 30, 2014 11:16 pm    Post subject: Reply with quote

I was not questioning your decision to use ati-drivers above, though personally I do question anyone who uses the proprietary drivers I was questioning why you had enabled drivers for a wide variety of video cards, since you almost certainly have no more than two distinct video cards in the system.

That output looks much better. It appears you have changed VIDEO_CARDS, but not yet updated the meta-package that uses it. The world update correctly wants to update that meta-package. However, according to that output, the only available versions of the proprietary ATI drivers require an older X server. That older X server cannot be used if you want to keep your existing keyboard/mouse input drivers. You might be able to solve this by keywording or unmasking newer proprietary drivers, or by switching to the open driver. The open drivers usually seem to be kept current with the X server.

You also have an icu conflict, which looks like it might be caused by not updating the packages that currently use it. If these packages were installed with --oneshot, that might happen. Otherwise, I do not know why your use of --deep --with-bdeps=y is insufficient to cause them to update.
Back to top
View user's profile Send private message
aschueler
Tux's lil' helper
Tux's lil' helper


Joined: 09 Apr 2004
Posts: 119

PostPosted: Sun Mar 30, 2014 11:39 pm    Post subject: Reply with quote

Sadly I am feel obligated to use the proprietary drivers to get the performance I want.

Here is where I am now....

I didn't install with --oneshot.

I did try the --backtrack=30 option, which resolved the icu conflict but for some reason stated that i needed to unmask beta driver for ati. This I did, and now it's recompiling. I hope it works.

Thanks for trying to help, you seem to know a lot. I didn't specifically enable all those drivers, not sure where they came from...I did emerge kde meta, and I think it brought them in.

It's been about 9 yrs since I have used gentoo, part of me misses it and part of me remembers why I left.
Back to top
View user's profile Send private message
aschueler
Tux's lil' helper
Tux's lil' helper


Joined: 09 Apr 2004
Posts: 119

PostPosted: Mon Mar 31, 2014 1:27 am    Post subject: Reply with quote

all that worked, but now I have broken Xorg, it doesn't like my fglrx driver (no screens found, cannot load kde)

Will figure that out later, tomorrow is a workday and I won't work on it for a few days.


Feel like I am playing whack-a-mole
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Mon Mar 31, 2014 2:17 am    Post subject: Reply with quote

have you run
Code:
aticonfig --initial

_________________
Defund the FCC.
Back to top
View user's profile Send private message
aschueler
Tux's lil' helper
Tux's lil' helper


Joined: 09 Apr 2004
Posts: 119

PostPosted: Tue Apr 01, 2014 1:30 am    Post subject: Reply with quote

Quote:
have you run

aticonfig --initial




Tried that and it didn't help, although I got excited about something I may have overlooked

What I have now is a working system (as far as I can tell) that will NOT run with fglrx, which is ironic. I wanted to use my graphics card mostly to tun the 3d effects of KDE and have multiple desktops, now it just quits. It won't run
Code:
X -configure
because of fatal error, and now I want to get at least my original driver back. I have no xorg or X at all now, and I did have it before, but not as robust as I wanted.

I think I have to remove
Code:
VIDEO_CARDS="fglrx"
from my /etc/portage/make.conf and replace it with --> what? radeon???

I think I need alter my kernel again for radeon? Any other ideas out there?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Tue Apr 01, 2014 2:04 am    Post subject: Reply with quote

genkernel --menuconfig all or
Code:
cd /usr/src/linux;make menuconfig

edit menuconfig to:
Quote:

Device Drivers --->
Graphics support --->
<M> /dev/agpgart (AGP Support) --->
< > AMD Opteron/Athlon64 on-CPU GART support
< > Intel 440LX/BX/GX, I8xx and E7x05 chipset support
< > SiS chipset support
< > VIA chipset support # pick one to match motherboard chipset else none

-*- VGA Arbitration
(2) Maximum number of GPUs
[ ] Laptop Hybrid Graphics - GPU switching support
< > Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)
<*> Support for frame buffer devices --->
--- Support for frame buffer devices
[*] Enable firmware EDID
[ ] Framebuffer foreign endianness support ----
[*] Enable Video Mode Handling Helpers
[*] Enable Tile Blitting Support
*** Frame buffer hardware drivers ***
< > Cirrus Logic support
< > Permedia2 support
< > CyberPro 2000/2010/5000 support
< > Arc Monochrome LCD board support
[ ] Asiliant (Chips) 69000 display support
[ ] IMS Twin Turbo display support
< > VGA 16-color graphics support
< > Userspace VESA VGA graphics support
[*] VESA VGA graphics support
[*] EFI-based Framebuffer Support
< > N411 Apollo/Hecuba devkit support
< > Hercules mono graphics support
< > Epson S1D13XXX framebuffer support
< > nVidia Framebuffer Support
< > nVidia Riva support
< > Intel740 support
< > Intel LE80578 (Vermilion) support
< > Matrox acceleration
< > ATI Radeon display support
< > ATI Rage128 display support
< > ATI Mach64 display support
< > S3 Trio/Virge support
< > S3 Savage support
< > SiS/XGI display support
< > VIA UniChrome (Pro) and Chrome9 display support
< > NeoMagic display support
< > IMG Kyro support
< > 3Dfx Banshee/Voodoo3/Voodoo5 display support
< > 3Dfx Voodoo Graphics (sst1) support
< > VIA VT8623 support
< > Trident/CyberXXX/CyberBlade support
< > ARK 2000PV support
< > Permedia3 support
< > Fujitsu carmine frame buffer support
< > SMSC UFX6000/7000 USB Framebuffer support
< > Displaylink USB Framebuffer support
< > Goldfish Framebuffer
< > Virtual Frame Buffer support (ONLY FOR TESTING!)
< > E-Ink Metronome/8track controller support
< > Fujitsu MB862xx GDC support
< > E-Ink Broadsheet/Epson S1D13521 controller support
< > AUO-K190X EPD controller support
[ ] Simple framebuffer support
[ ] Exynos Video driver support ----
[*] Backlight & LCD device support --->
--- Backlight & LCD device support
<*> Lowlevel LCD controls
< > Platform LCD controls
<*> Lowlevel Backlight controls
< > Generic (aka Sharp Corgi) Backlight Driver
< > Apple Backlight Driver
< > Tabletkiosk Sahara Touch-iT Backlight Driver
< > Backlight Driver for ADP8860/ADP8861/ADP8863 using WLED
< > Backlight Driver for ADP8870 using WLED
< > Backlight Driver for LM3630A
< > Backlight Driver for LM3639
< > Backlight driver for TI LP855X
< > Sanyo LV5207LP Backlight
< > Rohm BD6107 Backlight
Console display driver support --->
-*- VGA text console
[*] Enable Scrollback Buffer in System RAM
(256) Scrollback Buffer Size (in KB)
<*> Framebuffer Console support
[ ] Map the console to the primary display device
[ ] Framebuffer Console Rotation
[*] Bootup logo --->
--- Bootup logo
[ ] Standard black and white Linux logo
[ ] Standard 16-color Linux logo
[*] Standard 224-color Linux logo
exit menuconfig saving the configuration, recompile, recopy kernel
Edit /etc/portage make.conf to include
Quote:
VIDEO_CARDS="fglrx vesa"
INPUT_DEVICES="evdev synaptics"
synaptics if a touchpad

more to follow
_________________
Defund the FCC.
Back to top
View user's profile Send private message
aschueler
Tux's lil' helper
Tux's lil' helper


Joined: 09 Apr 2004
Posts: 119

PostPosted: Thu Apr 03, 2014 12:20 am    Post subject: Reply with quote

Here is what worked, and it was a process indeed. Some of this if not all might belong in desktop forums

Had to totally remove fglrx, and install radeon. this was not easy; what worked was to load it as modules, then I ran into a bug with emerge linux-firmware, although I didn't realize it. As a last ditch effort I removed linux-firmware and emerged radeon-ucode, and when I restarted the system it loaded on its own.

Oh and I did have to rm the xorg config file at one point as it kep thinking fglrx was there even though it was gone.

Thanks for all your help, the radeon drivers are working for me now. At least, until the next time I break my systemm
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum