Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Frage zu abi_x86_32
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Wed Apr 02, 2014 5:15 am    Post subject: Frage zu abi_x86_32 Reply with quote

Da ich endlich mal das Wine-Problem angehen will, dachte ich, ich stell mal mein System auf Multilib, aka abi_x86_32 um.

Jetzt hab ich das so verstanden, dass die benötigten Libs sowohl als 64-, als auch als 32-bit-Version gebaut werden. Wozu brauch ich dann noch die emul-linux-x86-Dinger? Die stehen in der Merge-Liste ja auch wieder mit drin.
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1560
Location: Schweiz

PostPosted: Wed Apr 02, 2014 6:19 am    Post subject: Reply with quote

So weit ich das mitbekommen habe sind noch nicht alle Pakete die in den emul-libs vertreten sind auf das neue ABI umgestellt und außerdem haben noch immer viele ebuilds die emul-libs als Abhängigkeit mit drin.
_________________
GPG: 0x3FC78AEE51E5FB95
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Wed Apr 02, 2014 1:10 pm    Post subject: Reply with quote

Hab jetzt die emul-libs in package.provided eingetragen und die meisten angezeigten Programme mit Flag ABI_X86="64 32" compiliert. Übrig ist momentan noch die Liste:

Code:
emerge -puDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/freetype-2.5.3  ABI_X86="32*"
[ebuild   R    ] media-libs/fontconfig-2.11.0-r1  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXft-2.3.1-r1  ABI_X86="32*"
[ebuild   R    ] x11-libs/libSM-1.2.2  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXtst-1.2.2  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXt-1.1.4  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXpm-3.5.11  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXmu-1.1.2  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXaw-1.0.12  ABI_X86="32*"
[ebuild   R    ] www-plugins/adobe-flash-11.2.202.346  ABI_X86="32*"
[ebuild   R    ] media-libs/glew-1.10.0-r2  ABI_X86="32*"

Das scheitert als erstes an freetype:
Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible //usr/lib64/libm.so when searching for -lm
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible //usr/lib64/libm.a when searching for -lm
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible //usr/lib64/libz.so when searching for -lz
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible //usr/lib64/libz.a when searching for -lz
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible //usr/lib64/libbz2.so when searching for -lbz2
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible //usr/lib64/libpng16.so when searching for -lpng16
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible //usr/lib64/libharfbuzz.so when searching for -lharfbuzz
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../libharfbuzz.so when searching for -lharfbuzz
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libharfbuzz.so when searching for -lharfbuzz
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lharfbuzz
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible //usr/lib64/libc.so when searching for -lc
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible //usr/lib64/libc.a when searching for -lc
collect2: error: ld returned 1 exit status
config.mk:55: recipe for target '/var/tmp/portage/media-libs/freetype-2.5.3/work/freetype-2.5.3-x86/libfreetype.la' failed
make: *** [/var/tmp/portage/media-libs/freetype-2.5.3/work/freetype-2.5.3-x86/libfreetype.la] Error 1
 * ERROR: media-libs/freetype-2.5.3::gentoo failed (compile phase):
 *   emake failed
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Wed Apr 02, 2014 2:06 pm    Post subject: Reply with quote

das ist nicht die richtige vorgehensweise. du musst die emul-linux pakete behalten und bei denen das abi_x86_32 useflag aktivieren.
die sind so angepasst, dass sie wissen welche pakete schon das abi_x86_32 haben, diese werden dann als abhängigkeit verlangt und nicht als binary installiert und alles was es noch nicht als abi_x86_32 gibt wird als binary installiert.

Also am besten:
prüfen welche emul-linux pakete installiert sind und für diese dann abi_x86_32 aktivieren.
danach emerge -uDN $( alle installierten/benötigten emul-linux pakete ). das wird nicht funktionieren, weil die emul-linux pakete fordern, bei weiteren paketen abi_x86_32 zu aktivieren. bei den geforderten paketen auch abi_x86_32 aktivieren
dann nochmal emerge -uDN $( alle installierten/benötigten emul-linux pakete ). das sollte dann funktionieren und neben den emul-linux paketen eine ganze reihe weitere pakete neu installieren.

falls es nochmal probleme gibt, frag ruhig nochmal
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Fri Apr 11, 2014 4:59 pm    Post subject: Reply with quote

@musv

wenn du auf echtes multilib umstellst, dann benötigst du emul-linux-x86 nicht mehr.
ich habe das bereits (zum glück ohne größere probleme) gemacht.
nun läuft bei mir wine auch wieder, aber leider fehlen zwei wichtige libs und zwar gnutls und openssl, dadurch funktionieren leider windowsprogramme nicht, die ssl benötigen. das ist aber immernoch besser als darauf zu warten das emul-linux-x86 jemals aktualisiert wird (vorher lief bei mir kein programm wegen dem amd64-libpng-versionsmurks)
ein weiterer nachteil ist das man mehr ~testing pakete aktivieren muss, das hat sich bei mir aber im rahmen gehalten.

alles in allem kann ich es nur empfehlen sich von emul-linux-x86 zu lösen.
das scheint mir auf die dauer der bessere weg zu sein.

also in package.mask
Code:

app-emulation/emul-linux-x86-*

eintragen und die abhängigkeiten auflösen
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Fri Apr 11, 2014 5:42 pm    Post subject: Reply with quote

das problem mit den fehlenden libs bekommst du geregelt, wenn du die emul-linux pakete mit abi_x86_32 useflags installierst. dann behälst du soweit bereits vorhanden pakete mit abi_x86_32 useflag, alles andere kommt durch die emul linux pakete
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Sat Apr 12, 2014 9:59 am    Post subject: Reply with quote

@Christian99

danke für den tipp, aber ich habe ja auf ein echtes multilib-system umgestellt und da scheint ein mischbetrieb nicht möglich zu sein.

Code:

# emerge emul-linux-x86-baselibs -pv
[ebuild  N    ] app-emulation/emul-linux-x86-baselibs-20131008-r6  USE="development" ABI_X86="-32"
[uninstall    ] dev-libs/libgcrypt-1.6.1-r1  USE="-static-libs" ABI_X86="32 (64) (-x32)"
[blocks b     ] <=app-emulation/emul-linux-x86-baselibs-20131008-r19 ("<=app-emulation/emul-linux-x86-baselibs-20131008-r19" is blocking dev-libs/libgcrypt-1.6.1-r1)
[blocks b     ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32]" is blocking dev-libs/libgcrypt-1.6.1-r1)
[blocks B     ] <app-emulation/emul-linux-x86-baselibs-20131008-r8 ("<app-emulation/emul-linux-x86-baselibs-20131008-r8" is blocking dev-libs/dbus-glib-0.100.2-r1)
[blocks B     ] <=app-emulation/emul-linux-x86-baselibs-20131008-r11 ("<=app-emulation/emul-linux-x86-baselibs-20131008-r11" is blocking sys-devel/gettext-0.18.3.2)
[blocks B     ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking sys-devel/llvm-3.3-r3, sys-fs/udev-208, media-libs/tiff-4.0.3-r6, media-libs/lcms-2.5-r1, dev-libs/expat-2.1.0-r3, dev-libs/libusb-1.0.18, dev-libs/libffi-3.0.13-r1, sys-apps/dbus-1.6.18-r1, dev-libs/libxslt-1.1.28-r2, dev-libs/glib-2.38.2-r1, media-libs/libpng-1.6.10, dev-libs/dbus-glib-0.100.2-r1, dev-libs/libxml2-2.9.1-r2, dev-libs/libusb-compat-0.1.5-r2, media-libs/libjpeg-turbo-1.3.0-r3, dev-libs/libgpg-error-1.12-r1)
[blocks B     ] <=app-emulation/emul-linux-x86-baselibs-20131008-r12 ("<=app-emulation/emul-linux-x86-baselibs-20131008-r12" is blocking dev-libs/libgpg-error-1.12-r1)
[blocks B     ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking sys-devel/gettext-0.18.3.2, dev-libs/elfutils-0.158, sys-libs/libavc1394-0.5.4-r1, sys-libs/ncurses-5.9-r3, sys-libs/libraw1394-2.1.0-r1, sys-libs/zlib-1.2.8-r1, app-arch/bzip2-1.0.6-r6)
[blocks B     ] <=app-emulation/emul-linux-x86-baselibs-20131008-r20 ("<=app-emulation/emul-linux-x86-baselibs-20131008-r20" is blocking dev-libs/libxslt-1.1.28-r2)
[blocks B     ] <=app-emulation/emul-linux-x86-baselibs-20131008-r6 ("<=app-emulation/emul-linux-x86-baselibs-20131008-r6" is blocking dev-libs/libxml2-2.9.1-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/glib-2.38.2-r1::gentoo, installed) pulled in by
    dev-libs/glib required by @selected

  (dev-libs/dbus-glib-0.100.2-r1::gentoo, installed) pulled in by
    dev-libs/dbus-glib required by @selected

  (app-emulation/emul-linux-x86-baselibs-20131008-r6::gentoo, ebuild scheduled for merge) pulled in by
    emul-linux-x86-baselibs

  (sys-fs/udev-208::gentoo, installed) pulled in by
    sys-fs/udev required by @selected



ich denke ich werde daher lieber bei meinem eingeschlagenen weg bleiben und warten bis die fehlenden libs
mit abi_x86_32 zur verfügung stehen, da die abhängigkeiten von emul-linux-x86 auch in zukunft vermutlich immer wieder für probleme sorgen werden, wenn die entwickler (wie in den letzten monaten) nicht hinterherkommen, daher bin ich eigentlich froh die pakete los zu sein.
wie gesagt wine-1.7.16 läuft bei mir wunderbar ohne irgendeine emul-linux-x86. man muss eben (NOCH) auf einige dinge wie ssl verzichten, aber das ist immernoch besser als wenn dann irgendwann wieder von einem tag auf den anderen gar nichts mehr funktioniert oder man andere pakete nicht aktualisieren kann, weil man sonst mit emul-linux probleme bekommt (stichwort libpng)
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Sat Apr 12, 2014 5:28 pm    Post subject: Reply with quote

du musst noch die abi_x86_32 useflage für die emul pakete aktivieren. dann handeln die das.
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Sun Apr 13, 2014 1:58 pm    Post subject: Reply with quote

also bei mir will das nicht so wirklich funktionieren...
nachdem ich die useflags eingetragen und einige weitere erforderliche ~testing pakete hinzufügen musste sieht es nun so aus
(ich gehe mal davon aus das die benötigten ssl libs in den baselibs enthalten sind)

Code:

# emerge app-emulation/emul-linux-x86-baselibs -pv
[ebuild     U ] dev-libs/nettle-2.7.1-r1 [2.7.1] USE="gmp -doc (-neon) -static-libs {-test}" ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS   ] media-libs/libpng-1.2.51 [1.5.17-r15, 1.6.10] ABI_X86="32 (64) (-x32)"
[ebuild  NS   ] media-libs/tiff-3.9.7-r1 [4.0.3-r6] USE="cxx jpeg zlib -jbig" ABI_X86="32 (64) (-x32)"
[ebuild     U ] sys-libs/readline-6.3_p3 [6.2_p1] USE="-static-libs%" ABI_X86="32%* (64%*) (-x32)"
[ebuild     U ] dev-libs/libtasn1-3.4-r1 [2.14] USE="-doc -static-libs" ABI_X86="32%* (64%*) (-x32)"
[ebuild     U ] dev-db/sqlite-3.8.4.3 [3.8.2] USE="readline -debug -doc -icu -secure-delete -static-libs -tcl {-test}" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N    ] dev-libs/json-c-0.11-r1  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild  N    ] dev-libs/udis86-1.7-r2  USE="{-test}" ABI_X86="32 (64) (-x32)"
[ebuild  N    ] app-emulation/emul-linux-x86-baselibs-20131008-r19  USE="development" ABI_X86="32"
[blocks B     ] <=app-emulation/emul-linux-x86-baselibs-20131008-r19 ("<=app-emulation/emul-linux-x86-baselibs-20131008-r19" is blocking dev-libs/libgcrypt-1.6.1-r1)
[blocks B     ] <=app-emulation/emul-linux-x86-baselibs-20131008-r20 ("<=app-emulation/emul-linux-x86-baselibs-20131008-r20" is blocking dev-libs/libxslt-1.1.28-r2)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libtasn1:0

  (dev-libs/libtasn1-3.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libtasn1-3.4-r1[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-baselibs-20131008-r19::gentoo, ebuild scheduled for merge)

  (dev-libs/libtasn1-2.14::gentoo, installed) pulled in by
    >=dev-libs/libtasn1-1:0/0= required by (app-crypt/gcr-3.10.1::gentoo, installed)



 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

... - cut -


# equery depends dev-libs/libtasn1-1
 * These packages depend on dev-libs/libtasn1-1:
app-crypt/gcr-3.10.1 (>=dev-libs/libtasn1-1)
app-crypt/p11-kit-0.20.2 (asn1 ? >=dev-libs/libtasn1-2.14)
net-libs/gnutls-3.2.13 (>=dev-libs/libtasn1-2.14)


# equery depends gcr
 * These packages depend on gcr:
app-crypt/seahorse-3.10.2-r1 (>=app-crypt/gcr-3.9.1)
                             (app-crypt/gcr[vala])
gnome-base/gnome-keyring-3.10.1 (>=app-crypt/gcr-3.5.3[gtk])

Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Mon Apr 14, 2014 11:46 am    Post subject: Reply with quote

diese libtasn1 sache sieht seltsam aus. mach mal bitte
Code:
USE=-abi_x86_32 emerge -1 =libtasn1-3.4-r1

wenn das funktioniert probier nochma die emul baselibs, ansonsten bitte fehler posten
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Mon Apr 14, 2014 1:07 pm    Post subject: Reply with quote

also das problem mit libtasn konnte aufgelöst werden, danach ging es aber weiter mit

Code:

[blocks B     ] <=app-emulation/emul-linux-x86-baselibs-20131008-r19 ("<=app-emulation/emul-linux-x86-baselibs-20131008-r19" is blocking dev-libs/libgcrypt-1.6.1-r1)
[blocks B     ] <=app-emulation/emul-linux-x86-baselibs-20131008-r20 ("<=app-emulation/emul-linux-x86-baselibs-20131008-r20" is blocking dev-libs/libxslt-1.1.28-r2)


für die beiden libs habe ich dann auch -abi_x86_32 eingetragen.

danach wäre dann ein package.unmask notwendig gewesen

Code:

=dev-libs/libgcrypt-1.5.3-r100


an dieser stelle habe ich die aktion dann abgebrochen, da mich das im moment alles zuviel zeit kostet und ich auch insgesamt schon 12 weitere ~testing pakete freischalten musste. ich bleibe daher doch vorerst lieber dabei mit einem emul-linux-freien system weiterzuarbeiten und hoffe das in den nächsten wochen/monaten die benötigten ssl libs auch mit abi_x86_32 zur verfügung stehen.

dennoch danke für den versuch zu helfen, möglich wäre es vermutlich gewesen, aber der zeitaufwand ist mir im moment einfach zu gross und ich will mein system auch nicht kaputtmachen.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Mon Apr 14, 2014 2:56 pm    Post subject: Reply with quote

Kann ich eigentlich auch irgendwelche Pakete per USE-Flag von ABI_X86="32*" ausschließen? Wie oben schon erwähnt, ist es bei mir egal, ob ich jetzt die emul-Libs wieder reinnehm oder nicht. In der Kette will Portage als erstes freetype bauen, was eben fehlschlägt. Wie wäre das entsprechende USE-Flag? -x32? Geht das per USE-Flag?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Mon Apr 14, 2014 7:02 pm    Post subject: Reply with quote

@andi:
bei mir ist dev-libs/libxslt-1.1.28-r2 hardgemasked und nur die r1 version installiert. überprüf das mal bei dir und installiere notfalls mal die r1er .möglicherweise hebt das deinen block auf. was das mit libgcrypt ist weiß ich nicht, bei mir ist die(in der version) gar nicht installiert.
mach das erst mal mit xslt und dann schaun wir weiter. wenn dus aber sein lassen willst, dann auch gut :)

@musv:
Quote:
Kann ich eigentlich auch irgendwelche Pakete per USE-Flag von ABI_X86="32*" ausschließen?

was meinst du damit? entweder ist ein useflag aktiviert oder nicht. x32 ist was anderes.
hast du die emul libs noch in package.provided? die müssen da weg.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Tue Apr 15, 2014 11:52 am    Post subject: Reply with quote

Christian99 wrote:
@musv:
Quote:
Kann ich eigentlich auch irgendwelche Pakete per USE-Flag von ABI_X86="32*" ausschließen?

was meinst du damit? entweder ist ein useflag aktiviert oder nicht. x32 ist was anderes.
hast du die emul libs noch in package.provided? die müssen da weg.

Hab die emul-libs aus package.provided rausgenommen. Trotzdem steht in der Liste der zu bauenden Pakete als erstes freetype, was sich ja bei mir nicht bauen lässt als Multilib.

Hab jetzt aber auch schon ein paar Tage lang kein Portage-Update mehr gemacht. Evtl. wurde das schon gefixt.
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Tue Apr 15, 2014 12:36 pm    Post subject: Reply with quote

Je höher die Version der emul-linux packages, desto weniger Bibliotheken (Mit USE="abi_x86_32") installiert, und die entsprechenden Abhängigkeiten gezogen.

Bei mir sieht es jetzt wie folgt aus, um app-emulation/wine-1.7.16 mit so vielen selbstgebauten Bibliotheken wie möglich zu betreiben: (Achtung, dies ist warscheinlich zu viel nur für wine, aber ich habe auch noch acroread und icaclient installiert, die ebenfalls viel 32bit-Krempel benötigen)
Code:
 ~ # grep emul-linux /etc/portage/package.unmask
=app-emulation/emul-linux-x86-baselibs-20140406-r1::gentoo
=app-emulation/emul-linux-x86-db-20140406::gentoo
=app-emulation/emul-linux-x86-gstplugins-20140406::gentoo
=app-emulation/emul-linux-x86-gtklibs-20140406-r0::SED-Local # (*)
=app-emulation/emul-linux-x86-medialibs-20140406::gentoo
=app-emulation/emul-linux-x86-opengl-20140406::gentoo
=app-emulation/emul-linux-x86-soundlibs-20140406::gentoo
=app-emulation/emul-linux-x86-xlibs-20140406::gentoo
Wegen der emul-linux-x86-gtklibs-20140406-r0, siehe bug 507292 - da hatte ich File Kollisionen.
Code:
 ~ # grep "abi_x86" /etc/portage/package.use
app-arch/bzip2 abi_x86_32
app-arch/xz-utils abi_x86_32
app-emulation/emul-linux-x86-baselibs abi_x86_32
app-emulation/emul-linux-x86-db abi_x86_32
app-emulation/emul-linux-x86-gstplugins abi_x86_32
app-emulation/emul-linux-x86-gtklibs abi_x86_32
app-emulation/emul-linux-x86-medialibs abi_x86_32
app-emulation/emul-linux-x86-opengl abi_x86_32
app-emulation/emul-linux-x86-soundlibs abi_x86_32 -pulseaudio
app-emulation/emul-linux-x86-xlibs abi_x86_32
app-text/libpaper abi_x86_32
dev-db/sqlite abi_x86_32
dev-lang/orc abi_x86_32
dev-libs/dbus-glib abi_x86_32
dev-libs/elfutils abi_x86_32 lzma static-libs threads
dev-libs/expat abi_x86_32
dev-libs/fribidi abi_x86_32
dev-libs/glib abi_x86_32
dev-libs/gmp abi_x86_32
dev-libs/icu abi_x86_32
dev-libs/json-c abi_x86_32
dev-libs/libcdio abi_x86_32
dev-libs/libcdio-paranoia abi_x86_32
dev-libs/libffi abi_x86_32
dev-libs/libgcrypt abi_x86_32
dev-libs/libgpg-error abi_x86_32
dev-libs/liboil abi_x86_32
dev-libs/libpcre abi_x86_32 pcre16
dev-libs/libpthread-stubs abi_x86_32
dev-libs/libtasn1 abi_x86_32
dev-libs/libusb abi_x86_32
dev-libs/libusb-compat abi_x86_32
dev-libs/libxml2 abi_x86_32
dev-libs/libxslt abi_x86_32
dev-libs/lzo abi_x86_32
dev-libs/nettle abi_x86_32
dev-libs/udis86 abi_x86_32
dev-libs/wayland abi_x86_32
media-gfx/graphite2 abi_x86_32
media-libs/a52dec abi_x86_32
media-libs/alsa-lib abi_x86_32
media-libs/audiofile abi_x86_32
media-libs/faac abi_x86_32
media-libs/faad2 abi_x86_32
media-libs/fdk-aac abi_x86_32
media-libs/flac abi_x86_32
media-libs/fontconfig abi_x86_32
media-libs/freeglut abi_x86_32
media-libs/freetype abi_x86_32
media-libs/glew abi_x86_32 doc
media-libs/glu abi_x86_32
media-libs/harfbuzz abi_x86_32 icu
media-libs/ladspa-sdk abi_x86_32
media-libs/lcms abi_x86_32
media-libs/libao abi_x86_32
media-libs/libcuefile abi_x86_32
media-libs/libdca abi_x86_32
media-libs/libdv abi_x86_32
media-libs/libdvdcss abi_x86_32
media-libs/libdvdnav abi_x86_32
media-libs/libdvdread abi_x86_32
media-libs/libid3tag abi_x86_32
media-libs/libiec61883 abi_x86_32
media-libs/libjpeg-turbo abi_x86_32
media-libs/libmad abi_x86_32
media-libs/libmikmod abi_x86_32
media-libs/libmimic abi_x86_32
media-libs/libmms abi_x86_32
media-libs/libmodplug abi_x86_32
media-libs/libmpeg2 abi_x86_32
media-libs/libogg abi_x86_32
media-libs/libpng abi_x86_32
media-libs/libreplaygain abi_x86_32
media-libs/libsamplerate abi_x86_32
media-libs/libshout abi_x86_32
media-libs/libsidplay abi_x86_32
media-libs/libsndfile abi_x86_32
media-libs/libtheora abi_x86_32
media-libs/libtxc_dxtn abi_x86_32
media-libs/libv4l abi_x86_32
media-libs/libvisual abi_x86_32
media-libs/libvorbis abi_x86_32
media-libs/libvpx abi_x86_32
media-libs/mesa abi_x86_32 gallium gbm gles1 gles2 llvm llvm-shared-libs openvg osmesa vdpau xa xorg xvmc
media-libs/openal abi_x86_32
media-libs/opencore-amr abi_x86_32
media-libs/openjpeg abi_x86_32
media-libs/opus abi_x86_32
media-libs/portaudio abi_x86_32
media-libs/schroedinger abi_x86_32
media-libs/speex abi_x86_32
media-libs/tiff abi_x86_32
media-libs/vo-aacenc abi_x86_32
media-libs/vo-amrwbenc abi_x86_32
media-libs/webrtc-audio-processing abi_x86_32
media-libs/x264 abi_x86_32
media-libs/xvid abi_x86_32
media-plugins/alsaequal abi_x86_32
media-plugins/caps-plugins abi_x86_32
media-plugins/swh-plugins abi_x86_32
media-sound/cdparanoia abi_x86_32
media-sound/gsm abi_x86_32
media-sound/jack-audio-connection-kit abi_x86_32
media-sound/lame abi_x86_32
media-sound/mpg123 abi_x86_32
media-sound/musepack-tools abi_x86_32
media-sound/twolame abi_x86_32
media-sound/wavpack abi_x86_32
media-video/ffmpeg abi_x86_32
media-video/libav abi_x86_32 amr avx -bindist cdio doc faac fdk -frei0r jpeg2k mmxext network -openssl opus -sdl schroedinger -ssl theora threads tools v4l vpx
sci-libs/fftw abi_x86_32 threads
sys-apps/attr abi_x86_32
sys-apps/dbus abi_x86_32
sys-apps/file abi_x86_32
sys-apps/tcp-wrappers abi_x86_32
sys-devel/clang abi_x86_32 multitarget
sys-devel/gettext abi_x86_32
sys-devel/llvm abi_x86_32 clang doc gold multitarget udis86
sys-fs/udev abi_x86_32
sys-libs/e2fsprogs-libs abi_x86_32
sys-libs/gdbm abi_x86_32
sys-libs/gpm abi_x86_32
sys-libs/libavc1394 abi_x86_32
sys-libs/libieee1284 abi_x86_32
sys-libs/libraw1394 abi_x86_32
sys-libs/ncurses abi_x86_32
sys-libs/readline abi_x86_32
sys-libs/zlib abi_x86_32
virtual/glu abi_x86_32
virtual/jpeg abi_x86_32
virtual/libffi abi_x86_32
virtual/libgudev abi_x86_32
virtual/libiconv abi_x86_32
virtual/libintl abi_x86_32
virtual/libudev abi_x86_32
virtual/libusb abi_x86_32
virtual/opengl abi_x86_32
virtual/udev abi_x86_32
x11-libs/cairo abi_x86_32
x11-libs/gdk-pixbuf abi_x86_32 introspection
x11-libs/libdrm abi_x86_32 libkms
x11-libs/libICE abi_x86_32
x11-libs/libpciaccess abi_x86_32
x11-libs/libSM abi_x86_32
x11-libs/libva abi_x86_32
x11-libs/libva-intel-driver abi_x86_32
x11-libs/libva-vdpau-driver abi_x86_32
x11-libs/libvdpau abi_x86_32
x11-libs/libX11 abi_x86_32
x11-libs/libXau abi_x86_32
x11-libs/libXaw abi_x86_32
x11-libs/libxcb abi_x86_32 xkb
x11-libs/libXcomposite abi_x86_32
x11-libs/libXcursor abi_x86_32
x11-libs/libXdamage abi_x86_32
x11-libs/libXdmcp abi_x86_32
x11-libs/libXext abi_x86_32
x11-libs/libXfixes abi_x86_32
x11-libs/libXft abi_x86_32
x11-libs/libXi abi_x86_32
x11-libs/libXinerama abi_x86_32
x11-libs/libXmu abi_x86_32
x11-libs/libXp abi_x86_32
x11-libs/libXpm abi_x86_32
x11-libs/libXrandr abi_x86_32
x11-libs/libXrender abi_x86_32
x11-libs/libXScrnSaver abi_x86_32
x11-libs/libxshmfence abi_x86_32
x11-libs/libXt abi_x86_32
x11-libs/libXtst abi_x86_32
x11-libs/libXv abi_x86_32
x11-libs/libXvMC abi_x86_32
x11-libs/libXxf86dga abi_x86_32
x11-libs/libXxf86vm abi_x86_32
x11-libs/motif abi_x86_32 -abi_x86_64
x11-libs/pango abi_x86_32 introspection
x11-libs/pangox-compat abi_x86_32
x11-libs/pixman abi_x86_32
x11-proto/compositeproto abi_x86_32
x11-proto/damageproto abi_x86_32
x11-proto/dri2proto abi_x86_32
x11-proto/dri3proto abi_x86_32
x11-proto/fixesproto abi_x86_32
x11-proto/glproto abi_x86_32
x11-proto/inputproto abi_x86_32
x11-proto/kbproto abi_x86_32
x11-proto/presentproto abi_x86_32
x11-proto/printproto abi_x86_32
x11-proto/randrproto abi_x86_32
x11-proto/recordproto abi_x86_32
x11-proto/renderproto abi_x86_32
x11-proto/scrnsaverproto abi_x86_32
x11-proto/videoproto abi_x86_32
x11-proto/xcb-proto abi_x86_32 python_targets_python3_3
x11-proto/xextproto abi_x86_32
x11-proto/xf86bigfontproto abi_x86_32
x11-proto/xf86dgaproto abi_x86_32
x11-proto/xf86driproto abi_x86_32
x11-proto/xf86vidmodeproto abi_x86_32
x11-proto/xineramaproto abi_x86_32
x11-proto/xproto abi_x86_32
Ich bin schon sehr gespannt darauf wie es mit dem ABI Krempel weitergeht.
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Wed Apr 16, 2014 1:35 pm    Post subject: Reply with quote

Notiz: app-emulation/emul-linux-x86-gtklibs-20140406 wurde korrigiert.
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum