Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mount bind-option does not show disk space.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
tuner23
Tux's lil' helper
Tux's lil' helper


Joined: 18 May 2006
Posts: 80

PostPosted: Wed Apr 02, 2014 6:57 pm    Post subject: Mount bind-option does not show disk space. Reply with quote

Hello,


i have a system with one root-partition and two encrypted LVM-partitions (system and data):
Code:

/dev/mapper/local-system  /system     ext4   noatime                     1 0
/dev/mapper/local-data    /data       ext4   noatime                     1 0


Now on system i have several system partitions which are dynamical growing and bind them with the mount command to the system:
Code:
# ll /system/
...
drwxr-xr-x  3 root root 4,0K 17. Mai 2010  home
drwxr-xr-x 15 root root 4,0K 30. Jan 12:09 opt
drwxr-xr-x 14 root root 4,0K 24. Jan 17:06 usr
drwxr-xr-x 13 root root 4,0K 24. Jan 21:29 var


Code:

/system/usr               /usr        none   bind
/system/var               /var        none   bind
/system/opt               /opt        none   bind


The main problem is, that it does not work as expected, cause when i use the first bind command, the /system-partition isn't been shown anymore and the also the other binds are missing. It looks like this:
Code:

# df -h
Dateisystem            Größe Benutzt Verf. Verw% Eingehängt auf
/dev/mapper/rootfs     1007M    363M  593M   38% /
tmpfs                   385M    796K  384M    1% /run
udev                     10M       0   10M    0% /dev
shm                     1,9G    140K  1,9G    1% /dev/shm
cgroup_root              10M       0   10M    0% /sys/fs/cgroup
/system/usr              25G     18G  5,9G   75% /usr
/dev/mapper/local-data   50G     21G   27G   44% /data
tmpfs                   1,9G     16K  1,9G    1% /tmp


Code:

# mount | grep system
/dev/mapper/local-system on /system type ext4 (rw,noatime,commit=0)
/system/usr on /usr type none (rw,bind,commit=0)
/system/var on /var type none (rw,bind,commit=0)
/system/opt on /opt type none (rw,bind,commit=0)


Where is the problem here? Do i use the wrong bind-options? I cannot figure out how to solve this or where the problem is.
Can someone explain me what is going wrong here?

This also brings some other effects with, for example when i want to emerge:
Code:

 * There is NOT at least 6 GiB disk space at "/system/portage/portage/app-office/libreoffice-4.1.4.2/temp"



Thanks,
Antonios.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum