Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] No sound on some applications after system update
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message

Joined: 26 Oct 2013
Posts: 28

PostPosted: Mon Mar 31, 2014 5:13 pm    Post subject: [solved] No sound on some applications after system update Reply with quote

After updating my whole system (emerge @world) some of the applications have no sound:
- Kerbal Space program (native)
- League of Legends (wine)

Kerbal dont show anything weird, but on console in League of legends I get:

ALSA lib /var/tmp/portage/media-libs/alsa-lib- Cannot open shared library
ALSA lib /var/tmp/portage/media-libs/alsa-lib- Unknown PCM default
ALSA lib /var/tmp/portage/media-libs/alsa-lib- unable to open slave

The path seem incorrect, I guess the same problem is in Kerbal. How can I fix this?
Recompiling wine didn't help and other applications are fine.

Recompiling the kernel solved the issue.

Last edited by hubertnnn on Tue Apr 22, 2014 6:46 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 06 Mar 2007
Posts: 15608

PostPosted: Tue Apr 01, 2014 2:15 am    Post subject: Reply with quote

What application provides What is the output of emerge --info media-libs/alsa-lib?
Back to top
View user's profile Send private message

Joined: 26 Oct 2013
Posts: 28

PostPosted: Tue Apr 01, 2014 1:49 pm    Post subject: Reply with quote


$qfile /usr/lib/alsa-lib/
media-plugins/alsa-plugins (/usr/lib64/alsa-lib/


$emerge --info media-libs/alsa-lib
Portage 2.2.10 (default/linux/amd64/13.0/desktop, gcc-4.8.2, glibc-2.18-r1, 3.13.7-gentoo x86_64)
                         System Settings
System uname: Linux-3.13.7-gentoo-x86_64-Intel-R-_Core-TM-_i7-4700MQ_CPU_@_2.40GHz-with-gentoo-2.2
KiB Mem:    16365436 total,  13682736 free
KiB Swap:   33554428 total,  33554428 free
Timestamp of tree: Fri, 28 Mar 2014 15:45:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p45-r1
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.3.5
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.18-r1
Repositories: gentoo stuff gentoo-zh bumblebee gamerlay steam-overlay x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -march=native"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="rsync:// rsync://"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/stuff /var/lib/layman/gentoo-zh /var/lib/layman/bumblebee /var/lib/layman/gamerlay /var/lib/layman/steam /usr/local/portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bindlist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dhcpcd dri dts dvd dvdr emboss encode exif fam firefox flac fortran gconf gdbm gdm gif gnome gpm gtk iconv icu ipv6 java jpeg laptop lcms ldap libnotify mad mercurial mmx mng modules mp3 mp4 mpeg multilib ncurses networkmanager nls nptl nsplugin ogg opengl openmp openrc-force osmesa pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 readline samba sdl session spell sse sse2 ssl startup-notification svg tcpd theora threads tiff truetype udev udisks unicode upower usb vala vorbis wxwidgets x264 xcb xine xinerama xml xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia intel modesetting" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

media-libs/alsa-lib- was built with the following:
USE="-alisp -debug -doc -python" ABI_X86="32 64 -x32" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"

Back to top
View user's profile Send private message

Joined: 06 Apr 2014
Posts: 9

PostPosted: Sun Apr 06, 2014 6:28 am    Post subject: Reply with quote

Have you tried recompiling the audio mixer?

Also check to see if there are other mixers that may be interfering. Such as XFCE-Mixer.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum