Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No sound after custom kernel (Updated.Images now)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Sun Apr 06, 2014 10:56 am    Post subject: No sound after custom kernel (Updated.Images now) Reply with quote

Yesterday I made my custom kernel. Took me 14 hours to finish it!!!! But is not recognized sound, camera, wifi, touchscreen. But lets start to make it work one by one. First of all sound. I have intel sound with realtek hd codecs into my kernel and of course alsa sound support. My sound is intel. (snd_hda_intel) and I started alsasound service but xfce4-mixer returns me:
Code:
GStreamer was unable to detect any sound devices. Some sound system specific GStreamer packages may be missing. It may also be a permissions problem.

Is not permission problem because I have my user into /etc/group on audio section.
How to make my sound to work?
_________________
Compile The Universe


Last edited by sk8harddiefast on Mon Apr 07, 2014 8:48 am; edited 3 times in total
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1109
Location: switzerland

PostPosted: Sun Apr 06, 2014 12:57 pm    Post subject: Reply with quote

you compiled the kernel with the sound driver as module or built-in?
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Sun Apr 06, 2014 12:58 pm    Post subject: Reply with quote

Build in. With tick. No bullet.
I don't know what logs I should post. Tell me everything you should know
_________________
Compile The Universe
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1109
Location: switzerland

PostPosted: Sun Apr 06, 2014 2:06 pm    Post subject: Reply with quote

post the output of lspci -k

(emerge the package pciutils)

another thing that you can do is boot from the install dvd and post lsmod

(I don't speak english very well, I hope you can understand me)
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Sun Apr 06, 2014 2:35 pm    Post subject: Reply with quote

I have some progress. I installed the latest kernel 3.14. Now I have sound icon seems that icon works but still no sound :(
I will post the output shortly because now I got an error with devpty and I cannot open xfce4-terminal :(
_________________
Compile The Universe
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Sun Apr 06, 2014 3:08 pm    Post subject: Reply with quote

Ok. I am back. I fixed the problem and now I have terminal. Also now my camera works! I show my face in google talk plugin :)
Now let's go for sound.
This is the output of the command

Code:
ember@gentoo ~ $ sudo lspci -k
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
   Subsystem: Lenovo Device 3977
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
   Subsystem: Lenovo Device 3904
   Kernel driver in use: i915
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
   Subsystem: Lenovo Device 3977
   Kernel driver in use: xhci_hcd
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
   Subsystem: Lenovo Device 3977
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
   Subsystem: Lenovo Device 3977
   Kernel driver in use: ehci-pci
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
   Subsystem: Lenovo Device 3977
   Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
   Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
   Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
   Subsystem: Lenovo Device 3977
   Kernel driver in use: ehci-pci
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
   Subsystem: Lenovo Device 3977
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
   Subsystem: Lenovo Device 3977
   Kernel driver in use: ahci
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
   Subsystem: Lenovo Device 3977
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
   Subsystem: Lenovo Device 3977
   Kernel driver in use: r8169
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
   Subsystem: Intel Corporation Centrino Wireless-N 2230 BGN
   Kernel modules: iwlwifi


Ps: Me too I don't speak very good English. So feel nice with that :)
_________________
Compile The Universe
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1109
Location: switzerland

PostPosted: Sun Apr 06, 2014 4:46 pm    Post subject: Reply with quote

first of all compile the kernel with sound as module and not built-in

to view which others modules needed for the sound you can run the lsmod command when booting from the install dvd, you can view all dependencies of snd_hda_intel
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Sun Apr 06, 2014 4:52 pm    Post subject: Reply with quote

ok. I will do it now and I will post ther results
lsmod return me snd_hda_intel snd_hda_realtek snd_hda_hdmi
_________________
Compile The Universe
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Sun Apr 06, 2014 5:16 pm    Post subject: Reply with quote

Ok. I set intel and realtek_codec as module and rebuild kernel. Next step?
_________________
Compile The Universe
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1109
Location: switzerland

PostPosted: Sun Apr 06, 2014 5:43 pm    Post subject: Reply with quote

compile with all 3 modules, snd_hda_intel, snd_hda_realtek and snd_hda_hdmi

you already compiled the package alsa-utils?

after that you have to start alsasound service (with command /etc/init.d/alsasound start)
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Sun Apr 06, 2014 5:52 pm    Post subject: Reply with quote

I have alsa-utils and I started alsasound. On kernel:
Sound Card Support -> PCI Sound devices -> Intel HD Audio (Module) ->
Build hwdep interface for HD-audio reconfiguration + Allow dynamic codec reconfiguration - Ticked
Support jack plugin notification via input layer - Ticked
Build Realtek HD-audio codec support - As module with bullet
Build HDMI/DisplayPort HD-audio codec support - As module with bullet.
Am I ok?
_________________
Compile The Universe
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1109
Location: switzerland

PostPosted: Sun Apr 06, 2014 6:15 pm    Post subject: Reply with quote

I think yes, it's ok.

run alsamixer to unmute the sound card (press M on the master channel to mute/unmute) if it doesn't work
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Sun Apr 06, 2014 6:26 pm    Post subject: Reply with quote

Alsamixer says that this sound device does not have any conrols
_________________
Compile The Universe
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1109
Location: switzerland

PostPosted: Sun Apr 06, 2014 6:36 pm    Post subject: Reply with quote

the modules are loaded?

post the output of lsmod
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Sun Apr 06, 2014 6:53 pm    Post subject: Reply with quote

No. Lsmod return none module. It shouldn't be autoloaded? Also one more question. Why I should use modules? All this drivers, I build them into kernel as part of kernel. Is bad idea? Why? I use modules for things where I maybe use them but I don't want them now. So I build them as modules in the case of I need them in the future.
_________________
Compile The Universe
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Mon Apr 07, 2014 8:33 am    Post subject: Reply with quote

Ok. I took pictures of exactly everything.
http://s21.postimg.org/bwt5nnqfb/image.png
http://s23.postimg.org/5in4arbij/image.png
http://s11.postimg.org/p2obrpbyb/image.png
http://s29.postimg.org/tngsf5opz/image.png
http://s18.postimg.org/57tu0igih/image.png
http://s30.postimg.org/8mzh2c3m9/image.png
http://s27.postimg.org/p8wd3r5sj/image.png
http://s28.postimg.org/g3etijst9/image.png

My cat /proc/asound/cards

Code:
 0 [Loopback       ]: Loopback - Loopback
                      Loopback 1
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xd0610000 irq 44


My cat /proc/asound/oss/sndstat
Code:

Sound Driver:3.8.1a-980706 (ALSA emulation code)
Kernel: Linux gentoo 3.14.0-gentoo #2 SMP Sun Apr 6 17:05:36 EEST 2014 x86_64
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
Loopback 1
HDA Intel PCH at 0xd0610000 irq 44

Audio devices:
0: Loopback PCM (DUPLEX)
1: ALC269VC Analog (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
7: system timer

Mixers:
0: Loopback Mixer
1: Intel PantherPoint HDMI


I set Alsasound into boot process.
I installed mpg123 & mpg321
I installed alsa-utils & alsa-oss

Restarting alsasound
Code:

ember@gentoo ~ $ sudo /etc/init.d/alsasound restart
Password:
 * WARNING: you are stopping a boot service
 * Storing ALSA Mixer Levels ...                                          [ ok ]
 * Restoring Mixer Levels ...                                             [ ok ]

What I miss? It should work!
_________________
Compile The Universe
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1109
Location: switzerland

PostPosted: Mon Apr 07, 2014 11:17 am    Post subject: Reply with quote

yes, it should works! :?

I don't understand why it doesn't works...

what are you doing to test the sound? with which package do you test?

try to test sound with this command

speaker-test -t wav

(to end the test ctrl-c)
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Mon Apr 07, 2014 12:04 pm    Post subject: Reply with quote

I just open youtube to see a video. Video works but sound not. I don't have any player yet. But also I tried the jack of laptop and I don't hear any sound even there too.
speaker-test -t wav works but I don't hear any sound :(
_________________
Compile The Universe


Last edited by sk8harddiefast on Mon Apr 07, 2014 12:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1109
Location: switzerland

PostPosted: Mon Apr 07, 2014 12:07 pm    Post subject: Reply with quote

it's not a good test youtube (need some plugins), try the command above
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Mon Apr 07, 2014 12:08 pm    Post subject: Reply with quote

I tried it but still no sound :(
_________________
Compile The Universe
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1109
Location: switzerland

PostPosted: Mon Apr 07, 2014 12:18 pm    Post subject: Reply with quote

I'm very sorry but I know any more suggest you :cry:

did you already read this link? http://wiki.gentoo.org/wiki/ALSA

also this is helpfull http://docs.huihoo.com/gentoo/resources/document-listing/alsa-guide.html

and this https://www.gentoo.org/doc/it/alsa-guide.xml (if you understand italian)
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Mon Apr 07, 2014 1:39 pm    Post subject: Reply with quote

Yes. I have read them :(
_________________
Compile The Universe
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1109
Location: switzerland

PostPosted: Mon Apr 07, 2014 1:43 pm    Post subject: Reply with quote

we can try again...can you post all the lsmod result of the installer dvd please

perhaps we miss some modules
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Mon Apr 07, 2014 2:05 pm    Post subject: Reply with quote

Ok. Here we are:
Code:

Module                  Size  Used by
fan                     2393  0
ipv6                  234115  36
arc4                    1775  2
iwldvm                100413  0
mac80211              213617  1 iwldvm
snd_hda_codec_hdmi     25527  1
snd_hda_codec_realtek    34348  1
snd_hda_intel          23724  0
snd_hda_codec          98368  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_pcm                59467  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc          5978  2 snd_pcm,snd_hda_intel
snd_timer              15358  1 snd_pcm
x86_pkg_temp_thermal     4333  0
iwlwifi                64184  1 iwldvm
snd                    48492  6 snd_hda_codec_realtek,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec,snd_hda_intel
acpi_cpufreq            6411  1
freq_table              2164  1 acpi_cpufreq
ideapad_laptop          6396  0
cfg80211              166777  3 iwlwifi,mac80211,iwldvm
soundcore               4290  1 snd
sparse_keymap           2376  1 ideapad_laptop
r8169                  47304  0
rfkill                 13283  2 cfg80211,ideapad_laptop
processor              23303  9 acpi_cpufreq
video                  10716  0
thermal                 8068  0
backlight               4394  2 video,ideapad_laptop
ac                      3076  0
battery                 7141  0
button                  4325  0
thermal_sys            16627  5 fan,video,thermal,processor,x86_pkg_temp_thermal
xts                     2615  0
gf128mul                5146  1 xts
aes_x86_64              7199  0
sha256_generic          9508  0
iscsi_tcp               7580  0
libiscsi_tcp           10362  1 iscsi_tcp
libiscsi               30668  2 libiscsi_tcp,iscsi_tcp
tg3                   126742  0
hwmon                   1193  2 tg3,thermal_sys
libphy                 16794  1 tg3
ptp                     6556  1 tg3
pps_core                5720  1 ptp
e1000                  86441  0
fuse                   60514  1
jfs                   134305  0
btrfs                 605688  0
zlib_deflate           17419  1 btrfs
multipath               5136  0
linear                  3103  0
raid0                   6443  0
dm_raid                14604  0
raid10                 33921  1 dm_raid
raid1                  22884  1 dm_raid
raid456                49684  1 dm_raid
async_pq                3524  1 raid456
async_xor               2593  2 async_pq,raid456
xor                    10008  2 btrfs,async_xor
async_memcpy            1278  1 raid456
async_raid6_recov       1209  1 raid456
raid6_pq               89350  3 async_pq,btrfs,async_raid6_recov
async_tx                1670  5 async_pq,raid456,async_xor,async_memcpy,async_raid6_recov
dm_snapshot            23205  0
dm_crypt               12518  0
dm_mirror              11212  0
dm_region_hash          6167  1 dm_mirror
dm_log                  7258  2 dm_region_hash,dm_mirror
dm_mod                 67159  5 dm_raid,dm_log,dm_mirror,dm_crypt,dm_snapshot
hid_sunplus             1368  0
hid_sony                5346  0
hid_samsung             2717  0
hid_pl                  1304  0
hid_petalynx            1833  0
hid_gyration            1987  0
sl811_hcd               8871  0
xhci_hcd               80588  0
ohci_hcd               15761  0
uhci_hcd               18625  0
usb_storage            42574  0
mpt2sas               118870  0
raid_class              3108  1 mpt2sas
aic94xx                62969  0
libsas                 54547  1 aic94xx
qla2xxx               453140  0
megaraid_sas           71960  0
megaraid_mbox          23564  0
megaraid_mm             6648  1 megaraid_mbox
megaraid               34209  0
aacraid                67500  0
sx8                    10981  0
DAC960                 60926  0
hpsa                   43407  0
cciss                  44110  0
3w_9xxx                28946  0
3w_xxxx                20652  0
mptsas                 43001  0
scsi_transport_sas     20979  4 mpt2sas,libsas,mptsas,aic94xx
mptfc                  12133  0
scsi_transport_fc      38597  2 qla2xxx,mptfc
scsi_tgt                8024  1 scsi_transport_fc
mptspi                 13278  0
mptscsih               23455  3 mptfc,mptsas,mptspi
mptbase                74980  4 mptfc,mptsas,mptspi,mptscsih
atp870u                22041  0
dc395x                 26258  0
qla1280                19487  0
dmx3191d                9041  0
sym53c8xx              60900  0
gdth                   71181  0
advansys               43936  0
initio                 14572  0
BusLogic               18983  0
arcmsr                 23410  0
aic7xxx               103026  0
aic79xx               117681  0
scsi_transport_spi     18763  5 mptspi,sym53c8xx,aic79xx,aic7xxx,dmx3191d
sg                     23902  0
pdc_adma                5101  0
sata_inic162x           6309  0
sata_mv                22633  0
ata_piix               23607  0
ahci                   21888  1
libahci                18253  1 ahci
sata_qstor              4884  0
sata_vsc                3849  0
sata_uli                2916  0
sata_sis                3565  0
sata_sx4                7712  0
sata_nv                17826  0
sata_via                7491  0
sata_svw                4157  0
sata_sil24              9895  0
sata_sil                7039  0
sata_promise            9511  0
pata_sl82c105           3517  0
pata_cs5530             4120  0
pata_cs5520             3502  0
pata_via                8172  0
pata_jmicron            2307  0
pata_marvell            2803  0
pata_sis               10182  1 sata_sis
pata_netcell            2121  0
pata_sc1200             2882  0
pata_pdc202xx_old       4302  0
pata_triflex            3047  0
pata_atiixp             4371  0
pata_opti               2681  0
pata_amd               10063  0
pata_ali                8981  0
pata_it8213             3338  0
pata_pcmcia             9628  0
pcmcia                 28731  1 pata_pcmcia
pcmcia_core            10511  1 pcmcia
pata_ns87415            3140  0
pata_ns87410            2680  0
pata_serverworks        5020  0
pata_artop              4774  0
pata_it821x             8157  0
pata_optidma            4353  0
pata_hpt3x2n            5324  0
pata_hpt3x3             2928  0
pata_hpt37x            10816  0
pata_hpt366             4944  0
pata_cmd64x             6770  0
pata_efar               3486  0
pata_rz1000             2637  0
pata_sil680             4481  0
pata_radisys            2834  0
pata_pdc2027x           6083  0
pata_mpiix              2774  0
libata                138614  52 ahci,pata_pdc202xx_old,sata_inic162x,pata_efar,pata_opti,sata_sil,sata_sis,sata_sx4,sata_svw,sata_uli,sata_via,sata_vsc,pata_marvell,sata_promise,sata_mv,sata_nv,libahci,sata_qstor,sata_sil24,pata_netcell,pata_ali,pata_amd,pata_sis,pata_via,pata_sl82c105,pata_triflex,pata_ns87410,pata_ns87415,libsas,pdc_adma,pata_artop,pata_atiixp,pata_mpiix,pata_cmd64x,pata_cs5520,pata_cs5530,pata_hpt3x2n,pata_optidma,pata_hpt366,pata_hpt37x,pata_hpt3x3,pata_it8213,pata_it821x,pata_serverworks,pata_pcmcia,pata_sc1200,pata_sil680,pata_rz1000,ata_piix,pata_jmicron,pata_radisys,pata_pdc2027x

_________________
Compile The Universe
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Mon Apr 07, 2014 6:59 pm    Post subject: Reply with quote

Also I want to mention that my microphone works perfect. I don't know if has any relation with the sound. I say this because we speak for a laptop and maybe this too are not separated.
_________________
Compile The Universe
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum