Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Invalid atom in /etc/portage/package.use
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 197
Location: Wien

PostPosted: Tue Apr 29, 2014 10:34 am    Post subject: [gelöst] Invalid atom in /etc/portage/package.use Reply with quote

Hallo,
möchte mir gerade ein neues Gentoo-amd64 System aufsetzen.
Habe noch gar nicht so viele Pakete installiert, da kommt
von emerge bzw. portage schon ständig folgende Meldung:
Code:
 
--- Invalid atom in /etc/portage/package.use: dev-lang/python-2.7.5-r3

Was bedeutet das und wie bekommt man es weg.
Bitte um Hilfe


Last edited by oliver2104 on Thu May 01, 2014 12:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Tue Apr 29, 2014 11:02 am    Post subject: Reply with quote

das heißt du hast einen fehlerhaften eintrag in dieser datei.
Back to top
View user's profile Send private message
mvaterlaus
Apprentice
Apprentice


Joined: 01 Oct 2010
Posts: 202
Location: Switzerland

PostPosted: Tue Apr 29, 2014 11:34 am    Post subject: Reply with quote

hi,
das bedeutet, dass der folgende eintrag fehler aufweist:

Code:
--- Invalid atom in /etc/portage/package.use: dev-lang/python-2.7.5-r3


zum einen hat dieser eintrag keine use flags, die gesetzt oder entfernt werden (vorausgesetzt, du hast nicht vergessen, diese zu posten). die zweite sache ist, dass du keinen der "modifier" <,> oder = davor hast. immer wenn du eine genaue paketversion angibst, musst du einen dieser modifier setzten. da ich mal davon ausgehe, dass du useflags für genau diese version setzten willst, sollte die zeile wie folgt aussehen:

Code:

# cat /etc/portage/package.use
...
=dev-lang/python-2.7.5-r3 +useflag -anderes_useflag
...

_________________
For calming down your eyes or clearing your mind: www.patrickwehli.ch
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 197
Location: Wien

PostPosted: Thu May 01, 2014 12:43 pm    Post subject: [gelöst] Invalid atom in /etc/portage/package.use Reply with quote

Danke für die Antworten,

Hatte in /etc/portage/package.use den Eintrag:
Code:

dev-lang/python-2.7.5-r3 sqlite

Ich habe glaube die Datei /etc/portage/package.use von einer alten
Installation ohne sie genau anzusehen, in die neue Installation übernommen.
Jedenfalls hab ich den Eintrag jetzt auskommentiert und das Problem ist weg.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum