Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error updating gawk
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
remu
n00b
n00b


Joined: 29 Apr 2014
Posts: 1

PostPosted: Tue Apr 29, 2014 4:47 pm    Post subject: Error updating gawk Reply with quote

I am trying to update gawk from version 4.0.1 to 4.1.1-r1 and get the following error when running 'emerge -uv gawk':

Code:

i686-pc-linux-gnu-gcc -DDEFPATH='".:/usr/share/awk"' -DDEFLIBPATH="\"/usr/lib/gawk\"" -DSHLIBEXT="\"so"\" -DHAVE_CONFIG_H -DGAWK -DLOCALEDIR='"/usr/share/locale"' -I.     -O2 -march=i686 -pipe -DNDEBUG -c debug.c
i686-pc-linux-gnu-gcc -DDEFPATH='".:/usr/share/awk"' -DDEFLIBPATH="\"/usr/lib/gawk\"" -DSHLIBEXT="\"so"\" -DHAVE_CONFIG_H -DGAWK -DLOCALEDIR='"/usr/share/locale"' -I.     -O2 -march=i686 -pipe -DNDEBUG -c dfa.c
dfa.c:1002: error: expected declaration specifiers or ‘...’ before ‘(’ token
dfa.c:1004: error: expected declaration specifiers or ‘...’ before string constant
dfa.c:1002: warning: data definition has no type or storage class
Makefile:687: recipe for target 'dfa.o' failed
make[2]: *** [dfa.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory '/var/tmp/portage/sys-apps/gawk-4.1.1-r1/work/gawk-4.1.1'
Makefile:727: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/sys-apps/gawk-4.1.1-r1/work/gawk-4.1.1'
Makefile:546: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: sys-apps/gawk-4.1.1-r1::gentoo failed (compile phase):
 *   emake failed


Heres the output of emerge --info '=sys-apps/gawk-4.1.1-r1::gentoo'

Code:

Portage 2.2.8-r1 (default/linux/x86/13.0, gcc-4.4.7, glibc-2.19, 2.6.35-gentoo-r12 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.35-gentoo-r12-i686-Intel-R-_Xeon-R-_CPU_E5-2630_0_@_2.30GHz-with-gentoo-2.2
KiB Mem:     2070512 total,   1009204 free
KiB Swap:     530140 total,    530140 free
Timestamp of tree: Tue, 29 Apr 2014 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p37
dev-lang/python:          2.6.5-r3, 2.7.6, 3.1.2-r4, 3.2.3-r2, 3.3.5
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.11.1, 1.12.6, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.4.7, 4.5.4, 4.6.4, 4.8.2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.14 (virtual/os-headers)
sys-libs/glibc:           2.19
Repositories: gentoo
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
USE="acl apache2 berkdb bzip2 cgi cli cracklib crypt curl cxx dri fortran gd gdbm iconv ipv6 jpeg ldap modules mysql ncurses nls nptl openmp pam pcre pear perl php png readline session snmp ssl tcpd unicode x86 xml zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authnz_ldap ldap access_compat authn_core authz_core socache_shmcb autoindex setenvif asis proxy proxy_ajp access proxy_http alias auth auth_basic mime actions auth_digest authn_alias authn_default authz_host headers log_config proxy_connect rewrite vhost_alias cgi dir imap unixd cgid" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4 php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Wed Apr 30, 2014 11:14 am    Post subject: Re: Error updating gawk Reply with quote

remu wrote:
Code:
-DSHLIBEXT="\"so"\" -DHAVE_CONFIG_H -DGAWK -DLOCALEDIR='"/usr/share/locale"' -I.     -O2 -march=i686 -pipe -DNDEBUG -c dfa.c
dfa.c:1002: error: expected declaration specifiers or ‘...’ before ‘(’ token
dfa.c:1004: error: expected declaration specifiers or ‘...’ before string constant
dfa.c:1002: warning: data definition has no type or storage class

remu ... as this section of the code deals with unicode for toupper I wonder if this hasn't something to do with your locale (somewhat of a guess).

remu wrote:
Code:
sys-devel/gcc:  4.4.7, 4.5.4, 4.6.4, 4.8.2

You should probably let us know which of these is the currently active gcc ('gcc-config --list') ... and btw, you could probably depclean some of these versions ... unless of course you have some reason to have them available.

remu wrote:
Code:
LANG="en_GB.UTF-8"
LC_ALL="en_US.utf8"

What is setting LC_ALL? ... this isn't set by /etc/env.d/02locale only LANG. LC_ALL will overide all LC_* settings and its best not to set this. Also, are both of these locales available in /etc/locale.gen?

/etc/env.d/02locale
Code:
LANG="en_GB.utf8"
LC_COLLATE="C"

Anyhow, you might want to set LANG="C" in make.conf as IME some packages (often gnu) have issues otherwise ... you might try the following (again, this is a wild guess).

Code:
# LC_ALL="" LANG="C" emerge --oneshot =sys-apps/gawk-4.1.1-r1

HTH & best ... khay
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13845

PostPosted: Thu May 01, 2014 2:26 am    Post subject: Re: Error updating gawk Reply with quote

khayyam wrote:
remu wrote:
Code:
sys-devel/gcc:  4.4.7, 4.5.4, 4.6.4, 4.8.2

You should probably let us know which of these is the currently active gcc ('gcc-config --list')
He did, by way of posting the full emerge --info output. The gcc referenced in the first line is the active gcc. See /usr/lib/portage/pym/_emerge/actions.py method getgccversion.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Thu May 01, 2014 2:53 am    Post subject: Re: Error updating gawk Reply with quote

Hu wrote:
He did, by way of posting the full emerge --info output. The gcc referenced in the first line is the active gcc.

Hu ... indeed, and doh!

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum