Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Amarok Collection Fehler
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3116
Location: Berlin

PostPosted: Tue Apr 29, 2014 5:03 pm    Post subject: Amarok Collection Fehler Reply with quote

Hallo,
Amarok scannt die Musiksammlung nicht mehr. IN der Konsole sieht das so aus: (Auszug)
Code:
It is of size 1048576 bytes but we need more than 2777782 bytes.
void CollectionScanner::ScanningState::setLastFile(const QString&) QSharedMemory is too small to hold the data.


Code:
dev-db/mariadb-5.5.37-r1  USE="community embedded pam perl ssl -cluster -debug -extraengine -jemalloc -latin1 -max-idx-128 -minimal -oqgraph -profiling (-selinux) -sphinx -static -static-libs -systemtap -tcmalloc {-test} -tokudb"
Code:
media-sound/amarok-2.8.0-r1:4  USE="cdda handbook ipod mtp ofa opengl semantic-desktop utils (-aqua) -debug -embedded -lastfm -mp3tunes {-test}"
Back to top
View user's profile Send private message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 71

PostPosted: Tue Apr 29, 2014 8:14 pm    Post subject: Amarok Collection Fehler Reply with quote

Ich bin bei mysql-5.1.70 als Datenbankuntersatz; amarok ist auf dem gleichen Versionsstand wie bei Dir mit den USE-Flags cdda embedded handbook opengl semantic-desktop utils -aqua -debug -ipod -lastfm -mp3tunes -mtp -ofa -test LINGUAS="de

Leider bin ich nicht der Datenbankexperte, der in diesem Ansatz (externe Datenbank, Tabellenreparatur oder Neuaufsetzen für Amarok) eine Idee hat.
Ich hatte in meiner Erfahrung im Umgang mit Amarok einen ähnlichen Effekt (Sammlungsaktualisierung funtionierte nicht, Playlists vermurkst, Coveranzeige teilweise weg, obwohl in den Verzeichnissen nachweislich vorhanden etc. pp). Nach verschiedensten Experimenten und Recherchen habe ich mich entschieden, bei Amarok das embedded USE-Flag zu setzen und habe seitdem keine Probleme mehr gehabt. Ob das jetzt die optimale Lösung ist, weiß ich nicht - aber es läuft. mysql wird zum runlevel default gestartet. Mit der mariadb sollte es m. E. genauso funktionieren. Sowohl bei mariadb mit embedded compiliert, als auch bei mysql bewirkt es: Build embedded server (libmysqld)

und bei amarok bewirkt das einschalten: Use libmysqld, MySQL embedded server library. Try disabling this if you encounter -PIC related in amarok, it will make amarok rely only on standalone MySQL server.

Gruß demiurg
_________________
Kernel 5.xx-gentoo
GCC 9.xx
Profile amd64/17.1/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F31
ATI RX580
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum