Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
MicroSD keeps disppearing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
kyu0114
n00b
n00b


Joined: 05 May 2014
Posts: 3
Location: United Kingdom

PostPosted: Mon May 05, 2014 9:38 am    Post subject: MicroSD keeps disppearing Reply with quote

I have a strange situation where MicroSD keeps disappearing at times.
I have LG Z360 ultrabook which has 2 microSD slots. I never experienced this problem when I was just using windows 8 but after installing gentoo (dual boot) I started to notice the problem. Then I figured out when this happens and how to solve it.

When I restart from gentoo, neither gentoo nor windows8 detects the existence of microsds (fdisk doesn't recognise nor gparted.) They are 64 gb, exfat and I have fuse installed to access them.
The only way to get them back is to properly shutdown from Windows or using 'shutdown -h now' from gentoo. After doing so they appear on Windows and Gentoo. When they appear they work fine. Also if I shutdown using shutdown button on KDE, its a bit random.

I'm sure its not normal and I'd appreciate if if someone comes up with a solution!
Thank you in advance.
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1351

PostPosted: Mon May 19, 2014 9:07 pm    Post subject: Reply with quote

Firstly Welcome to Gentoo.

I am not sure how you are using these drives, did you make an entry for them in /ets/fstab?
are you using them to boot?
Cheers
Turtle
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
kyu0114
n00b
n00b


Joined: 05 May 2014
Posts: 3
Location: United Kingdom

PostPosted: Sat Jun 28, 2014 12:05 am    Post subject: Reply with quote

It is not in fstab but sometimes it appears in Dolphin and at other times it doesnt. When it doesnt, i figured out it will reappear after reloading xhci_hcd. But annoying thay i have to keep doing it as sometime later it disappears again! (Physically reinserting microsd doesnt work..)
I use ssd to dual boot between windows 8.1 and gentoo. Everything else works fine but microsd.
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1351

PostPosted: Sun Jul 06, 2014 3:02 am    Post subject: Reply with quote

Check out this this thread
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum