Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Interactive boot not working anymore?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
leifbk
Guru
Guru


Joined: 05 Jan 2004
Posts: 373
Location: Bærum, Norway

PostPosted: Thu May 08, 2014 2:28 pm    Post subject: [SOLVED] Interactive boot not working anymore? Reply with quote

A week or two ago my computer just froze and the screen went black, and all I could do was to turn the power off and on. I can't figure out what really happened, but the boot messages indicated a problem with the video driver, which at the time was nvidia-driver from ~arch. When X was started, no watch, the screen went black, and everything hung again. I rebooted, and hit i (for interactive boot) dozens of times, but the boot sequence just went on its merry way to oblivion. Finally I had to boot from a two years old live CD, chroot, "rc-update del xdm default", reboot, edit /etc/portage/package.keywords and comment out "x11-drivers/nvidia-drivers ~amd64", then "emerge nvidia-drivers" to get the last stable version, and reboot again. My desktop came back, and everything has worked okay since then.

The borked video driver isn't the main point here. I just don't get why I couldn't enter interactive mode during boot, in order to not try to start X. I still haven't quite recovered from the incident, so I haven't added xdm to rc default again; I prefer to login to root and enter "/etc/init.d/xdm start && exit" until I've got this squared out.
_________________
Grumpy old man


Last edited by leifbk on Thu May 08, 2014 5:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
jfp
Apprentice
Apprentice


Joined: 08 Jul 2007
Posts: 279
Location: Virginia, USA

PostPosted: Thu May 08, 2014 2:38 pm    Post subject: Reply with quote

One possibility:
Check /etc/rc.conf:
Quote:
# Set rc_interactive to "YES" and you'll be able to press the I key during
# boot so you can choose to start specific services. Set to "NO" to disable
# this feature. This feature is automatically disabled if rc_parallel is
# set to YES.
rc_interactive="YES"

_________________
jfp
Back to top
View user's profile Send private message
leifbk
Guru
Guru


Joined: 05 Jan 2004
Posts: 373
Location: Bærum, Norway

PostPosted: Thu May 08, 2014 2:45 pm    Post subject: Reply with quote

jfp wrote:
One possibility:
Check /etc/rc.conf:
Quote:
# Set rc_interactive to "YES" and you'll be able to press the I key during
# boot so you can choose to start specific services. Set to "NO" to disable
# this feature. This feature is automatically disabled if rc_parallel is
# set to YES.
rc_interactive="YES"


Code:
balapapa ~ # grep -i interactive /etc/rc.conf
# Set rc_interactive to "YES" and you'll be able to press the I key during
#rc_interactive="YES"


Sure, that's it. I removed the hash sign now :)

Thank you very much!
_________________
Grumpy old man
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum