Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Laptop Battery not charging
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
d3x73r
n00b
n00b


Joined: 16 Apr 2010
Posts: 55
Location: Bahia/Brazil

PostPosted: Sat May 17, 2014 5:06 am    Post subject: Laptop Battery not charging Reply with quote

Hey guys!

After recent upgrades in packages and kernel my battery doesn't want to charge until its full capacity (whitch have decreased to 89%).
Even when the AC power is plugged it stuks in 67% of its capacity.

Here is some debug:

Code:
$ upower -d
Device: /org/freedesktop/UPower/devices/line_power_ADP0
  native-path:          ADP0
  power supply:         yes
  updated:              Sáb 17 Mai 2014 01:52:05 BRT (31 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    online:             no

Device: /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          BAT0
  vendor:               SIMPLO
  model:                Dell
  serial:               1607
  power supply:         yes
  updated:              Sáb 17 Mai 2014 01:52:11 BRT (25 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               discharging
    energy:              38,1544 Wh
    energy-empty:        0 Wh
    energy-full:         56,4916 Wh
    energy-full-design:  65,12 Wh
    energy-rate:         29,9404 W
    voltage:             15,939 V
    time to empty:       1,3 hours
    percentage:          67%
    capacity:            86,75%
    technology:          lithium-ion
  History (rate):
    1400302330  29,940  discharging
    1400302329  29,437  discharging
    1400302327  32,353  discharging

Daemon:
  daemon-version:  0.9.23
  on-battery:      yes
  on-low-battery:  no
  lid-is-closed:   no
  lid-is-present:  yes
  is-docked:       no

Code:
$ upower -d
Device: /org/freedesktop/UPower/devices/line_power_ADP0
  native-path:          ADP0
  power supply:         yes
  updated:              Sáb 17 Mai 2014 01:53:29 BRT (647 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    online:             yes

Device: /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          BAT0
  vendor:               SIMPLO
  model:                Dell
  serial:               1607
  power supply:         yes
  updated:              Sáb 17 Mai 2014 02:04:05 BRT (11 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               charging
    [b]energy:              39,0424 Wh[/b]
    energy-empty:        0 Wh
    [b]energy-full:         56,4916 Wh[/b]
    energy-full-design:  65,12 Wh
    [b]energy-rate:         0,0148 W[/b]
    voltage:             16,278 V
    percentage:          69%
    capacity:            86,75%
    technology:          lithium-ion

Daemon:
  daemon-version:  0.9.23
  on-battery:      no
  on-low-battery:  no
  lid-is-closed:   no
  lid-is-present:  yes
  is-docked:       no


Note to the energy rate value. I tested time after time and its value was decreasing ultil the result above. It means that althought the capacity is 89%, it is charging to about only 68 or 69%.

Code:
$ cat /usr/src/linux/.config | grep CONFIG_ACPI_BATTERY
CONFIG_ACPI_BATTERY=y


Code:
$ acpi-batt-status
On AC Power; Battery BAT0 charging, currently at 68%, 1184:00 remaining


Does anyone know any related bug or something else? I did not change any configuration and I have laptop-mode-tools installed. What else could I do?
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7273
Location: almost Mile High in the USA

PostPosted: Sat May 17, 2014 9:37 am    Post subject: Reply with quote

Laptop batteries tend to be handled by hardware and you're only seeing different numbers reported now. It's probably charging as much as it did in the past but reporting different numbers. Quite possibly the problem has existed but exasperated due to the new software install. Can you confirm with an old livecd that the battery truly is acting "different" than it was before?

I suspect your battery has degraded to a point where it's really noticeable now, perhaps well past the 89% mark. Might want to discharge/recharge the battery to let the smart battery/microcontroller on the battery figure out the real battery condition.

But it may very well be some software behavior change. You may also want to change back to the old kernel to see if the behavior truly changed? What versions of the kernel was it and is it now?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1403
Location: Adelaide/Australia

PostPosted: Mon May 19, 2014 12:25 am    Post subject: Reply with quote

I posted an article regarding unhandled ACPI events.

However, I have noticed that my laptop thinks it's not docked, when it is, as well as my batteries reporting low charge.

I think the low charge is simple degradation of my batteries, but the problem that my laptop reports it is not docked when it is.

I thought I would link the topic here.

ACPI event unhandled: battery
_________________
...Lyall
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum