Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Merkwürdiges Tastaturproblem unter X
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
TheSmallOne
Guru
Guru


Joined: 22 Jan 2005
Posts: 461
Location: Germany

PostPosted: Sun May 18, 2014 10:32 am    Post subject: Merkwürdiges Tastaturproblem unter X Reply with quote

Hi,
ich habe ein sehr merkwürdiges Tastaturproblem. Ich weiß nur nicht so recht, wo ich zu erklären anfangen soll, da mein Setup als solches schon sehr speziell ist und es daher vermutlich niemanden geben wird, der das Problem überhaupt nachvollziehen kann.

Also ich besitze eine Truly-Ergonomic-Tastatur, die ich mit einem leicht modifizierten Neo2-Layout betreibe.
Dafür habe ich mir unter /usr/share/X11/xkb/{geometry,symbols,keycodes} eigene Dateien angelegt und die evdev-rules-Datei entsprechend modifiziert.
Dieses Setup hat auch für die letzten zwei Jahre einwandfrei funktioniert und auch diverse World-Updates überstanden.

Nach meinem letzten World-Update habe ich jedoch ein extrem merkwürdiges Verhalten: Einzelne Tasten funktionieren nicht, bzw. sind mit völlig anderen Funktionen belegt. Darüber hinaus ist dies offenbar vom jeweils aktiven Window-Manager abhängig.

Mal als Beispiel: Starte ich den X-Server komplett allein und völlig ohne Window-Manager und öffne ein Xterm zeigt sich das folgende Verhalten: Die meisten Tasten sind so belegt, wie ich es eigentlich erwarten würde. Bei den Tasten, die mit x,w,ä und q belegt sind, ist es jedoch so, dass ein Drücken der Taste zusammen mit der als Shift deklarierten Taste nicht den gewünschten Großbuchstaben hervorbringt, wie es bei den anderen Tasten der Fall ist. Stattdessen führt z.B. ein Drücken des großen Q (also das, was das große Q sein sollte) zu einer Art „Schrift vergrößern”-Funktion.
Wirklich eigenartig ist jedoch: Starte ich aus dem xterm heraus das Programm xev und lasse mir den Keycode und das dafür belegte Zeichen anzeigen, so bekomme ich die korrekten Angaben (also da steht, dass ein großes Q herauskommen müsste).

Wie bereits am Anfang beschrieben ändert sich das Verhalten je nach Window-Manager. Starte ich also metacity, funktionieren die besagten Tasten völlig problemlos, dafür habe ich andere Tasten, die herumspinnen. Die als h deklarierte Taste führt zum Beispiel zu einem Minimieren der Fenster. In xev wird hier auch der keycode gar nicht mehr richtig übermittelt.
Unter xfwm4 hingegen reagiert eine meiner beiden Tabulator-Tasten (hab' mir zwei eingestellt) überhaupt nicht, während hier keine Probleme mit Großbuchstaben oder h zu erkennen sind.

Im Moment bin ich echt ziemlich ratlos, wo ich überhaupt anfangen soll zu suchen, weil sich das Problem so chaotisch zeigt.

Wie gesagt ist schon mein Setup als solches extrem speziell, aber vielleicht hat ja doch irgendjemand einen rettenden Tipp für mich. Ich kann auch gerne alle benötigten Konfig-Dateien zur Verfügung stellen, aber ich schätze ohne die entsprechende Tastatur wird das nicht besonders viel bringen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum