Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kernel 3.14.* and sound cirrus logic
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 352
Location: Den Haag, Netherlands

PostPosted: Tue May 20, 2014 12:30 am    Post subject: kernel 3.14.* and sound cirrus logic Reply with quote

With kernel 3.14.* my sound does not work anymore:

Code:
May 20 01:00:53 bergwerf kernel: snd_cs46xx 0000:05:00.0: Direct firmware load failed with error -2
May 20 01:00:53 bergwerf kernel: snd_cs46xx 0000:05:00.0: Falling back to user helper


So I am stuck with kernel 3.13.7

Is there a fix?
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Tue May 20, 2014 5:38 am    Post subject: Reply with quote

Yet another licensing issue I presume.
As you will notice, it is somehow recurrent.
The solution is there : https://bugzilla.kernel.org/show_bug.cgi?id=10750
_________________
Back to top
View user's profile Send private message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 352
Location: Den Haag, Netherlands

PostPosted: Tue May 20, 2014 6:19 pm    Post subject: Reply with quote

I tried..
firmware seems to be compiled into the kernel, but it doesn't work.

debug messages from kernel:
Code:
May 20 20:07:08 bergwerf kernel: bus: 'pci': add driver snd_cs46xx
May 20 20:07:08 bergwerf kernel: bus: 'pci': driver_probe_device: matched device 0000:05:00.0 with driver snd_cs46
May 20 20:07:08 bergwerf kernel: bus: 'pci': really_probe: probing driver snd_cs46xx with device 0000:05:00.0
May 20 20:07:08 bergwerf kernel: device: 'input2': device_add

May 20 20:07:08 bergwerf kernel: __allocate_fw_buf: fw-cs46xx/cwc4630 buf=ffff8800bbbb2800
May 20 20:07:08 bergwerf kernel: snd_cs46xx 0000:05:00.0: Direct firmware load failed with error -2
May 20 20:07:08 bergwerf kernel: snd_cs46xx 0000:05:00.0: Falling back to user helper
May 20 20:07:08 bergwerf kernel: device: 'cs46xx!cwc4630': device_add
May 20 20:07:08 bergwerf kernel: PM: Adding info for No Bus:cs46xx!cwc4630
May 20 20:07:08 bergwerf kernel: firmware cs46xx!cwc4630: firmware: requesting cs46xx/cwc4630

May 20 20:07:08 bergwerf kernel: PM: Removing info for No Bus:cs46xx!cwc4630
May 20 20:07:08 bergwerf kernel: __fw_free_buf: fw-cs46xx/cwc4630 buf=ffff8800bbbb2800 data=          (null) size=0
May 20 20:07:08 bergwerf kernel: ALSA sound/pci/cs46xx/cs46xx_lib.c:3270 firmware load error [cwc4630]
May 20 20:07:08 bergwerf kernel: snd_cs46xx: probe of 0000:05:00.0 failed with error -2


So back to the old kernel...
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 352
Location: Den Haag, Netherlands

PostPosted: Tue May 20, 2014 11:38 pm    Post subject: Reply with quote

Ok it works now!
I removed my card at the pci sound devices in the kernel config. I thougt perhaps the firmware drivers are enough, but there was still no sound.
So I put my card back in the config and suddenly some modules were installed! And now my sound works again.
So next time I will try without the firmware. Perhaps it was just some stupid error in the kernel config that caused the trouble.
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum