Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Forgot Password / Cant boot from livecd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
skid99
n00b
n00b


Joined: 30 May 2014
Posts: 4

PostPosted: Fri May 30, 2014 2:27 am    Post subject: Forgot Password / Cant boot from livecd Reply with quote

Sorry for the noob question and also for this possibly being in the wrong section. Just completed gentoo install, started last night but finished today. Well i forgot what password i assigned root....... i know i need to load from livecd and mount drives and change it that way but no matter what I do in bios i cant get it to recognize my livecd usb hdd, even turned off all other options for boot devices and it still just goes straight to grub screen. what do i do here? Thanks.
_________________
noob
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Fri May 30, 2014 3:43 am    Post subject: Reply with quote

uhhh you need to change your boot order in bios. on a few machines i have f8 or f2 control boot order on the fly. del esc f12 can usually set it in bios. one of my machines requires the f8 or f2 to get to boot usb media. all you gotta do is remount / chroot to it then run passwd to reset roots password.
Back to top
View user's profile Send private message
skid99
n00b
n00b


Joined: 30 May 2014
Posts: 4

PostPosted: Fri May 30, 2014 4:38 am    Post subject: Reply with quote

no i have the boot order set, usb hdd, then the other two disabled. no other options but usb hdd, it worked with the same settings before I got grub installed.

anyways. new problem. i booted up into my working gentoo install and now i have no connectivity. i cant ping anything and /etc/resolv.conf is blank, i though i copied it over in the livecd environment but now i cant figure it out... lol
_________________
noob
Back to top
View user's profile Send private message
necron
Tux's lil' helper
Tux's lil' helper


Joined: 09 Sep 2010
Posts: 97

PostPosted: Fri May 30, 2014 5:06 am    Post subject: Reply with quote

Try a different USB port (if you still can't boot from the liveusb) and copy the working configuration from there
Back to top
View user's profile Send private message
skid99
n00b
n00b


Joined: 30 May 2014
Posts: 4

PostPosted: Fri May 30, 2014 12:09 pm    Post subject: Reply with quote

necron wrote:
Try a different USB port (if you still can't boot from the liveusb) and copy the working configuration from there


tried them all. no lucks.

it just flashes a grub screen for a split second then gives me my boot options screen
_________________
noob
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1746

PostPosted: Fri May 30, 2014 12:35 pm    Post subject: Reply with quote

Don't you use initramfs generated with genkernel by any chance?
If you run it with "debug" param on kernel command line it will drop you to shell early during boot. While you're there, mount root manualy, chroot into it and run `passwd` to reser root's password.
Then exit chroot, umount root and exit shell to let boot continue
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Fri May 30, 2014 1:34 pm    Post subject: Reply with quote

szatox wrote:
If you run it with "debug" param on kernel command line it will drop you to shell early during boot. While you're there, mount root manualy, chroot into it and run `passwd` to reser root's password.

szatox, skid99, et al ...

whether an initramfs is used or not one can always enter single user mode by passing "softlevel=single" as a kernel parameter, from there you can 'mount -o remount,rw /' and run 'passwd'.

HTH & best ... khay
Back to top
View user's profile Send private message
skid99
n00b
n00b


Joined: 30 May 2014
Posts: 4

PostPosted: Fri May 30, 2014 5:39 pm    Post subject: Reply with quote

Update, I found out my USB hdd which was previously working is now bricked.. i stuck it into my windows laptop to redo the .iso image on it with unetbootin and it could not be formatted..

so i burned a cd and got access to live cd again and resolved my password issue



My noob problems still persist. I can not get eth0 to start when booting into gentoo, and Ive narrowed it down to I didnt add the right modules to the kernel.

Ive discovered that I have a via-rhine onboard NIC. Ive tried adding modules="via-rhine" into /etc/conf.d/modules but that module name is just guesswork as i dont know what the proper one is, and i guess i dont understand how to recompile kernel afterwards to make the module changes take effect... :cry: :cry: :cry: been at this for hours and hours now im about done messing with this lol. Shotgun time approaches :evil:
_________________
noob
Back to top
View user's profile Send private message
jonathan183
Guru
Guru


Joined: 13 Dec 2011
Posts: 309

PostPosted: Fri May 30, 2014 6:33 pm    Post subject: Reply with quote

Try booting from the live cd and check if the network card is detected, if it is run lspci -vnn and check the name of the module the live cd kernel is using.
You can then check you have the module compiled in your custom kernel, load it manually using modprobe and/or add the module to the list of modules to be loaded.

You could check the output of lspci -nn if the above does not work or post it here.


Last edited by jonathan183 on Fri May 30, 2014 6:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1746

PostPosted: Fri May 30, 2014 6:34 pm    Post subject: Reply with quote

khayyam wrote:

whether an initramfs is used or not one can always enter single user mode by passing "softlevel=single" as a kernel parameter, from there you can 'mount -o remount,rw /' and run 'passwd'.

True, but I think default gentoo settings demand root pasword in single mode just as much as it does in any other.


Quote:
Ive discovered that I have a via-rhine onboard NIC. Ive tried adding modules="via-rhine" into /etc/conf.d/modules but that module name is just guesswork asIve discovered that I have a via-rhine onboard NIC. Ive tried adding modules="via-rhine" into /etc/conf.d/modules but that module name is just guesswork (...)
you most likely don't have correct driver compiled at all. I think with up-to-date gentoo it would be loaded automagicaly, even if you didn't have any service configured to use it.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Fri May 30, 2014 6:40 pm    Post subject: Reply with quote

skid99 wrote:
My noob problems still persist. I can not get eth0 to start when booting into gentoo, and Ive narrowed it down to I didnt add the right modules to the kernel.

skid99 ... firstly, your ethernet device is *probably* not called "eth0" due to udev renaming the interface, a quick look at the output of 'ifconfig', or peek in '/sys/class/net/', should provide the current name. You can then choose to disable such renaming (by adding 'net.ifnames=0' to the kernel parameters) or rename /etc/init.d/net.eth0 and your specifications (if any) in /etc/conf.d/net to the renamed device name.

skid99 wrote:
Ive discovered that I have a via-rhine onboard NIC. Ive tried adding modules="via-rhine" into /etc/conf.d/modules but that module name is just guesswork as i dont know what the proper one is, and i guess i dont understand how to recompile kernel afterwards to make the module changes take effect...

That is the correct module name (see: here) but it may not be enabled, checking dmesg and/or the output of 'lspci -k' (from 'sys-apps/pciutils') should show it loading/registered or what driver the device its using (marked "Kernel driver in use:" in the 'lspic -k' output) ... or you can check the driver is enabled in the kernel via the following:

Code:
# grep CONFIG_VIA_RHINE /usr/src/linux/.config

If its "y" or "m", then its either builtin, or a module (respectively) ... "n" equates to disabled. You would need to enable it via 'make menuconfig' and then 'make && make modules_install' (though, by the sounds of it you used genkernel initially, so you may want to run 'genkernel --menuconfig').

HTH & best ... khay

edit: corrected spelling/syntax


Last edited by khayyam on Fri May 30, 2014 6:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Fri May 30, 2014 6:45 pm    Post subject: Reply with quote

szatox wrote:
khayyam wrote:
whether an initramfs is used or not one can always enter single user mode by passing "softlevel=single" as a kernel parameter, from there you can 'mount -o remount,rw /' and run 'passwd'.

True, but I think default gentoo settings demand root pasword in single mode just as much as it does in any other.

szatox ... yeah, I forgot that it uses 'sulogin', its been a while since I used the above as I generally access a rescue shell from my initramfs for such things.

best ... khay
Back to top
View user's profile Send private message
necron
Tux's lil' helper
Tux's lil' helper


Joined: 09 Sep 2010
Posts: 97

PostPosted: Fri May 30, 2014 7:16 pm    Post subject: Reply with quote

skid99 wrote:
necron wrote:
Try a different USB port (if you still can't boot from the liveusb) and copy the working configuration from there


tried them all. no lucks.

it just flashes a grub screen for a split second then gives me my boot options screen

Check the your BIOS configuration. It's possible for you to disable the ability to boot from a USB stick. Is there a submenu called "USB"/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum