Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Upgrading] udev and systemd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
aleskandro
n00b
n00b


Joined: 05 Sep 2012
Posts: 13

PostPosted: Thu Jun 05, 2014 2:19 pm    Post subject: [Upgrading] udev and systemd Reply with quote

Hi all, i'm trying to upgrade my gentoo but it report this error:
Code:

Total: 531 packages (495 upgrades, 33 new, 3 in new slots, 6 uninstalls), Size of downloads: 1,454,951 kB
Conflict: 21 blocks (3 unsatisfied)
 
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.
 
  (sys-fs/udev-212-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev,introspection?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-),gudev]) required by (virtual/libgudev-208::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-208 required by (virtual/udev-208-r2::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-208:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,static-libs?] (>=sys-fs/udev-208:0/0[abi_x86_64(-)]) required by (virtual/libudev-208::gentoo, ebuild scheduled for merge)
 
  (sys-apps/systemd-212-r5::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/systemd-200 required by (sys-power/upower-0.9.23-r3::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4::gentoo, ebuild scheduled for merge)
 
 
For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
 
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Full list in http://pastebin.com/ZpPiztRT


How can I solve?
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1752

PostPosted: Thu Jun 05, 2014 6:35 pm    Post subject: Reply with quote

yes, it's a bit messy this time.
Emerge attempts to pull several packages that don't belong together. Since you post this, you likely don't want systemd so add it (and integration, and upower) to /etc/portage/package.mask and the rest will install just fine

Also, use "search" button, it's like 3rd or 4th thread on this topic since like yesterday...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum