Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kernel modules for ZTE K3565-Z
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ev56o
Apprentice
Apprentice


Joined: 26 Jan 2010
Posts: 180

PostPosted: Mon Jun 09, 2014 8:15 pm    Post subject: kernel modules for ZTE K3565-Z Reply with quote

i can' t have working this usb modem key (with sim card)
the dmesg prompt only the product name and the manufacturer, in dev there is not device and i enabled the kernel module ZTE but i doesn' t work yet.
Back to top
View user's profile Send private message
dachschaden
n00b
n00b


Joined: 07 Jun 2014
Posts: 65
Location: Germany

PostPosted: Mon Jun 09, 2014 9:13 pm    Post subject: Reply with quote

What is the output of lsub?
In case you don't have it installed right now, it's in the package sys-apps/usbutils-007, you have to emerge it beforehand.
Back to top
View user's profile Send private message
ev56o
Apprentice
Apprentice


Joined: 26 Jan 2010
Posts: 180

PostPosted: Tue Jun 10, 2014 11:32 am    Post subject: Reply with quote

i have no internet and portage in the gentoo computer, i have to download ebuild and tar file from a windows pc how to do?
i can arrive here:
http://packages.gentoo.org/package/sys-apps/usbutils?full_cat
are you sure this is an help?
Back to top
View user's profile Send private message
ev56o
Apprentice
Apprentice


Joined: 26 Jan 2010
Posts: 180

PostPosted: Tue Jun 10, 2014 1:29 pm    Post subject: Reply with quote

i performed lsusb with a slackware 12 live dvd and i have something similar:
id 19d2:2000 ZTE WCDMA MSM MF627/MF628/MF628+/MF636+ HSDPA/HSUPA

and in a sys rescue cd live based on gentoo here i have a lot of device ttyUSB* maybe it recognize?
id 19d2:0063
Back to top
View user's profile Send private message
ev56o
Apprentice
Apprentice


Joined: 26 Jan 2010
Posts: 180

PostPosted: Tue Jun 10, 2014 3:40 pm    Post subject: Reply with quote

starting with system rescue cd gentoo based i have this output:
modem-manager ttyUSB0 opening serial port
probe requested by plugin ZTE
and i have the devices /dev/ttyUSB0
it looks it works.
when i restart with my normal gentoo system i see i have the ttyUSB0 magically!
it looks the ss cd unlock the usm modem.
Now i have wvdialconf that write the configuration
Start wvdial i have other the normal output a continuosly
No carrier signal lost

i add an output
Code:

(none) m # cat /etc/wvdial.conf
[Dialer Defaults]
Auto DNS = Off
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=16,"IP","websfr"
Modem Type = Analog Modem
ISDN = 0
Phone = *99#
Modem = /dev/ttyUSB1
username = dummy
password = dummy
Baud = 9600
(none) m # wvdial
--> WvDial: Internet dialer version 1.61
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=16,"IP","websfr"
AT+CGDCONT=16,"IP","websfr"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
NO CARRIER
--> No Carrier!  Trying again.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
NO CARRIER
--> No Carrier!  Trying again.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
NO CARRIER
--> No Carrier!  Trying again.
^CCaught signal 2:  Attempting to exit gracefully...
--> Disconnecting at Tue Jun 10 22:30:11 2014


under windows 7 it works...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum