Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo not fitting to screen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
NuclearKev
n00b
n00b


Joined: 09 Jun 2014
Posts: 3

PostPosted: Mon Jun 09, 2014 9:14 pm    Post subject: Gentoo not fitting to screen Reply with quote

I just installed a fresh copy of Gentoo 64 to my desktop and I have noticed an issue with the screen size. Imagine this, two square, one smaller square inside of a larger one. The smaller square is what is actually being used, and the larger isn't. There is about 1 inch all around that is just black. Whats interesting is that I have this same issue on the Gentoo installation medium, but not on the Arch based Manjaro Linux. This issue is both in the command line and while Xorg is running.

My graphics card is a Nvidia and I have installed the proper driver but no dice. Anyone have any ideas?!

Also, I tried adjusting the screen settings on the actual screen, it didn't help. I also tried to fix it by changing the GRUB startup resolution (you know like using vga=271 or whatever).
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5004
Location: Dark side of the mood

PostPosted: Tue Jun 10, 2014 1:04 pm    Post subject: Reply with quote

(I might be on an NVidia debunking spree today :D )

This (what you describe) typically is what you get when using ordinary [U]VESAFB with NVidia cards and non-standard resolutions. To prevent this, two solutions: either you use a standard 4:3 resolution and monitor (such as 1024x768, 1280x1024, 800x600,...) or use nouveau and kernel mode setting. Beware though that the latter won't allow for the proprietary drivers.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
NuclearKev
n00b
n00b


Joined: 09 Jun 2014
Posts: 3

PostPosted: Tue Jun 10, 2014 2:24 pm    Post subject: Reply with quote

Okay thanks! Ill try both! Here's the question now; how do I do that (the first one)? I have nouveau installed and i used genkernel because I'm too lazy to compile my own kernel. What do I do now?
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Tue Jun 10, 2014 2:30 pm    Post subject: Reply with quote

It may also be that your display's EDID is faulty.

In any event a third solution is to enter the modelines manually in xorg.conf. I copied them from a mandriva install last time I needed to do that, though knoppix is very good too, as is ubuntu, with hardware.

My old monitor had a faulty EDID: it took a while to work out the settings to get it not to use it:
Code:
<Section "Monitor">
..
   Option       "UseEDID" "false"
   # despite above we get:
   # Using HorizSync/VertRefresh ranges from the EDID
   # (Using EDID frequencies has been enabled on all display devices.)
   Option       "UseEDIDFreqs" "false"

   HorizSync    30.0 - 107.0
   VertRefresh  48.0 - 120.0
   Gamma        1

   Option       "DPI" "100x100"
   Option       "DPMS"

   ModeLine ..

Note: HorizSync and VertRefresh are specific to your display, should you need to use this.

ISTR I had
Code:
Option   "UseEDID" "false"
in the Device section as well.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Jun 10, 2014 2:48 pm    Post subject: Reply with quote

The problem is likely related to underscan/overscan. You need to make sure that both the monitor and your graphics driver have the same setting. When they mismatch, you will see black borders or content not fitting on the screen.
Example:
$ xrandr --output HDMI-1 --set underscan off
Back to top
View user's profile Send private message
NuclearKev
n00b
n00b


Joined: 09 Jun 2014
Posts: 3

PostPosted: Wed Jun 11, 2014 6:40 pm    Post subject: Victory! Reply with quote

So I edited the menuconfig of my kernel and realized that I didn't select the Nvidia drivers! Once I did that, I recompile the kernel and rebooted. Upon reboot it made the screen too big, luckily, I adjusted it to the correct settings from the monitor. Thanks for all the help guys!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum