Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error booting kernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
hinshelwood
n00b
n00b


Joined: 10 Jun 2014
Posts: 14

PostPosted: Tue Jun 10, 2014 7:00 am    Post subject: Error booting kernel Reply with quote

I have been trying to compile and boot the the gentoo kernel with no successes. I can not determine if it has to do with the initramfs encryption setup or the sata drivers I have enabled. I am trying to do a full disk encryption with LUKS and LVM that is decrypted during boot with a custom initramfs. This is the kernel error I'm getting:

Code:

     8.0083051]  ---[ end trace e523a48c90d82b3b 1---
     8.0091951]  -----------[  cut here ] -----------
     8.0100771]  WARNING: CPU: 1 PID: 10 at arch/x86/kernel/smp.c:124 native_smp_send_reschedule+Ox56/0x60()
     8.0109931]  Modules linked in:
     8.0119071] CPU: 1 PID: 10 Comm: migration/1 Tainted: G                 W    3.12.21-gewtoo-r1   #12
     8.0128521] Hardware name: LENOVO 42872VU/42872UU, BIOS 8DET4ZUU (1.12 ) 04/01/2011
     8.0138121] 0000000000000009 ffff8802348e9c48 ffffffff81935fba 0000000000000016
     8.014790]    0000000000000000 ffff8802348e9c88 ffffffff8105abb7 0000001000000000
     8.015777]  ffft88023e212b00 ffff8802348e9d18 ffff880235809c00 ffff88023464cce0



These are the hardware specs from lspci:

Code:

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM67 Express Chipset Family LPC Controller (rev 04)
00:1f.2 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
00:1f.5 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller (rev 04)
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]
0d:00.0 System peripheral: Ricoh Co Ltd PCIe SDXC/MMC Host Controller (rev 04)


I have found another post https://forums.gentoo.org/viewtopic-t-970744-start-0.html I tried this solution with no avail.

Anyone have seen this before or know how to solve it.

Here is my .config file: http://pastebin.com/DbPTZbMY


Last edited by hinshelwood on Tue Jun 10, 2014 8:57 am; edited 2 times in total
Back to top
View user's profile Send private message
schorsch_76
Guru
Guru


Joined: 19 Jun 2012
Posts: 450

PostPosted: Tue Jun 10, 2014 8:09 am    Post subject: Reply with quote

Actually you did cut the backtrace. This backtrace would indicate where the error did occur. Can you provide the backtrace nd the full error log?
Back to top
View user's profile Send private message
hinshelwood
n00b
n00b


Joined: 10 Jun 2014
Posts: 14

PostPosted: Tue Jun 10, 2014 9:51 am    Post subject: Reply with quote

I could not figure out how to get KFT working so I posted a image here: http://imagebin.ca/v/1PQar86j06lV
Back to top
View user's profile Send private message
schorsch_76
Guru
Guru


Joined: 19 Jun 2012
Posts: 450

PostPosted: Tue Jun 10, 2014 10:01 am    Post subject: Reply with quote

According to [1] it tries to bring you other CPUs online, but they are offline. This would indicate an error at your SMP configuration of your kernel.

Two options:
a) I suggest to use a seed from pappy [2] [3] and include your needed modules.
b) Try to fix the SMP configuration in your current kernel.

[1] http://lxr.free-electrons.com/source/arch/x86/kernel/smp.c#L121
[2] http://kernel-seeds.org/
[3] https://forums.gentoo.org/viewtopic-t-887894.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum