Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg errors,help!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
lhw828
n00b
n00b


Joined: 05 Sep 2013
Posts: 58

PostPosted: Thu Jun 12, 2014 11:22 am    Post subject: xorg errors,help! Reply with quote

Code:
[  4924.762]
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.
[  4924.762]
X.Org X Server 1.15.99.903 (1.16.0 RC 3)
Release Date: 2014-06-04
[  4924.763] X Protocol Version 11, Revision 0
[  4924.763] Build Operating System: Linux 3.14.4-gentoo x86_64 Gentoo
[  4924.763] Current Operating System: Linux lhw 3.15.0-gentoo #1 SMP Wed Jun 11 13:24:54 CST 2014 x86_64
[  4924.763] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.15.0-gentoo root=UUID=fe35344e-de12-4ccc-b570-33cf48427621 ro
[  4924.763] Build Date: 11 June 2014  08:59:04AM
[  4924.763] 
[  4924.763] Current version of pixman: 0.32.4
[  4924.764]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  4924.764] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  4924.765] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jun 12 11:16:11 2014
[  4924.765] (==) Using config file: "/etc/X11/xorg.conf"
[  4924.765] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  4924.765] (==) ServerLayout "X.org Configured"
[  4924.765] (**) |-->Screen "Screen0" (0)
[  4924.765] (**) |   |-->Monitor "Monitor0"
[  4924.765] (**) |   |-->Device "Card0"
[  4924.765] (**) |-->Input Device "Mouse0"
[  4924.765] (**) |-->Input Device "Keyboard0"
[  4924.765] (==) Automatically adding devices
[  4924.765] (==) Automatically enabling devices
[  4924.765] (==) Automatically adding GPU devices
[  4924.765] (**) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/,
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[  4924.765] (**) ModulePath set to "/usr/lib64/xorg/modules"
[  4924.765] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  4924.765] (WW) Disabling Mouse0
[  4924.765] (WW) Disabling Keyboard0
[  4924.765] (II) Loader magic: 0x806c60
[  4924.765] (II) Module ABI versions:
[  4924.765]    X.Org ANSI C Emulation: 0.4
[  4924.765]    X.Org Video Driver: 18.0
[  4924.765]    X.Org XInput driver : 21.0
[  4924.765]    X.Org Server Extension : 8.0
[  4924.767] (--) PCI:*(0:0:2:0) 8086:0166:17aa:21fa rev 9, Mem @ 0xf0000000/4194304, 0xe0000000/268435456, I/O @ 0x00006000/64
[  4924.767] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[  4924.767] (II) LoadModule: "glx"
[  4924.767] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  4924.767] (II) Module glx: vendor="X.Org Foundation"
[  4924.767]    compiled for 1.15.99.903, module version = 1.0.0
[  4924.767]    ABI class: X.Org Server Extension, version 8.0
[  4924.767] (==) AIGLX enabled
[  4924.767] (II) LoadModule: "intel"
[  4924.768] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[  4924.768] (II) Module intel: vendor="X.Org Foundation"
[  4924.768]    compiled for 1.15.99.903, module version = 2.99.912
[  4924.768]    Module class: X.Org Video Driver
[  4924.768]    ABI class: X.Org Video Driver, version 18.0
[  4924.768] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[  4924.768] (II) intel: Driver for Intel(R) HD Graphics: 2000-5000
[  4924.768] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100
[  4924.768] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200
[  4924.768] (--) using VT number 7

[  4924.772] (EE) No devices detected.
[  4924.772] (EE)
Fatal server error:
[  4924.772] (EE) no screens found(EE)
[  4924.772] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  4924.772] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  4924.772] (EE)
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Thu Jun 12, 2014 11:29 am    Post subject: Reply with quote

Open kernel menuconfig, and ensure that you have set CONFIG_DRM_I915_KMS=y (if you don't know where that option is, press / in menuconfig to search).

Alternatively, add i915.modeset=1 kernel parameter to your boot loader.
Back to top
View user's profile Send private message
lhw828
n00b
n00b


Joined: 05 Sep 2013
Posts: 58

PostPosted: Thu Jun 12, 2014 12:27 pm    Post subject: Reply with quote

Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib64/xorg/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "Backlight"             # <str>
        #Option     "DRI"                   # <str>
        #Option     "Present"               # [<bool>]
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "VSync"                 # [<bool>]
        #Option     "PageFlip"              # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"          # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "ReprobeOutputs"        # [<bool>]
        #Option     "DeleteUnusedDP12Displays"    # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "VirtualHeads"          # <i>
        #Option     "TearFree"              # [<bool>]
        #Option     "PerCrtcPixmaps"        # [<bool>]
   Identifier  "Card0"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum