Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]kernel panics after installing Gentoo on Hyper-V
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
roarkh
Tux's lil' helper
Tux's lil' helper


Joined: 24 May 2003
Posts: 90
Location: Bellingham, Washington

PostPosted: Fri Jun 20, 2014 9:22 pm    Post subject: [solved]kernel panics after installing Gentoo on Hyper-V Reply with quote

I am trying to get Gentoo installed as a Hyper-V Guest running on a Windows 8 host. I am assuming my problems must be related to not getting kernel options right but I am at a loss as to what I am missing.

When I try to boot I get the following messages just before the kernel panic...

Code:
EXT3-fs (sda4): error: couldn't mount because of unsupported optional features (240)
EXT2-fs (sda4): error: couldn't mount because of unsupported optional features (240)
UDF-fs: warning (device dsa4): udf_fill_super: No partition found (2)
List of all partitions:
0800   41943040 sda   driver: sd
0801   2048 sda1   4ab262f7-01
0802   131072 sda2   4ab262f7-02
0803   4094304 sda3   4ab262f7-03
0804   37614592 sda4   4ab262f7-04
0b00   1048575 sr0   driver: sr
No filesystem could mount root, tried: reiserfs ext3 ext2 vfat msdos iso9660 udf
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,4)
CPU: 0 PID: 1 Comm: swapper/0 Not tainted 3.12.21-gentoo-r1 #1
Hardware name: Microsoft Corporation Virtual Machine/Virtual machine, BIOS 090006  05/23/2012
0000000000000000 FFFFFFFFFFFFFFFF FFFFFFFF814C73F9 FFFFFFFF816301A0

Any anyone help me troubleshoot what might be happening here?


Last edited by roarkh on Fri Jun 20, 2014 9:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
roarkh
Tux's lil' helper
Tux's lil' helper


Joined: 24 May 2003
Posts: 90
Location: Bellingham, Washington

PostPosted: Fri Jun 20, 2014 9:50 pm    Post subject: Reply with quote

Well this is a bit embarrassing, I spent so much time trying to figure out the Hyper-V specific stuff in my kernel config that I neglected to enable ext4 support. Once that was set I was able to boot.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum