Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
can't connect to internet
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
nubber555
n00b
n00b


Joined: 23 Jun 2014
Posts: 5

PostPosted: Mon Jun 23, 2014 10:37 pm    Post subject: can't connect to internet Reply with quote

The eth0, lo, and wireless all showed up on ifconfig command but trying to get to www.gentoo.org with "links" I get the message "host not found." I can ping the laptop with my other computer but it can't ping out. I tried the handbook and looked in the drivers folder, tried loading modules like it says but I don't think it is that because I got a printout for thewireless network card. Then I tried setting the IP, broadcast, etc. but still got the same response. The partition seemed okay, I tried two different setups according to what I saw on youtube video, no cheese. My friend says that the ifconfig info looks off, it even says <up, broadcast, multicast> but still not working. It seems like the router doesn't recognize the machine, even though when I looked at the configuration it says it's "active".
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13987

PostPosted: Tue Jun 24, 2014 1:56 am    Post subject: Reply with quote

Please post the output of cat -n /etc/resolv.conf; cat -n /etc/conf.d/net.
Back to top
View user's profile Send private message
nubber555
n00b
n00b


Joined: 23 Jun 2014
Posts: 5

PostPosted: Tue Jun 24, 2014 2:53 am    Post subject: Reply with quote

cat -n /etc/resolv.conf
generated by dhcpcd
/etc/resolv.conf.head can replace this line
/etc/resolv.conf.tail can replace this line

and the other command:
/etc/conf.d/net: No such file or directory

I tried manually putting in the nameserver before I changed the partition...one thing I noticed was after listing the contents of:
/lib/modules/`uname -r`/kernel/drivers/net
there were numerous files including ethernet, wireless, and wan, don't know if that helps
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Tue Jun 24, 2014 6:16 am    Post subject: Reply with quote

@nubber
are you booting the minimal install cd and trying to perform the handbook steps listed at https://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?style=printable&full=1#book_part1_chap3 ? If so have you run
Code:
net-setup
?
Are you trying to use a wired or a wireless connection?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
nubber555
n00b
n00b


Joined: 23 Jun 2014
Posts: 5

PostPosted: Wed Jun 25, 2014 7:18 am    Post subject: Reply with quote

Thanks! All it took was configuring net-setup, I tried that once before but must have got the settings wrong.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum