Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X server keeps crashing - Hardware or Software?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 973

PostPosted: Tue Jul 01, 2014 10:01 pm    Post subject: X server keeps crashing - Hardware or Software? Reply with quote

My X Server keeps crashing. I tend to believe this is hardware related because my screen will start blinking and looking weird also. I got this from /var/log/messages:

Quote:
Jul 1 16:39:27 localhost kernel: [ 93.584982] ------------[ cut here ]------------
Jul 1 16:39:27 localhost kernel: [ 93.585000] WARNING: at drivers/gpu/drm/i915/intel_display.c:1028 intel_wait_for_pipe_off+0x18a/0x1a0()
Jul 1 16:39:27 localhost kernel: [ 93.585002] Hardware name: Latitude E6430
Jul 1 16:39:27 localhost kernel: [ 93.585014] pipe_off wait timed out
Jul 1 16:39:27 localhost kernel: [ 93.585014] Modules linked in:
Jul 1 16:39:27 localhost kernel: [ 93.585017] Pid: 4322, comm: X Not tainted 3.8.13-gentoo #27
Jul 1 16:39:27 localhost kernel: [ 93.585019] Call Trace:
Jul 1 16:39:27 localhost kernel: [ 93.585022] [<ffffffff8159c6ba>] ? intel_wait_for_pipe_off+0x18a/0x1a0
Jul 1 16:39:27 localhost kernel: [ 93.585027] [<ffffffff810915da>] warn_slowpath_common+0x7a/0xb0
Jul 1 16:39:27 localhost kernel: [ 93.585030] [<ffffffff810916b1>] warn_slowpath_fmt+0x41/0x50
Jul 1 16:39:27 localhost kernel: [ 93.585033] [<ffffffff8159c6ba>] intel_wait_for_pipe_off+0x18a/0x1a0
Jul 1 16:39:27 localhost kernel: [ 93.585035] [<ffffffff8159c7f6>] intel_disable_pipe+0x126/0x190
Jul 1 16:39:27 localhost kernel: [ 93.585037] [<ffffffff8159cf85>] ironlake_crtc_disable+0xb5/0x830
Jul 1 16:39:27 localhost kernel: [ 93.585039] [<ffffffff815a4c2d>] intel_set_mode+0x35d/0xa60
Jul 1 16:39:27 localhost kernel: [ 93.585043] [<ffffffff81226ecc>] ? dsl_dir_tempreserve_impl+0x1cc/0x2b0
Jul 1 16:39:27 localhost kernel: [ 93.585046] [<ffffffff815a5b4a>] intel_crtc_set_config+0x81a/0x950
Jul 1 16:39:27 localhost kernel: [ 93.585050] [<ffffffff81569c6d>] drm_mode_setcrtc+0x2ed/0x560
Jul 1 16:39:27 localhost kernel: [ 93.585052] [<ffffffff815977ff>] ? intel_crtc_load_lut+0x7f/0xa0
Jul 1 16:39:27 localhost kernel: [ 93.585055] [<ffffffff8155a91c>] drm_ioctl+0x44c/0x520
Jul 1 16:39:27 localhost kernel: [ 93.585057] [<ffffffff81569980>] ? drm_mode_setplane+0x3b0/0x3b0
Jul 1 16:39:27 localhost kernel: [ 93.585061] [<ffffffff8129c2da>] ? fsnotify+0x1ca/0x2b0
Jul 1 16:39:27 localhost kernel: [ 93.585065] [<ffffffff811bf636>] do_vfs_ioctl+0x96/0x550
Jul 1 16:39:27 localhost kernel: [ 93.585067] [<ffffffff811bfb81>] sys_ioctl+0x91/0xb0
Jul 1 16:39:27 localhost kernel: [ 93.585070] [<ffffffff811aeeed>] ? sys_write+0x4d/0x90
Jul 1 16:39:27 localhost kernel: [ 93.585073] [<ffffffff819b19a9>] system_call_fastpath+0x16/0x1b
Jul 1 16:39:27 localhost kernel: [ 93.585075] ---[ end trace be5d50c84a975b59 ]---



Would this be hardware related or software related?
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6313
Location: /usr/lib64/lv2

PostPosted: Tue Jul 01, 2014 10:16 pm    Post subject: Reply with quote

Probably software. You'd notice consistent problems that look the same regardless of whether you're using a basic VT or Xorg if it was a hardware problem.

First thing I would try is up/downgrading the video driver, to make sure it isn't a bug in the version you're using.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 973

PostPosted: Tue Jul 01, 2014 10:21 pm    Post subject: Reply with quote

Strangely, this never happens when the laptop is stand alone. Only when it is connected to the laptop dock. Would it still be software in this instance?
Back to top
View user's profile Send private message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 973

PostPosted: Tue Jul 01, 2014 11:11 pm    Post subject: Reply with quote

Oh, also...the monitor connected to the dock that flickers on and off does it in a way that the power goes on and off. I have replaced the laptop dock and both monitors and same issue. Would this still be software?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13836

PostPosted: Wed Jul 02, 2014 1:45 am    Post subject: Reply with quote

When the laptop is physically connected to the dock, does the system detect hardware that is not detected when the laptop is not physically connected to the dock? If yes, then when connected to the dock, the laptop may run code that does not run when not physically connected to the dock.

Your kernel is quite old. Please try to reproduce the problem on a 3.16-rc or at least the 3.15.x stable line.
Back to top
View user's profile Send private message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 973

PostPosted: Wed Jul 02, 2014 2:28 pm    Post subject: Reply with quote

Hu wrote:
When the laptop is physically connected to the dock, does the system detect hardware that is not detected when the laptop is not physically connected to the dock? If yes, then when connected to the dock, the laptop may run code that does not run when not physically connected to the dock.

Your kernel is quite old. Please try to reproduce the problem on a 3.16-rc or at least the 3.15.x stable line.


Good idea....I did a lspci -k before and after the dock and there was no extra drivers running.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum