Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Intel ValleyView Gen7 Acer B115M no console, KB error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 263

PostPosted: Sun Jul 06, 2014 8:16 pm    Post subject: Intel ValleyView Gen7 Acer B115M no console, KB error Reply with quote

Hi, I've bought new NB Acer B115M.
Booting actual minimal CD of Gentoo is without problems, but after install I reboot and grub2 writes echo (gentoo kernel version), then it flashes with semi-white screen and then only black screen with backlight. I can login as root and write commands but no visual, so I think it must be some kernel config mistake. After that I followed http://wiki.gentoo.org/wiki/Intel but no change.

NB has Intel Corporation ValleyView Gen7 graphic.


Last edited by DeIM on Wed Jul 09, 2014 11:16 am; edited 1 time in total
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Mon Jul 07, 2014 12:31 am    Post subject: Reply with quote

Maybe a kernel problem? You can try upgrading to 3.15 if you are not running that yet.

Also check if the same happens when you boot with an external monitor attached.
Back to top
View user's profile Send private message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 263

PostPosted: Mon Jul 07, 2014 6:34 am    Post subject: Reply with quote

I use gentoo-sources 3.12.21-r1 on both install CD and installed system. I don't know why install CD graphically (I mean text console) boots and system not.
I've tried to attach external monitor over HDMI, but it didn't show anything (although it detected NB output).
If You think 3.15 will help, I'll try it. Thank you.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Mon Jul 07, 2014 7:11 am    Post subject: Reply with quote

Recently (though I'm not sure if as far back as 3.12) another option has been added (called something like 'intel legacy console' - somewhat misleading name IMHO) that needs to be set too.
There's also 'framebuffer efi'', that might be helpful to be set.

In the end, we might need to look at your full kernel config - there's always a chance that either you or us are forgetting about something obvious.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Mon Jul 07, 2014 7:20 am    Post subject: Reply with quote

The difference is that the minimal install CD uses vesafb for the console, while the configuration guide tells you to use KMS.
Back to top
View user's profile Send private message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 263

PostPosted: Mon Jul 07, 2014 8:47 pm    Post subject: Reply with quote

Thank you, new kernel solved black screen problem :)
Now I have main problem with synaptic touchpad - I can't get it to run. I have tried some kernel settings.

kernel config:
http://pastebin.com/N7akLhzj
dmesg:
http://pastebin.com/2qNZYpcm

Maybe there is a another bios problem - sometimes after reboot arrows and enter don't work in grub menu. In system enter works but form arrows only left works (it happens after hard shutdown regularly)

But when there isn't that bios problem touchpad should work, but it doesn't.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Mon Jul 07, 2014 9:33 pm    Post subject: Reply with quote

Code:
# CONFIG_MOUSE_PS2_ELANTECH is not set
# CONFIG_MOUSE_PS2_SENTELIC is not set
# CONFIG_MOUSE_PS2_TOUCHKIT is not set
Maybe your touchpad belongs to one of these. Try enabling them.

Also, your BIOS might have disabled the touchpad. See if pressing the BIOS hotkey for toggling the touchpad function makes a difference.
Back to top
View user's profile Send private message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 263

PostPosted: Tue Jul 08, 2014 4:11 am    Post subject: Reply with quote

Thank you, but it didn't help, I found in dmesg that it diabled AUX so I put i8042.nopnp on kernel line and now it can detect touchpad and after pressing fn+toggle touchpad, it seems to work :D
Back to top
View user's profile Send private message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 263

PostPosted: Wed Jul 09, 2014 11:01 am    Post subject: Acer B115-M keyboard sometimes works weird Reply with quote

It seems I have last problem - arrows and delete key, as I wrote before, sometimes don't work - only left arrow. It starts when I can't select items in grub menu on boot.
I've tried to set kernel options

Code:
i8042.nopnp i8042.reset


Code:
[    3.529620] i8042: PNP detection disabled
[    3.535563] i8042: Detected active multiplexing controller, rev 1.1
[    3.538414] serio: i8042 KBD port at 0x60,0x64 irq 1
[    3.540546] serio: i8042 AUX0 port at 0x60,0x64 irq 12
[    3.542714] serio: i8042 AUX1 port at 0x60,0x64 irq 12
[    3.544838] serio: i8042 AUX2 port at 0x60,0x64 irq 12
[    3.546902] serio: i8042 AUX3 port at 0x60,0x64 irq 12
[    3.549207] mousedev: PS/2 mouse device common for all mice
[    3.551839] usbcore: registered new interface driver synaptics_usb


Code:
i8042.nopnp i8042.nomux i8042.reset


Code:
[    3.598101] i8042: PNP detection disabled
[    3.603841] serio: i8042 KBD port at 0x60,0x64 irq 1
[    3.606010] serio: i8042 AUX port at 0x60,0x64 irq 12
[    3.608597] mousedev: PS/2 mouse device common for all mice
[    3.611313] usbcore: registered new interface driver synaptics_usb


but it didn't change anything.
When I want to reboot gentoo, it always freezes.
Back to top
View user's profile Send private message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 263

PostPosted: Wed Jul 09, 2014 11:23 am    Post subject: Reply with quote

Now I found (over PNMixer Hotkeys):
up arrow = nothing
down arrow = XF86TouchpadOff
right arrow = XF86Launch1
del key = XF86TouchpadOn
fn+uparrow = XF86WWW (should be XF86AudioRaiseVolume)

It have to be since grub start, I don't know how to resolve this since number of this weird grub start is higher.
Back to top
View user's profile Send private message
nihil39
Tux's lil' helper
Tux's lil' helper


Joined: 15 Nov 2005
Posts: 97
Location: Italy

PostPosted: Sun Oct 26, 2014 8:42 am    Post subject: Reply with quote

Did you manage to make brightness keys work? xbacklight works so i think kernel properly manages backlight. Did you issue some special commands to the kernel? I tried acpi video.use_native_backlight=1 && acpi_osi="!Windows 2012" to no avail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum