Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] BTRFS LZO problems in Kernel 3.15.3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
splurben
Apprentice
Apprentice


Joined: 03 Feb 2004
Posts: 197
Location: Augusta, Southwest Western Australia

PostPosted: Tue Jul 08, 2014 6:05 am    Post subject: [SOLVED] BTRFS LZO problems in Kernel 3.15.3 Reply with quote

Can anyone else report problems with BTRFS (LZO compressed) filesystems on Kernel 3.15.3?

I've got a test system that can't mount the root filesystem with lzo compression enabled, but the device and filesystem are fine from the Gentoo admin CD (admincd-amd64-20130620) without lzo compression.

I've tested the underlying hardware SATA controller and SSD itself and found no issues.

Or, did I miss a tech note about changes to BTRFS?
_________________
--=>Like... Goodness had nothing to do with it.<=--


Last edited by splurben on Sat Jul 12, 2014 2:53 am; edited 1 time in total
Back to top
View user's profile Send private message
N8Fear
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2013
Posts: 140
Location: Berlin (Germany)

PostPosted: Tue Jul 08, 2014 7:27 am    Post subject: Reply with quote

I haven't tested it myself (and have no reachable box with btrfs) but in theory there can be issues with 3.15.3 as the lzo code was changed to prevent a recent security (recent like in open for the last 20 years or something) issue in the kernels lzo code.
If you can reproduce this error with a 3.15.3 vanilla kernel and it worked fine before the fix it's likely a good reason to create a bugreport with upstream...
Back to top
View user's profile Send private message
splurben
Apprentice
Apprentice


Joined: 03 Feb 2004
Posts: 197
Location: Augusta, Southwest Western Australia

PostPosted: Tue Jul 08, 2014 11:17 pm    Post subject: LZO Compression, BTRFS and Kernel 3.15.3 Reply with quote

N8Fear wrote:
I haven't tested it myself (and have no reachable box with btrfs) but in theory there can be issues with 3.15.3 as the lzo code was changed to prevent a recent security (recent like in open for the last 20 years or something) issue in the kernels lzo code.
If you can reproduce this error with a 3.15.3 vanilla kernel and it worked fine before the fix it's likely a good reason to create a bugreport with upstream...


Well, I'm not running Vanilla. I can reproduce the problem on ~AMD64 Genkernel Gentoo with root on BTRFS using LZO compression.

I just noticed there's a 3.15.4. So I'll look through the change notes and see if it's been addressed.
_________________
--=>Like... Goodness had nothing to do with it.<=--
Back to top
View user's profile Send private message
splurben
Apprentice
Apprentice


Joined: 03 Feb 2004
Posts: 197
Location: Augusta, Southwest Western Australia

PostPosted: Sat Jul 12, 2014 3:05 am    Post subject: Solution Reply with quote

Disable LZO compression in FSTAB.

(remove compress=lzo from mount options)
_________________
--=>Like... Goodness had nothing to do with it.<=--
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum