Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
UEFI bios set to compatible other OS - no Grub2 menu on SSD
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 263

PostPosted: Sat Jul 12, 2014 2:18 pm    Post subject: UEFI bios set to compatible other OS - no Grub2 menu on SSD Reply with quote

Hi,

I have new PC with 1 SSD + 2 HDDs.

1 HDD is for Windows (MBR).

SSD is in installation over fdisk GPT.

SSD is partitioned like I found at http://wiki.gentoo.org/wiki/SSD , but with swap on second HDD.
I've emerged Grub2 and installation and configuration was flawless. But after reboot I can't boot from SSD
I've install grub2 on /dev/sda.

Maybe problem with no set boot flag on any partition? I don't fully understand GPT.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13830

PostPosted: Sat Jul 12, 2014 2:42 pm    Post subject: Reply with quote

Do I understand correctly that your problem is that your system never transfers control to Grub2, so you never have the chance to use the Grub2 menu? Or is your problem that Grub2 runs but has no useful choices? If the problem is that Grub2 never runs, then you need to configure your system to try to boot off the drive on which Grub2 was installed. We can try to help you with this, but picking the boot drive in a multi-drive system has always been vendor-specific.
Back to top
View user's profile Send private message
russK
l33t
l33t


Joined: 27 Jun 2006
Posts: 630

PostPosted: Sat Jul 12, 2014 5:08 pm    Post subject: Reply with quote

I just worked through this here recently, but I think we need more information in order to help
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1696

PostPosted: Sat Jul 12, 2014 6:52 pm    Post subject: Reply with quote

One thing I would ask, is if windows was installed in bios mode or UEFI. I'm assuming you setup grub2 for UEFI, in which case you'd have a partition on one of the drives that has a partition formated as fat32 (EFI boot partition is required for UEFI, and has to be formated as fat32) and the disk is setup for GPT. A easy way to check in linux, is run fdisk on any of the drives, and see what the disk's label says. If you want to boot from UEFI, both systems needs to be setup for UEFI (the system drives will have a disk label saying GPT). You can not boot a msdos system through UEFI, and same for other way around. From what I gathered, linux is not picky if it's installed on a GPT drive or not, but Windows IS picky. Most likely, you are going need to reconfigure grub2 to NOT use UEFI or reinstall windows for UEFI. (I had to setup a usb boot drive, to get windows 7 to install in UEFI mode).
Back to top
View user's profile Send private message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 263

PostPosted: Sat Jul 12, 2014 8:32 pm    Post subject: Reply with quote

Thanks for answers.
Grub2 menu is never shown (I haven't chance to use Grub2 menu). First boot disk is set to SSD, but only Windows on HDD boots.
Windows is installed no-UEFI way (BIOS mode) on mbr disk (100M help boot partition, 2 rest partition NTFS).
Only SSD is GPT and formated with grub boot 2M partition (/dev/sda1) and rest for / (/dev/sda2).
Grub installation didn't show any error and found linux and windows.

I set GRUB_PLATFORMS="efi-64 pc" but let Grub to automatically decide and not set target system.
I have Intel i7 with Z97 based MB.
Back to top
View user's profile Send private message
djdunn
l33t
l33t


Joined: 26 Dec 2004
Posts: 780
Location: Arrakis

PostPosted: Sun Jul 13, 2014 12:47 am    Post subject: Reply with quote

First to have the UEFI firmware find the GPT formatted UEFI partition and load grub2. you need /boot to be a separate partition formatted fat32 of type code EF00. then either while running in UEFI mode allow the bootloader to write to the UEFI boot menu (must be booted in uefi mode to edit the boot menu) or if booted in bios mode place the *.efi and supporting files in /boot/efi/boot/ and rename the *.efi to bootx64.efi, which is the fallback, and either leave it in fallback position or move it to wherever you want on the UEFI partition with the *efi called whatever you want and using the utility efibootmgr to edit the UEFI boot menu to point to the *.efi file after booting in UEFI mode from the fallback location.

I don't know how feasible bios/uefi hybrid booting is since i dont use grub2, id assume its probably ok as long as windows installed its bootloader in the MBR of the DOS partition disk, and if grub2 has the capacity to chainload the DOS partition disk to load the windows bootloader found on the mbr.

if grub can do that it should be able to pass the boot sequence to the DOS partition disk and load windows fine since it seems like the windows disk was partitioned with DOS partition. but again i dont know if grub2 can do this

on to the grub problem, maybe the UEFI has its CSM (compatibility support mode) set up to try BIOS first aka DOS partitioning, and you might need to toggle that to "UEFI first<

The toggles ive seen were, "UEFI only" or "BIOS only" or "UEFI first", or "BIOS first", try "UEFI first" or "UEFI", if you dont have a "UEFI first" and "UEFI" does not work then you are going to probably have to reinstall windows with a formatted GPT disk in UEFI mode.

and or the following could be causing grub to not appear or be bootable

Maybe you have secure boot active, which is causing the UEFI to ignore your grub which is most likely unsigned and basically invisible to the UEFI.

If so, then I would disable it, since it does nothing to increase security, since its easy to disable secure boot, in some cases to install new secureboot keys, slightly more difficult with a windows RT device, but its still easily disabled. I'm fairly sure we aren't allowed to talk about how to specifically disable secureboot on windows RT machine?
_________________
A process cannot be understood by stopping it. Understanding must move with the flow of the process, must join it and flow with it.

-The First Law of Mentat
Back to top
View user's profile Send private message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 263

PostPosted: Sun Jul 13, 2014 6:24 am    Post subject: Reply with quote

I made in fdisk non-UEFI GPT partitions as guide said (it seems the guide is not as correct as I expected).
Tried UEFI-first in BIOS, no change.
It seems GPT disk => BIOS thinks it's UEFI and finds FAT32 partition with code EF00.

I haven't see much good and straight forward guide for Gentoo on UEFI, so I try not to use this mode.
If somebody have good resources, please post it :)

I realized that I don't need to have grub on GPT SSD, so I installed it on MBR disk and now it runs just fine.
I know it's not exactly what I wanted but thank You for help.
Back to top
View user's profile Send private message
srs5694
Guru
Guru


Joined: 08 Mar 2004
Posts: 434
Location: Woonsocket, RI

PostPosted: Mon Jul 14, 2014 12:44 am    Post subject: Reply with quote

It's easiest to install all your OSes in the same boot mode -- that is, all in BIOS mode or all in EFI mode. Mixing them tends to lead to problems, because few boot managers can switch boot modes, meaning you'll need to use the firmware's built-in boot manager to switch OSes, and that's usually awkward. You usually have to hit a key at startup to switch boot modes. Some computers don't even let you do that.

AFAIK, the only installable boot manager that lets you switch between BIOS-mode and EFI-mode boots on a standard PC is my own rEFInd. If you want to use that feature, you'll need to uncomment the "scanfor" option in refind.conf and be sure that "hdbios" is among the options. Even this is not guaranteed to work, since not all EFIs include the necessary support.

It's usually better to install all your OSes in one mode, as I've already said.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum