Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] not syncing vfs unable to mount root fs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
spoliarium
n00b
n00b


Joined: 15 Jul 2014
Posts: 3

PostPosted: Tue Jul 15, 2014 10:06 pm    Post subject: [SOLVED] not syncing vfs unable to mount root fs Reply with quote

I have installed gentoo. my root fs formatted with ext3. Supporting ext3 and SATA are on in kernel config file
lilo booted gentoo then i get this screen:

http://s15.postimg.org/9lik7ng97/10491185_244537382411986_5604598643414128595_n.jpg

I also compiled my kernel with config file of livecd but still same result

Code:
zcat /proc/config.gz > .config


Last edited by spoliarium on Wed Jul 16, 2014 7:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Tue Jul 15, 2014 11:59 pm    Post subject: Reply with quote

if using genkernel or the livecd configuration you need to invoke an initrd in the bootloader. the initrd installs driver modules for file systems and hard drive drivers. alternate is to build those drivers into the kernel instead of as modules.
boot the livecd, mount the gentoo partitions, run
Code:
 lspci -k | wgetpaste
wgetpaste /mnt/gentoo/usr/src/linux/.config
post the url's returned
_________________
Defund the FCC.
Back to top
View user's profile Send private message
spoliarium
n00b
n00b


Joined: 15 Jul 2014
Posts: 3

PostPosted: Wed Jul 16, 2014 9:20 am    Post subject: Reply with quote

I have compiled with "genkernel all" I copied bzImage and initramfs then run lilo the result:

Code:
>> Determining root device...
!! Block device 802 is not a valid root device...
!! Could not find the root block device in
!! Please specify another value or:
!! - press Enter for the same
!! - type "shell" for a shell
!! - type "q" to skip
root block device() ::


I did not yet config my wifi connection therefore i cannot send you urls but i saved results in a file

lspci -k

Code:

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
   Subsystem: Dell Device 04b0
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
   Kernel driver in use: pcieport
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
   Subsystem: Dell Device 04ca
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
   Subsystem: Dell Device 04b0
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
   Subsystem: Dell Device 04b0
   Kernel driver in use: ehci-pci
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
   Subsystem: Dell Device 04b0
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
   Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
   Kernel driver in use: pcieport
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
   Kernel driver in use: pcieport
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
   Kernel driver in use: pcieport
00:1c.7 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 8 (rev b5)
   Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
   Subsystem: Dell Device 04b0
   Kernel driver in use: ehci-pci
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset Family LPC Controller (rev 05)
   Subsystem: Dell Device 04b0
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
   Subsystem: Dell Device 04b0
   Kernel driver in use: ahci
   Kernel modules: ahci
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
   Subsystem: Dell Device 04b0
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 525M] (rev a1)
   Subsystem: Dell Device 04ca
01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd_hda_intel
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
   Subsystem: Dell Device 04b0
   Kernel driver in use: r8169
   Kernel modules: r8169
09:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] (rev 34)
   Subsystem: Intel Corporation Centrino Wireless-N 1030 BGN
   Kernel driver in use: iwlwifi
   Kernel modules: iwlwifi
0b:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
   Subsystem: Dell Device 04b0
   Kernel driver in use: xhci_hcd
   Kernel modules: xhci_hcd



lilo.conf

Code:

boot   =/dev/sda
prompt
timeout   =30
default   =gentoo
vga=318

image=/boot/kernel-genkernel-x86_64-3.12.21-gentoo-r1
   initrd=/boot/initramfs-genkernel-x86_64-3.12.21-gentoo-r1
   label=gentoo
   read-only
   root=/dev/sda2
   

image=/boot/kernel-genkernel-x86_64-3.12.21-gentoo-r1
   initrd=/boot/initramfs-genkernel-x86_64-3.12.21-gentoo-r1
   label=gentoo_two
   read-only
   root=/dev/sda2
   append="rootfstype=ext3"

other=/dev/sda3
   label=win



.config

http://pastebin.com/Y0j4hvRf
Back to top
View user's profile Send private message
spoliarium
n00b
n00b


Joined: 15 Jul 2014
Posts: 3

PostPosted: Wed Jul 16, 2014 7:21 pm    Post subject: Reply with quote

I installed gentoo again via usbstick.
I solved this problem with this .config file: http://pastebin.com/uQX7cDcw from this thread: http://forums-web1.gentoo.org/viewtopic-t-925196-start-0.html
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Wed Jul 16, 2014 7:31 pm    Post subject: Reply with quote

disclaimer: I did lilo once or twice 10 years ago
opinion: after 16 hours of wrestling with genkernel and gentoo-sources-3.12.21-gentoo-r1 without success I have concluded that the initramfs is not functioning correctly or the supplied default configuration has problems. I have been able to get the genkernel kernel to function by modifying the configuration to build in the hard drive drivers vice having them as modules. Still investigating.
If you would like to give this a try, boot the livecd/usb, mount the gentoo partitions, enter the chroot, run:
Code:
cd /usr/src/linux;make menuconfig
edit the menuconfig to include:
Quote:
Device Drivers --->
SCSI device support --->
<M> RAID Transport Class
-*- SCSI device support
{*} SCSI target support
[*] legacy /proc/scsi/ support
*** SCSI support type (disk, tape, CD-ROM) ***
<*> SCSI disk support
< > SCSI tape support
< > SCSI OnStream SC-x0 tape support
<*> SCSI CDROM support
[*] Enable vendor-specific extensions (for SCSI CDROM)
<*> SCSI generic support
<M> SCSI media changer support
[*] Probe all LUNs on each SCSI device
[ ] Verbose SCSI error reporting (kernel size +=12K)
[ ] SCSI logging facility
[*] Asynchronous SCSI scanning
SCSI Transports --->
[*] SCSI low-level drivers --->
[*] PCMCIA SCSI adapter support --->
< > SCSI Device Handlers ----
< > OSD-Initiator library
<*> Serial ATA and Parallel ATA drivers --->
--- Serial ATA and Parallel ATA drivers
[*] Verbose ATA error reporting
[*] ATA ACPI Support
[ ] SATA Zero Power Optical Disc Drive (ZPODD) support
[ ] SATA Port Multiplier support
*** Controllers with non-SFF native interface ***
<*> AHCI SATA support
< > Platform AHCI SATA support
< > Initio 162x SATA support (Very Experimental)
< > ACard AHCI variant (ATP 8620)
< > Silicon Image 3124/3132 SATA support
[*] ATA SFF support (for legacy IDE and PATA)
*** SFF controllers with custom DMA interface ***
< > Pacific Digital ADMA support
< > Pacific Digital SATA QStor support
< > Promise SATA SX4 support (Experimental)
[*] ATA BMDMA support
*** SATA SFF controllers with BMDMA ***
<*> Intel ESB, ICH, PIIX3, PIIX4 PATA/SATA support
< > Calxeda Highbank SATA support
< > Marvell SATA support
< > NVIDIA SATA support
< > Promise SATA TX2/TX4 support
< > Renesas R-Car SATA support
< > Silicon Image SATA support
< > SiS 964/965/966/180 SATA support
< > ServerWorks Frodo / Apple K2 SATA support
< > ULi Electronics SATA support
< > VIA SATA support
< > VITESSE VSC-7174 / INTEL 31244 SATA support
*** PATA SFF controllers with BMDMA ***
< > ALi PATA support
< > AMD/NVidia PATA support
< > ARASAN CompactFlash PATA Controller Support
< > ARTOP 6210/6260 PATA support
< > ATI PATA support
< > ARTOP/Acard ATP867X PATA support
< > CMD64x PATA support
< > CS5510/5520 PATA support
< > CS5530 PATA support
< > CS5536 PATA support
< > Cypress CY82C693 PATA support (Very Experimental)
< > EFAR SLC90E66 support
< > HPT 366/368 PATA support
< > HPT 370/370A/371/372/374/302 PATA support
< > HPT 371N/372N/302N PATA support
< > HPT 343/363 PATA support
< > IT8213 PATA support (Experimental)
< > IT8211/2 PATA support
< > JMicron PATA support
< > Marvell PATA support via legacy mode
< > NETCELL Revolution RAID support
< > Ninja32/Delkin Cardbus ATA support
< > Nat Semi NS87415 PATA support
< > Intel PATA old PIIX support
< > OPTI FireStar PATA support (Very Experimental)
< > Promise PATA 2027x support
< > Older Promise PATA controller support
< > RADISYS 82600 PATA support (Experimental)
< > RDC PATA support
< > SC1200 PATA support
< > Intel SCH PATA support
< > SERVERWORKS OSB4/CSB5/CSB6/HT1000 PATA support
< > CMD / Silicon Image 680 PATA support
< > SiS PATA support
< > Toshiba Piccolo support (Experimental)
< > Compaq Triflex PATA support
< > VIA PATA support
< > Winbond SL82C105 PATA support
*** PIO-only SFF controllers ***
< > CMD640 PCI PATA support (Experimental)
< > Intel PATA MPIIX support
< > Nat Semi NS87410 PATA support
< > OPTI621/6215 PATA support (Very Experimental)
< > PCMCIA PATA support
< > PC Tech RZ1000 PATA support
*** Generic fallback / legacy drivers ***
< > ACPI firmware driver for PATA
< > Generic ATA support
< > Legacy ISA PATA support (Experimental)

File systems --->
< > Second extended fs support
< > Ext3 journalling file system support
<*> The Extended 4 (ext4) filesystem
[*] Use ext4 for ext2/ext3 file systems (NEW)
[*] Ext4 POSIX Access Control Lists
[*] Ext4 Security Labels
[ ] EXT4 debugging support
[ ] JBD2 (ext4) debugging support
then exit enough times to see "Do you wish to save your new configuration?"; yes; then run
Code:
make && make modules_install && make install
new kernel name will start vimlinuz, run lilo, leave initrd out; exit chroot and reboot

just saw your solution, will send this anyway, and look to see if config similarities exist, thanks for your post
_________________
Defund the FCC.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Wed Jul 16, 2014 7:47 pm    Post subject: Reply with quote

The config you used was for an amd motherboard and you have intel chipset. next kernel compile you might change to
<*> Intel ESB, ICH, PIIX3, PIIX4 PATA/SATA support
< > AMD/NVidia PATA support
and shuffle through for similar changes to make
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum