Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] mount /boot - geht, geht nicht ...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Louisdor
Veteran
Veteran


Joined: 14 Dec 2003
Posts: 1231
Location: im Brandenburgischen

PostPosted: Wed Jul 16, 2014 4:58 pm    Post subject: [Solved] mount /boot - geht, geht nicht ... Reply with quote

Hallo!

Nach gut 10 Jahren habe ich mein "altes" Gentoo platt gemacht und auf einem neuen Rechner neu installiert.
Nun habe ich das Problem, dass ich meine /boot Parttition nicht mehr ordentlich mounten kann.
In der /etc/fstab steht:
Code:
/dev/sdb1       /boot                   ext2            noauto,noatime,user,discard     1 2

Wenn ich jetzt mount -v /boot eingebe kommt:
Code:
mount: Falscher Dateisystemtyp, ungültige Optionen, der
Superblock von /dev/sdb1 ist beschädigt, fehlende
Kodierungsseite oder ein anderer Fehler

       In some cases useful info is found in syslog - try
       dmesg | tail or so.
celsius ~ #

Gebe ich aber mount -v -t auto /dev/sdb1 /boot/ ein kommt:
Code:
mount: /dev/sdb1 mounted on /boot.
celsius ~ #

Ist doch komisch, oder? Oder habe ich in der /etc/fstab irgendwas falsch eingetragen?
Verschiedene andere Linux und NTFS Partitionen lasse ich beim Starten automatisch mounten.
Das Problem habe ich nur mit /boot. (Soll ja auch nur eingehängt werden, wenn ich einen neuen Kernel baue, oder so ...)

Vielleicht kann mir ja jemand weiterhelfen?

Merci & Ciao,
aleX!

_________________
"Ich bin ich."


Last edited by Louisdor on Wed Jul 16, 2014 6:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 419

PostPosted: Wed Jul 16, 2014 5:48 pm    Post subject: Reply with quote

Ich glaube ext2 unterstützt "discard" nicht.
Back to top
View user's profile Send private message
Louisdor
Veteran
Veteran


Joined: 14 Dec 2003
Posts: 1231
Location: im Brandenburgischen

PostPosted: Wed Jul 16, 2014 6:02 pm    Post subject: Reply with quote

Apheus wrote:
Ich glaube ext2 unterstützt "discard" nicht.

Tja, das war es! Wenn ich discard weg lasse, dann geht es. Hm, ....
Muss ich dann also immer mal TRIM per Batched Discard (fstrim -v /boot) laufen lassen.

Edit: ext2 kann auch kein fstrim, also habe ich eine ext4 Partition draus gemacht.

Merci vielmals für Weiterhelfen!

Ciao,
aleX!

_________________
"Ich bin ich."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum