Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge-webrsync error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
bbrother
n00b
n00b


Joined: 17 Jul 2014
Posts: 2

PostPosted: Thu Jul 17, 2014 2:42 pm    Post subject: emerge-webrsync error Reply with quote

Hello i'm trying to install amd64 version of gentoo on my laptop. Everything went fine until i have reached part where i have to issue emerge-webrsync command. It starts to extract, but then suddenly it says 'Cannot write: No space left on device' and then ends with emerge-webrsync error: tar failed to extract the image. Tarball is corrupt?

Partition scheme:
root 30gb
swap 4gb
home all left space.

df -i / output
Inodes IUsed IFree IUse%
465177 95881 369296 21% on /

So clearly i have enough space right?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Thu Jul 17, 2014 5:18 pm    Post subject: Reply with quote

Suggest trying again boot the livecd/usb, mount the gentoo partitions, enter the chroot, nominally:
Code:
mount /dev/sda3 /mnt/gentoo
mount /dev/sda1 /mnt/gentoo/boot
cp -L /etc/resolv.conf /mnt/gentoo/etc/
mount -t proc none /mnt/gentoo/proc
mount --rbind /sys /mnt/gentoo/sys
mount --rbind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash

Quote:
source /etc/profile
export PS1="(chroot) $PS1" then
then
Code:
emerge-webrsync

_________________
Defund the FCC.
Back to top
View user's profile Send private message
bbrother
n00b
n00b


Joined: 17 Jul 2014
Posts: 2

PostPosted: Thu Jul 17, 2014 8:38 pm    Post subject: Reply with quote

DONAHUE wrote:
Suggest trying again boot the livecd/usb, mount the gentoo partitions, enter the chroot, nominally:
Code:
mount /dev/sda3 /mnt/gentoo
mount /dev/sda1 /mnt/gentoo/boot
cp -L /etc/resolv.conf /mnt/gentoo/etc/
mount -t proc none /mnt/gentoo/proc
mount --rbind /sys /mnt/gentoo/sys
mount --rbind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash

Quote:
source /etc/profile
export PS1="(chroot) $PS1" then
then
Code:
emerge-webrsync


Thanks problem fixed.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Thu Jul 17, 2014 8:42 pm    Post subject: Reply with quote

excellent! We have almost all missed the door to the chroot at some time or other.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum