Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]troubles with microsoft hd 3000
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
lawl
n00b
n00b


Joined: 18 Jul 2014
Posts: 20

PostPosted: Fri Jul 18, 2014 1:19 pm    Post subject: [SOLVED]troubles with microsoft hd 3000 Reply with quote

Hello!
I'm tryin to take video from my hd 3000 cam, but when I send next command
Code:

ffplay -f v4l2 -i /dev/video1

ffplay just freeze, and produce error in dmesg
Code:

[июл18 17:10] BUG: unable to handle kernel paging request at ffff8806b6c86230
[  +0,000038] IP: [<ffffffff81697182>] __vb2_queue_alloc+0x82/0x500
[  +0,000028] PGD 211e067 PUD 0
[  +0,000016] Oops: 0002 [#1] SMP
[  +0,000017] Modules linked in:
[  +0,000022] CPU: 2 PID: 2532 Comm: ffplay Not tainted 3.15.5-aufs #1
[  +0,000031] Hardware name: LENOVO 3259A87/3259A87, BIOS H0ET95WW (2.55 ) 01/20/2014
[  +0,000027] task: ffff880291098000 ti: ffff8800c06bc000 task.ti: ffff8800c06bc000
[  +0,000027] RIP: 0010:[<ffffffff81697182>]  [<ffffffff81697182>] __vb2_queue_alloc+0x82/0x500
[  +0,000031] RSP: 0018:ffff8800c06bfc30  EFLAGS: 00010287
[  +0,000020] RAX: 00000000be5bc000 RBX: ffff8800c3ea60d8 RCX: ffff8800be5bc400
[  +0,000024] RDX: 00000000be5bc021 RSI: 8000000000000163 RDI: ffffffff820e17f0
[  +0,000025] RBP: ffff8800c06bfc80 R08: ffff8800c3ea60d8 R09: ffffc90017a02000
[  +0,000024] R10: 00003ffffffff000 R11: ffffc90017a01fff R12: ffff8800be5bc400
[  +0,000025] R13: 0000000000000001 R14: ffff8800c3ea62bc R15: 0000000000000022
[  +0,000025] FS:  00007fdf409f1700(0000) GS:ffff88029e280000(0000) knlGS:0000000000000000
[  +0,000028] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  +0,000021] CR2: ffff8806b6c86230 CR3: 0000000286d81000 CR4: 00000000000407e0
[  +0,000024] Stack:
[  +0,000009]  0000002100000000 ffff880000000001 0000000100000100 ffff8800be5bc400
[  +0,000030]  ffff8800c3ea60d8 ffff8800c3ea60d8 ffff8800c3ea62b8 ffff8800c3ea6278
[  +0,000031]  ffff8800c06bfdc0 ffff8800c06bfdc8 ffff8800c06bfcc0 ffffffff81697a7c
[  +0,000030] Call Trace:
[  +0,000013]  [<ffffffff81697a7c>] __reqbufs.isra.12+0x13c/0x2b0
[  +0,000022]  [<ffffffff81697c1b>] vb2_reqbufs+0x2b/0x30
[  +0,000020]  [<ffffffff8169cfb9>] uvc_alloc_buffers+0x29/0x50
[  +0,000022]  [<ffffffff8169f1d8>] uvc_v4l2_do_ioctl+0xfc8/0x14a0
[  +0,000023]  [<ffffffff81160d6d>] ? do_read_fault.isra.89+0x18d/0x290
[  +0,000026]  [<ffffffff81183bc9>] ? __kmalloc+0xd9/0x190
[  +0,000020]  [<ffffffff8168965b>] ? video_usercopy+0x6b/0x5a0
[  +0,000021]  [<ffffffff81689926>] video_usercopy+0x336/0x5a0
[  +0,000022]  [<ffffffff8169e210>] ? uvc_v4l2_open+0x150/0x150
[  +0,000021]  [<ffffffff8169d61a>] uvc_v4l2_ioctl+0x2a/0x70
[  +0,000021]  [<ffffffff816840e0>] v4l2_ioctl+0x150/0x190
[  +0,000022]  [<ffffffff8119f918>] do_vfs_ioctl+0x2c8/0x490
[  +0,000021]  [<ffffffff813b1341>] ? selinux_file_ioctl+0x21/0xe0
[  +0,000023]  [<ffffffff8119fb61>] SyS_ioctl+0x81/0xa0
[  +0,000020]  [<ffffffff819410e2>] system_call_fastpath+0x16/0x1b
[  +0,000021] Code: f8 41 89 04 24 8b 03 41 89 44 24 04 8b 45 b8 83 f8 01 41 89 44 24 3c 74 50 8b 83 50 01 00 00 41 8d 14 07 41 83 c7 01 44 3b 7d c0 <4c> 89 64 d3 50 0f 84 ae 02 00 00 8b 7b 38 be d0 80 00 00 e8 56
[  +0,000162] RIP  [<ffffffff81697182>] __vb2_queue_alloc+0x82/0x500
[  +0,000024]  RSP <ffff8800c06bfc30>
[  +0,000013] CR2: ffff8806b6c86230
[  +0,004618] ---[ end trace cad6fdfac7f4a02e ]---

Help me please. I don't know, what i can do with that


Last edited by lawl on Sat Jul 19, 2014 5:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
boerKrelis
Apprentice
Apprentice


Joined: 01 Jul 2003
Posts: 241
Location: The Netherlands

PostPosted: Fri Jul 18, 2014 1:56 pm    Post subject: Reply with quote

Looks like a driver bug, you might want to report it at bugzilla.kernel.org .
Back to top
View user's profile Send private message
lawl
n00b
n00b


Joined: 18 Jul 2014
Posts: 20

PostPosted: Fri Jul 18, 2014 2:30 pm    Post subject: Reply with quote

boerKrelis wrote:
Looks like a driver bug, you might want to report it at bugzilla.kernel.org .

Thanks for fast response!
I already reported this bug, but may be I can use another driver or do something else. I remember I worked with this cam with another kernel, but now forgot config and version of that.
Back to top
View user's profile Send private message
lawl
n00b
n00b


Joined: 18 Jul 2014
Posts: 20

PostPosted: Sat Jul 19, 2014 11:56 am    Post subject: Reply with quote

Solved by upgrade kernel to 3.16 version
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum