Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing the upgrade of Firefox... [solved]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Fri Jul 18, 2014 1:52 pm    Post subject: Installing the upgrade of Firefox... [solved] Reply with quote

While, Gentoo is a nice piece of Hardware i just want to ask how to upgrade firefox on my netbook.

Code:
These are the packages that would be merged, in order:                                                                                         
                                                                                                                                               
Calculating dependencies /                                                                                                                     
                                                                                                                                               
!!! Problem resolving dependencies for app-misc/tracker:0 from @__auto_slot_operator_replace_installed__                                       
... done!                                                                                                                                     
[ebuild     U  ] dev-libs/expat-2.1.0-r4 [2.1.0-r2] USE="unicode -examples -static-libs" 0 kB                                                 
[ebuild     U  ] virtual/libiconv-0-r1 [0] 0 kB
[ebuild  N     ] dev-lang/python-exec-2.0.1-r1:2  PYTHON_TARGETS="(jython2_5) (jython2_7) (pypy) (python2_7) (python3_2) (python3_3) (python3_4)" 80 kB
[ebuild     U  ] dev-libs/libffi-3.1-r3 [3.0.11] USE="-debug -pax_kernel% -static-libs {-test}" 916 kB
[ebuild     U  ] virtual/libffi-3.0.13-r1 [3.0.11] 0 kB
[ebuild     U  ] media-libs/libvpx-1.3.0 [1.1.0] USE="mmx sse sse2 ssse3 threads (-altivec) -avx% -avx2% -doc -postproc -sse3 -sse4_1 -static-libs {-test%} (-debug%)" 2,036 kB
[ebuild     U  ] dev-libs/gobject-introspection-common-1.40.0 [1.34.2] 1,257 kB
[ebuild     U  ] sys-libs/zlib-1.2.8-r1 [1.2.7] USE="minizip -static-libs" 558 kB
[ebuild     U  ] dev-libs/nspr-4.10.6-r1 [4.9.4] USE="-debug" 1,105 kB
[ebuild     U  ] media-libs/libpng-1.6.12:0/16 [1.5.14:0/15] USE="apng (-neon) -static-libs" 891 kB
[ebuild     U  ] dev-lang/tcl-8.6.1-r1:0/8.6 [8.6.0-r1:0/8.6] USE="threads -debug" 5,639 kB
[ebuild     U  ] dev-util/gtk-doc-am-1.20 [1.18] 629 kB
[uninstall     ] dev-util/gtk-doc-1.18-r1  USE="-debug -doc -emacs -highlight {-test} -vim"
[blocks b      ] <dev-util/gtk-doc-1.20 ("<dev-util/gtk-doc-1.20" is blocking dev-util/gtk-doc-am-1.20)
[ebuild     U  ] dev-libs/glib-2.40.0-r1:2 [2.34.3:2] USE="(mime%*) -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" PYTHON_TARGETS="python2_7%*" 6,852 kB
[ebuild     U  ] dev-util/pkgconfig-0.28-r1 [0.28] USE="-hardened -internal-glib" 0 kB
[ebuild     U  ] virtual/pkgconfig-0-r1 [0] 0 kB
[ebuild     U  ] x11-proto/xproto-7.0.26 [7.0.23-r1] USE="-doc" 299 kB
[ebuild     U  ] x11-proto/xextproto-7.3.0 [7.2.1] USE="-doc" 224 kB
[ebuild     U  ] x11-proto/inputproto-2.3.1 [2.2] 192 kB
[ebuild     U  ] x11-proto/kbproto-1.0.6-r1 [1.0.6] 0 kB
[ebuild     U  ] sys-apps/kmod-18-r1 [12-r1] USE="lzma tools zlib -debug -doc -python% -static-libs" PYTHON_TARGETS="python2_7%* python3_3%* -python3_2% -python3_4%" 1,440 kB
[ebuild     U  ] x11-proto/xf86vidmodeproto-2.3.1-r1 [2.3.1] 0 kB
[ebuild     U  ] dev-libs/libpthread-stubs-0.3-r1 [0.3] USE="-static-libs" 0 kB
[ebuild     U  ] x11-proto/xf86bigfontproto-1.2.0-r1 [1.2.0] 0 kB
[ebuild     U  ] x11-proto/damageproto-1.2.1-r1 [1.2.1] 0 kB
[ebuild     U  ] x11-proto/dri2proto-2.8-r1 [2.8] 0 kB
[ebuild  N     ] x11-proto/dri3proto-1.0  103 kB
[ebuild  N     ] x11-proto/presentproto-1.0  106 kB
[ebuild     U  ] x11-proto/glproto-1.4.17 [1.4.16] 124 kB
[ebuild     U  ] x11-proto/xf86driproto-2.1.1-r1 [2.1.1] 0 kB
[ebuild     U  ] x11-libs/libXau-1.0.8 [1.0.7] USE="-static-libs" 289 kB
[ebuild     U  ] x11-libs/libXdmcp-1.1.1-r1 [1.1.1] USE="-doc -static-libs" 0 kB
[ebuild  N     ] x11-libs/libxshmfence-1.1  USE="-static-libs" 285 kB
[ebuild     U  ] x11-proto/fixesproto-5.0-r1 [5.0] 0 kB
[ebuild     U  ] x11-libs/libpciaccess-0.13.2 [0.13.1] USE="zlib -minimal -static-libs" 351 kB
[ebuild     U  ] x11-libs/libdrm-2.4.54 [2.4.40] USE="-libkms -static-libs" VIDEO_CARDS="intel (-exynos) (-freedreno) -nouveau (-omap) -radeon -vmware" 630 kB
[ebuild     U  ] dev-lang/python-2.7.7:2.7 [2.7.3-r3:2.7] USE="gdbm ipv6 ncurses readline sqlite ssl threads (wide-unicode) xml -berkdb -build -doc -examples -hardened% -tk -wininst" 10,264 kB
[ebuild     U  ] dev-libs/gobject-introspection-1.40.0 [1.34.2-r1] USE="cairo%* -doctool {-test}" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
[blocks b      ] <dev-libs/gobject-introspection-1.40.0 ("<dev-libs/gobject-introspection-1.40.0" is blocking dev-libs/gobject-introspection-common-1.40.0)                                                                                                                                   
[blocks b      ] <dev-libs/gobject-introspection-1.40 ("<dev-libs/gobject-introspection-1.40" is blocking dev-libs/glib-2.40.0-r1)
[ebuild     U  ] x11-proto/xcb-proto-1.10 [1.8] PYTHON_TARGETS="python2_7%* python3_3%* -python3_2%" 136 kB
[ebuild     U  ] x11-libs/libxcb-1.10 [1.9] USE="xkb%* -doc (-selinux) -static-libs" 465 kB
[ebuild     U  ] x11-libs/libX11-1.6.2 [1.5.0] USE="ipv6 -doc -static-libs {-test}" 2,286 kB
[ebuild     U  ] x11-libs/libXext-1.3.2 [1.3.1] USE="-doc -static-libs" 371 kB
[ebuild     U  ] x11-libs/libXfixes-5.0.1 [5.0] USE="-static-libs" 286 kB
[ebuild     U  ] x11-libs/libXxf86vm-1.1.3 [1.1.2] USE="-static-libs" 278 kB
[ebuild     U  ] x11-libs/libXdamage-1.1.4-r1 [1.1.4] USE="-static-libs" 0 kB
[ebuild     U  ] sys-libs/ncurses-5.9-r3:5 [5.9-r2:5] USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs -tinfo -trace" 0 kB
[ebuild     U  ] sys-libs/gpm-1.20.7-r2 [1.20.7-r1] USE="(-selinux) -static-libs" 0 kB
[ebuild     U  ] sys-libs/readline-6.3_p6-r1 [6.2_p4] USE="-static-libs" 2,420 kB
[ebuild     U  ] sys-devel/llvm-3.4.2:0/3.4 [3.1-r2:0/0] USE="libffi ncurses%* static-analyzer%* xml%* -clang% -cmake% -debug -doc% -gold -multitarget -ocaml -python% {-test} -udis86 (-vim-syntax%)" PYTHON_TARGETS="python2_7%* -pypy%" VIDEO_CARDS="-radeon%" 15,598 kB
[ebuild     U  ] dev-db/sqlite-3.8.5:3 [3.7.15.2:3] USE="readline tcl -debug -doc -icu -secure-delete -static-libs {-test} (-extensions%*) (-fts3%*) (-soundex%) (-threadsafe%*) (-unlock-notify%)" 5,498 kB
[ebuild     U  ] dev-libs/nss-3.16.1 [3.14.1] USE="cacert%* nss-pem%* -utils" 6,288 kB
[ebuild     U  ] sys-fs/udev-215 [197-r6] USE="acl firmware-loader%* gudev introspection kmod -doc (-selinux) -static-libs (-hwdb%*) (-keymap%*) (-openrc%*)" 2,824 kB
[ebuild  N     ] virtual/libudev-208:0/1  USE="-static-libs" 0 kB
[ebuild  N     ] virtual/libgudev-208  USE="introspection -static-libs" 0 kB
[ebuild     U  ] virtual/udev-208-r2 [197] USE="gudev introspection -static-libs (-hwdb%*) (-keymap%*) (-kmod%*) (-selinux%)" 0 kB
[ebuild     U  ] sys-apps/hwids-20140627 [20130131] USE="net%* pci%* udev usb%*" 1,613 kB
[ebuild     U  ] sys-fs/udev-init-scripts-26-r2 [22] 5 kB
[ebuild     U  ] media-libs/mesa-10.2.2 [9.0.1] USE="classic dri3%* egl gallium llvm nptl -bindist -debug -gbm -gles1 -gles2 -opencl% -openmax% -openvg -osmesa -pax_kernel -pic -r600-llvm-compiler (-selinux) -vdpau -wayland -xa -xvmc (-g3dvl%) (-shared-glapi%*) (-xorg%)" VIDEO_CARDS="intel (-freedreno) -i915 -i965 -ilo% -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware" 6,959 kB
[ebuild     U  ] www-client/firefox-30.0 [18.0.1] USE="alsa dbus gstreamer jit libnotify minimal pulseaudio%* startup-notification wifi -bindist -custom-cflags -custom-optimization -debug -hardened% (-pgo) (-selinux) -system-cairo% -system-icu% -system-jpeg -system-sqlite {-test%}" LINGUAS="de -af -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -csb -cy -da -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -km -kn -ko -ku -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -te -th -tr -uk -vi -xh% -zh_CN -zh_TW -zu (-ak%) (-lg%) (-nso%) (-ta_LK%)" 140,178 kB
[blocks B      ] <sys-apps/openrc-0.12 ("<sys-apps/openrc-0.12" is blocking sys-apps/kmod-18-r1)
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.40.0)
[blocks B      ] <sys-fs/lvm2-2.02.103 ("<sys-fs/lvm2-2.02.103" is blocking sys-fs/udev-215)
[blocks B      ] <dev-python/python-exec-10000 ("<dev-python/python-exec-10000" is blocking dev-lang/python-exec-2.0.1-r1)

Total: 58 packages (52 upgrades, 6 new, 1 uninstall), Size of downloads: 219,457 kB
Conflict: 7 blocks (4 unsatisfied)
thanks.

Last edited by ch64 on Mon Aug 11, 2014 11:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Fri Jul 18, 2014 7:21 pm    Post subject: Reply with quote

Good reading:
https://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?style=printable&full=1#book_part2 section 1e is particular to your problem
https://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?style=printable&full=1#book_part3

The feedback from the emerge command that appears after the section you posted provides more clues.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Sun Jul 20, 2014 6:08 pm    Post subject: Reply with quote

DONAHUE, my Linux Handbook helps not out. It's just for installation.
Do i really need another one.

I only guess, it's something with SLOTS i did not understand:
Hey, the Forum is really great. My Dolphin and Kmail are working, again.
I did a -avuDN system, just for to be sure. ;-)

http://pastebin.com/djKtmXw4
http://pastebin.com/yKiKVFML

PS: Do i smoke, too much? :D 8O
Back to top
View user's profile Send private message
P1neapple
n00b
n00b


Joined: 18 Jul 2014
Posts: 35

PostPosted: Mon Jul 21, 2014 6:26 am    Post subject: Reply with quote

Quote:
While, Gentoo is a nice piece of Hardware


It's software :wink:
_________________
Gentoo currently running in Virtualbox, hoping to switch to real hardware soon...
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Mon Jul 21, 2014 9:34 pm    Post subject: Reply with quote

I would try (knowing that things may get a little better or a whole lot worse): backup your system,boot a livecd/usb, preferably a current system rescue cd, to a GUI with network connection, mount the gentoo partitions, enter the chroot, nominally
Code:
mount /dev/sda3 /mnt/gentoo
mount /dev/sda1 /mnt/gentoo/boot
cp -L /etc/resolv.conf /mnt/gentoo/etc/
mount -t proc none /mnt/gentoo/proc
mount --rbind /sys /mnt/gentoo/sys
mount --rbind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash
source /etc/profile
export PS1="(chroot) $PS1"

Code:
emerge --sync

Code:
emerge portage

Code:
emerge python-updater perl-cleaner

Code:
nano /etc/portage/package.use

edit to add:
Quote:
>=media-libs/harfbuzz-0.9.28 icu
>=media-libs/mesa-10.2.4 gbm

Code:
emerge -C udev virtual/udev
emerge systemd

Code:
emerge -C upower virtual/python-argparse-1 net-im/amsn vlc pycairo pygobject orca gnome && emerge -1

Code:
emerge -C qtscript qthelp qtopengl geocode-glib qttest qtcore qtgui alsa-headers qtsql qtdeclarative qtxmlpatterns vala qtwebkit gdm qtsvg qtdbus lvm2 qt3support

Code:
emerge -1v qtscript  qthelp qtopengl qtsvg qttest qtgui qtcore qtsql qtdbus qtdeclarative qtxmlpatterns gobject-introspection python-exec gsettings-desktop-schemas udev upower-pm-utils qtwebkit qt3support

Code:
emerge gnome lvm2 geocode-glib vala gdm linux-headers

Code:
emerge -uND world

Code:
perl-cleaner reallyall
python updater
emerge -1 libtool
revdep-rebuild

make a graceful exit:
Code:
exit
cd
umount -l /mnt/gentoo/dev{/shm,/pts,}
umount -l /mnt/gentoo{/boot,/proc,}
reboot
as failures occur where you want help rerun the command piped to wgetpaste and post the url. Updating from the distant past is painful.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Sun Jul 27, 2014 3:58 pm    Post subject: Reply with quote

At first: This was a joke, with Gentoo beeing Hardware. ;-)

Then: When i booted, there was not finding /sbin/rc ...
So i booted up a live system. And reinstalled openrc.
Now i have the problem, that the system is not booting anymore.
I have:
Code:

!! The filesystem mounted at /dev/sda6 does not appear to be a valid /, try again
!! Could not find the root block device in .
    Please specify another value or: press Enter for the same, type "shell" for a shell, or "q" to skip...
root block device() ::


I don't really know why. Maybe this error came while i was deinstalling/removing some important packages?
The kernel isn't the thing.
And: When i go to a shell i can mount that root partition /dev/sda6 !

Now when doing like DONAHUE said... at emerge systemd i stop.

Code:

# emerge systemd
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
!!! Repository 'x-portage' is missing masters attribute in '/usr/local/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility

 * IMPORTANT: 30 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     U  ] virtual/libiconv-0-r1 [0]
[ebuild  N     ] sys-libs/libseccomp-2.1.1  USE="-static-libs"
[ebuild     U  ] dev-libs/libffi-3.1-r3 [3.0.11] USE="-pax_kernel%"
[ebuild     U  ] virtual/libffi-3.0.13-r1 [3.0.11]
[ebuild     U  ] dev-util/gtk-doc-am-1.20 [1.18]
[uninstall     ] dev-util/gtk-doc-1.18-r1
[blocks b      ] <dev-util/gtk-doc-1.20 ("<dev-util/gtk-doc-1.20" is blocking dev-util/gtk-doc-am-1.20)
[ebuild     U  ] dev-libs/glib-2.40.0-r1 [2.34.3] USE="(mime%*)" PYTHON_TARGETS="python2_7%*"
[uninstall     ] dev-util/gdbus-codegen-2.34.3
[blocks b      ] <dev-util/gdbus-codegen-2.40.0 ("<dev-util/gdbus-codegen-2.40.0" is blocking dev-libs/glib-2.40.0-r1)
[ebuild     U  ] sys-apps/kmod-18-r1 [12-r1] USE="-python%" PYTHON_TARGETS="python2_7%* python3_3%* -python3_2% -python3_4%"
[ebuild     U  ] sys-kernel/linux-headers-3.15 [3.7]
[ebuild  N     ] sys-apps/systemd-215-r1  USE="acl filecaps firmware-loader gudev introspection kmod lzma pam policykit seccomp ssl -audit -cryptsetup -doc -elfutils -gcrypt -http (-kdbus) -python -qrcode (-selinux) {-test} -vanilla" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2"
[ebuild  N     ] sys-apps/gentoo-systemd-integration-4
[ebuild  N     ] virtual/libudev-208  USE="-static-libs"
[ebuild  N     ] virtual/libgudev-208  USE="introspection -static-libs"
[ebuild  N     ] virtual/udev-208-r2  USE="gudev introspection -static-libs"
[ebuild     U  ] sys-apps/hwids-20140627 [20130131] USE="net%* pci%* usb%*"
[ebuild  N     ] sys-fs/udev-init-scripts-26-r2
[blocks B      ] media-sound/alsa-headers ("media-sound/alsa-headers" is hard blocking sys-kernel/linux-headers-3.15)
[blocks B      ] >=sys-apps/systemd-197 (">=sys-apps/systemd-197" is blocking sys-auth/nss-myhostname-0.3)
[blocks B      ] <dev-libs/gobject-introspection-1.40 ("<dev-libs/gobject-introspection-1.40" is blocking dev-libs/glib-2.40.0-r1)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking app-admin/openrc-settingsd-1.0.1)
[blocks B      ] sys-auth/nss-myhostname ("sys-auth/nss-myhostname" is blocking sys-apps/systemd-215-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-admin/openrc-settingsd-1.0.1:0/0::gentoo, installed) pulled in by
    app-admin/openrc-settingsd required by (gnome-base/gnome-control-center-3.6.3-r1:2/2::gentoo, installed)

  (sys-kernel/linux-headers-3.15:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-kernel/linux-headers:0 required by (virtual/os-headers-0:0/0::gentoo, installed)
    >=sys-kernel/linux-headers-3.8 required by (sys-apps/systemd-215-r1:0/2::gentoo, ebuild scheduled for merge)

  (sys-apps/systemd-215-r1:0/2::gentoo, ebuild scheduled for merge) pulled in by
    systemd
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs(-)?] (>=sys-apps/systemd-212-r5:0/2[abi_x86_32(-),gudev,introspection]) required by (virtual/libgudev-208:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs(-)?] (>=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)]) required by (virtual/libudev-208:0/1::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-208:0 required by (virtual/udev-208-r2:0/0::gentoo, ebuild scheduled for merge)

  (dev-libs/glib-2.40.0-r1:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.33:2 required by (media-video/totem-3.6.3-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-mobilephone/obexd-0.46:0/0::gentoo, installed)
    >=dev-libs/glib-2.33.3:2 required by (gnome-base/dconf-0.14.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (media-gfx/eog-3.6.2:1/1::gentoo, installed)
    >=dev-libs/glib-2.32 required by (gnome-extra/gucharmap-3.6.1:2.90/2.90::gentoo, installed)
    >=dev-libs/glib-2.26.0:2 required by (x11-terms/gnome-terminal-3.6.1-r2:0/0::gentoo, installed)
    >=dev-libs/glib-2.30:2 required by (gnome-extra/gnome-search-tool-3.6.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-faad-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.28.0:2 required by (media-libs/cogl-1.12.2:1.0/11::gentoo, installed)
    >=dev-libs/glib-2.26 required by (x11-libs/libnotify-0.7.5:0/0::gentoo, installed)
    >=dev-libs/glib-2.30:2 required by (net-im/telepathy-mission-control-5.14.0-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-resindvd-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-editors/gedit-3.6.2-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (gnome-base/libgnomeui-2.24.5:0/0::gentoo, installed)
    >=dev-libs/glib-2.31.10:2 required by (gnome-extra/gnome-color-manager-3.6.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (net-libs/gupnp-0.18.4:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (x11-libs/gtksourceview-3.6.2:3.0/3.0::gentoo, installed)
    dev-libs/glib:2 required by (dev-haskell/gio-0.12.4:0/0.12.4::gentoo, installed)
    >=dev-libs/glib-2.22:2 required by (net-libs/gssdp-0.12.2.1:0/0::gentoo, installed)
    >=dev-libs/glib-2 required by (x11-misc/shared-mime-info-1.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.30 required by (dev-util/pkgconfig-0.28:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-soup-0.10.31:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.4:2 required by (dev-libs/libIDL-0.8.14:0/0::gentoo, installed)
    >=dev-libs/glib-2.16 required by (x11-libs/libxklavier-5.3:0/0::gentoo, installed)
    >=dev-libs/glib-2.30.0:2 required by (media-gfx/shotwell-0.13.1-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-accessibility/at-spi2-core-2.6.3:2/2::gentoo, installed)
    >=dev-libs/glib-2.30 required by (gnome-extra/polkit-gnome-0.105:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-ugly-0.10.19:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.34:2 required by (net-libs/glib-networking-2.34.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.33.1:2 required by (net-libs/libsoup-2.40.2:2.4/2.4::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-bad-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2 required by (app-misc/geoclue-0.12.99:0/0::gentoo, installed)
    >=dev-libs/glib-2:2 required by (sys-libs/libosinfo-0.2.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.10:2 required by (gnome-base/libgnomecanvas-2.30.3:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/gst-plugins-base-1.0.5-r1:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.14:2 required by (x11-libs/gtksourceview-2.10.5-r2:2.0/2.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-vorbis-0.10.36:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-x264-0.10.19:0.10/0.10::gentoo, installed)
    dev-libs/glib:2 required by (net-dns/avahi-0.6.31:0/0::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-extra/gcalctool-6.6.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-a52dec-0.10.19:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-xvid-0.10.23:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.30 required by (media-video/gnome-mplayer-1.0.7:0/0::gentoo, installed)
    >=dev-libs/glib-2.28.5 required by (app-pda/gtkpod-2.1.3-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-mpeg2dec-0.10.19:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/gst-plugins-bad-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-wavpack-0.10.31:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.25.11:2 required by (x11-wm/mutter-3.6.2:0/0::gentoo, installed)
    dev-libs/glib:2 required by (media-sound/mpd-0.17.3:0/0::gentoo, installed)
    >=dev-libs/glib-2.22 required by (sys-power/upower-0.9.19:0/0::gentoo, installed)
    >=dev-libs/glib-2.33.12:2 required by (x11-libs/pango-1.32.5:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (dev-libs/folks-0.8.0:0/25::gentoo, installed)
    >=dev-libs/glib-2.9.3 required by (gnome-base/gnome-vfs-2.24.4-r1:2/2::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-bad-0.10.23-r1:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-taglib-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-sound/sound-juicer-3.5.1_pre20121231:0/0::gentoo, installed)
    >=dev-libs/glib-2.26.0:2 required by (games-board/aisleriot-3.2.3.2-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.31.0:2 required by (dev-python/pygobject-3.4.2-r1:3/3::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-wavpack-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.10.1:2 required by (app-admin/syslog-ng-3.3.5-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.25.11:2 required by (gnome-extra/yelp-3.6.2:0/0::gentoo, installed)
    >=dev-libs/glib-2:2 required by (sys-block/gparted-0.14.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-faad-0.10.23:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-libs/webkit-gtk-1.10.2-r300:3/3::gentoo, installed)
    >=dev-libs/glib-2.30:2 required by (net-libs/farstream-0.1.2-r1:0.1/0.1::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-good-0.10.31:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (www-client/firefox-18.0.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.33.12:2 required by (gnome-base/gvfs-1.14.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.20:2 required by (media-libs/clutter-gst-2.0.0:2.0/2.0::gentoo, installed)
    >=dev-libs/glib-2.28.0:2 required by (x11-misc/colord-0.1.28:0/1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-flac-0.10.31:0.10/0.10::gentoo, installed)
    dev-libs/glib:2 required by (dev-haskell/gtk-0.12.4:2/0.12.4::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-theora-0.10.36:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.31.14:2 required by (gnome-base/gnome-panel-3.6.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (net-voip/telepathy-salut-0.8.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.32.2 required by (media-plugins/audacious-plugins-3.3.3:0/0::gentoo, installed)
    dev-libs/glib:2 required by (sys-fs/fuseiso-20070708:0/0::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-util/desktop-file-utils-0.21:0/0::gentoo, installed)
    >=dev-libs/glib-2.25.10:2 required by (x11-wm/metacity-2.34.13:0/0::gentoo, installed)
    >=dev-libs/glib-2.25.9:2 required by (gnome-extra/nautilus-sendto-3.6.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.26 required by (dev-libs/dbus-glib-0.100-r2:0/0::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (dev-python/pygtk-2.24.0-r3:2/2::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/gst-plugins-good-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (gnome-extra/evolution-data-server-3.6.3:0/40::gentoo, installed)
    >=dev-libs/glib-2.6.0:2 required by (net-irc/xchat-2.8.8-r2:2/2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-lame-0.10.19:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-ugly-0.10.19:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.31.6:2 required by (gnome-base/gnome-shell-3.6.2-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-x-0.10.36:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (dev-libs/gjs-1.34.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gstreamer-0.10.36:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (gnome-base/librsvg-2.36.4:2/2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-vpx-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-dts-0.10.23:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.31.10 required by (gnome-extra/gnome-power-manager-3.6.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (x11-libs/colord-gtk-0.1.24:0/1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-xvideo-0.10.36:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.25.11:2 required by (net-im/telepathy-logger-0.6.0:0/3::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-alsa-0.10.36:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.34.2:2 required by (gnome-base/gnome-core-libs-3.6.2:3.0/3.0::gentoo, installed)
    >=dev-libs/glib-2.33.4:2 required by (gnome-base/gnome-session-3.6.2-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.31.0:2 required by (media-gfx/gnome-font-viewer-3.6.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.22 required by (sys-auth/consolekit-0.4.5_p20120320-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-oss-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.31.0:2 required by (gnome-base/gnome-settings-daemon-3.6.4:0/0::gentoo, installed)
    dev-libs/glib:2 required by (kde-base/systemsettings-4.9.5:4/4::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-base/gnome-control-center-3.6.3-r1:2/2::gentoo, installed)
    >=dev-libs/glib-2.18:2 required by (dev-libs/gmime-2.6.13:2.6/2.6::gentoo, installed)
    >=dev-libs/glib-2.30.2:2 required by (media-gfx/gimp-2.8.2-r1:2/2::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (media-video/cheese-3.6.2:0/7::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (app-admin/gnome-system-log-3.6.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-accessibility/orca-3.6.3-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/gst-plugins-ugly-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-libs/libgee-0.6.7:0/0::gentoo, installed)
    >=dev-libs/glib-2:2 required by (app-admin/gam-server-0.1.10-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.33:2 required by (app-text/evince-3.6.1:0/evd3.4-evv3.3::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/libcanberra-0.30-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.6.0:2 required by (gnome-base/libbonoboui-2.24.5:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-oss-0.10.31:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.25.10 required by (net-analyzer/gnome-nettool-3.2.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (dev-libs/libpeas-1.6.2-r1:0/0::gentoo, installed)
    dev-libs/glib:2 required by (sys-auth/polkit-qt-0.103.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.24.0:2 required by (dev-python/pygobject-2.28.6-r53:2/2::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-auth/polkit-0.110:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-ugly-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.28.0:2 required by (x11-libs/mx-1.4.7:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-musepack-0.10.23:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (dev-util/anjuta-3.6.2-r1:0/0::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/memphis-0.2.3:0.2/0.2::gentoo, installed)
    dev-libs/glib:2 required by (dev-haskell/glib-0.12.4:0/0.12.4::gentoo, installed)
    dev-libs/glib:2 required by (app-text/poppler-0.20.5:0/0::gentoo, installed)
    >=dev-libs/glib-2.14:2 required by (net-libs/libsocialweb-0.25.21:0/0::gentoo, installed)
    dev-libs/glib:2 required by (dev-qt/qtwebkit-4.8.4:4/4::gentoo, installed)
    >=dev-libs/glib-2.28.0:2 required by (net-misc/vinagre-3.6.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (gnome-extra/nautilus-tracker-tags-0.14.4:0/0::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (dev-libs/json-glib-0.15.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-libs/telepathy-farstream-0.6.0:0/3::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (dev-lang/vala-0.12.1-r1:0.12/0.12::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (gnome-extra/zenity-3.6.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.30:2 required by (sys-apps/accountsservice-0.6.30:0/0::gentoo, installed)
    >=dev-libs/glib-2.30 required by (media-sound/audacious-3.3.3:0/0::gentoo, installed)
    >=dev-libs/glib-2.10:2 required by (gnome-base/libglade-2.6.4:2.0/2.0::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (net-libs/libproxy-0.4.10-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.12 required by (app-editors/mousepad-0.3.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (dev-libs/totem-pl-parser-3.4.3-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2 required by (app-accessibility/speech-dispatcher-0.7.1-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.30 required by (sys-fs/udisks-1.0.4-r5:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-v4l2-0.10.31:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2 required by (gnome-base/libgnomeprint-2.18.8:2.2/2.2::gentoo, installed)
    >=dev-libs/glib-2.29.14:2 required by (app-arch/file-roller-3.6.3:0/0::gentoo, installed)
    >=dev-libs/glib-2.30.0:2 required by (net-print/cups-pk-helper-0.2.4:0/0::gentoo, installed)
    >=dev-libs/glib-2 required by (dev-libs/fribidi-0.19.5-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.22:2 required by (gnome-base/gnome-applets-3.6.0-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-libs/gnome-online-accounts-3.6.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (gnome-base/orbit-2.14.19-r1:2/2::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (dev-libs/libgdata-0.13.2-r2:0/13::gentoo, installed)
    dev-libs/glib:2 required by (kde-base/kscreensaver-4.9.5:4/4::gentoo, installed)
    >=dev-libs/glib-2.25.7:2 required by (dev-libs/libunique-3.0.2:3/3::gentoo, installed)
    dev-libs/glib:2 required by (dev-libs/libcroco-0.6.8:0.6/0.6::gentoo, installed)
    >=dev-libs/glib-2.31.2:2 required by (dev-libs/atk-2.6.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-dvdread-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.32.0:2 required by (gnome-base/gnome-keyring-3.6.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (media-libs/gegl-0.2.0-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.33.3:2 required by (net-im/empathy-3.6.3:0/0::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-base/gsettings-desktop-schemas-3.6.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (net-wireless/bluez-4.101-r5:0/0::gentoo, installed)
    >=dev-libs/glib-2.26 required by (net-misc/networkmanager-0.9.6.4-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.29.90:2 required by (net-wireless/gnome-bluetooth-3.6.1:2/11::gentoo, installed)
    dev-libs/glib:2 required by (dev-libs/gdl-3.6.2:3/5::gentoo, installed)
    >=dev-libs/glib-2.28.6:2 required by (x11-libs/cairo-1.12.10-r2:0/0::gentoo, installed)
    dev-libs/glib:2 required by (net-misc/olsrd-0.6.4:0/0::gentoo, installed)
    >=dev-libs/glib-2.30 required by (media-libs/gmtk-1.0.7:0/0::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-fs/udisks-2.0.91:2/2::gentoo, installed)
    >=dev-libs/glib-2.31.19:2 required by (media-libs/clutter-1.12.2:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.13:2 required by (net-libs/libnice-0.1.3-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.12.9 required by (media-sound/xmms2-0.8-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.4.2 required by (sys-fs/sshfs-fuse-2.4:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-jpeg-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-v4l2-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.31.6:2 required by (gnome-extra/gnome-documents-3.6.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-base-0.10.36:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (gnome-base/libgtop-2.28.4:2/2::gentoo, installed)
    >=dev-libs/glib-2.13 required by (dev-libs/libgweather-3.6.2:2/3-1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-gconf-0.10.31:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-pulse-1.0.5:1.0/1.0::gentoo, installed)
    dev-libs/glib:2 required by (kde-misc/kde-gtk-config-2.1.1:4/4::gentoo, installed)
    >=dev-libs/glib-2.18:2 required by (gnome-base/libgnomekbd-3.6.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.33.2:2 required by (gnome-base/gdm-3.6.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-ogg-0.10.36:0.10/0.10::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/gexiv2-0.4.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.28 required by (x11-misc/notification-daemon-0.7.6:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-resindvd-0.10.23:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (net-misc/vino-3.6.2-r1:0/0::gentoo, installed)
    dev-libs/glib:2 required by (gnome-extra/zeitgeist-0.9.5:0/0::gentoo, installed)
    >=dev-libs/glib-2.32.0:2 required by (net-libs/telepathy-glib-0.20.1-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.30 required by (www-plugins/gecko-mediaplayer-1.0.7:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-bad-0.10.23-r1:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.30.0:2 required by (sys-apps/baobab-3.6.4:0/0::gentoo, installed)
    >=dev-libs/glib-2.34:2 required by (dev-cpp/glibmm-2.34.1:2/2::gentoo, installed)
    >=dev-libs/glib-2.16 required by (net-im/pidgin-2.10.6:0/0::gentoo, installed)
    dev-libs/glib:2 required by (kde-base/phonon-kde-4.9.5:4/4::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (app-i18n/ibus-1.4.99.20121006:0/0::gentoo, installed)
    >=dev-libs/glib-2.29.15:2 required by (gnome-base/gnome-menus-3.6.2:3/3::gentoo, installed)
    >=dev-libs/glib-2.33.1 required by (x11-libs/gtk+-3.6.3-r2:3/3::gentoo, installed)
    >=dev-libs/glib-2.26 required by (net-libs/xulrunner-2.0.1-r1:1.9/1.9::gentoo, installed)
    >=dev-libs/glib-2.33.1:2 required by (media-gfx/gnome-screenshot-3.6.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-dicts/gnome-dictionary-3.6.0:0/6::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-mad-0.10.19:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-base/gconf-3.2.6:2/2::gentoo, installed)
    >=dev-libs/glib-2 required by (app-admin/system-config-printer-common-1.3.12:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-cdparanoia-0.10.36:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-a52dec-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (gnome-base/libgnome-2.32.1-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (net-libs/libzapojit-0.0.2:0/0::gentoo, installed)
    dev-libs/glib:2 required by (dev-libs/libzeitgeist-0.3.18:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-mpeg2dec-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-cdparanoia-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-dvdread-0.10.19:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-good-0.10.31:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.30.1:2 required by (net-libs/gtk-vnc-0.5.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.30:2 required by (x11-libs/gtk+-2.24.14:2/2::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-libs/webkit-gtk-1.8.3-r200:2/2::gentoo, installed)
    >=dev-libs/glib-2.6.0 required by (net-irc/irssi-0.8.15-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-pulse-0.10.31:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-libs/farstream-0.2.2:0.2/0.2::gentoo, installed)
    >=dev-libs/glib-2.4.0 required by (media-sound/pulseaudio-3.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (dev-lang/vala-0.14.2-r2:0.14/0.14::gentoo, installed)
    dev-libs/glib:2 required by (app-accessibility/at-spi2-atk-2.6.2:2/2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-base-0.10.36:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (app-crypt/gcr-3.6.2:0/1::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (gnome-extra/gnome-system-monitor-3.6.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (media-libs/libgpod-0.8.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-lame-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (net-libs/gupnp-igd-0.2.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (dev-libs/libgusb-0.1.4:0/0::gentoo, installed)
    >=dev-libs/glib-2.31.13:2 required by (x11-libs/vte-0.34.2:2.90/2.90::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-mad-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (mail-client/evolution-3.6.3:2.0/2.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-base-1.0.5-r1:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-dts-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (dev-lang/vala-0.16.1-r2:0.16/0.16::gentoo, installed)
    dev-libs/glib:2 required by (dev-qt/qtcore-4.8.4-r1:4/4::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-misc/tracker-0.14.4:0/0::gentoo, installed)
    >=dev-libs/glib-2.33.13:2 required by (gnome-base/nautilus-3.6.3:0/0::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/libchamplain-0.12.3:0.12/0.12::gentoo, installed)
    dev-libs/glib:2 required by (app-text/enchant-1.6.0:0/0::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/harfbuzz-0.9.11:0/0::gentoo, installed)
    >=dev-libs/glib-2.25.9:2 required by (gnome-extra/mousetweaks-3.6.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.34.0:2 required by (x11-libs/gdk-pixbuf-2.26.5:2/2::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (net-libs/rest-0.7.90:0.7/0.7::gentoo, installed)
    >=dev-libs/glib-2.25.6:2 required by (gnome-extra/gnome-screensaver-3.6.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-x264-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.14:2 required by (gnome-base/libbonobo-2.24.3:0/0::gentoo, installed)
    >=dev-libs/glib-2.10:2 required by (app-crypt/seahorse-3.6.3:0/0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-good-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (x11-libs/libwnck-3.4.4:3/3::gentoo, installed)
    >=dev-libs/glib-2.33.3:2 required by (gnome-base/gnome-desktop-3.6.2:3/4::gentoo, installed)
    dev-libs/glib:2 required by (x11-libs/wxGTK-2.8.12.1:2.8/2.8::gentoo, installed)
    >=dev-libs/glib-2.16 required by (media-sound/streamripper-1.64.6:0/0::gentoo, installed)
    >=dev-libs/glib-2.31.0:2 required by (app-crypt/libsecret-0.12:0/0::gentoo, installed)
    dev-libs/glib:2 required by (sci-geosciences/geocode-glib-0.99.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.31.10:2 required by (gnome-extra/gnome-contacts-3.6.2:0/0::gentoo, installed)
    dev-libs/glib:2 required by (app-mobilephone/obex-data-server-0.4.6:0/0::gentoo, installed)
    >=dev-libs/glib-2.18:2 required by (dev-lang/vala-0.18.1:0.18/0.18::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-libs/libgee-0.8.3:0.8/0.8::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-flac-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.29.14:2 required by (app-cdr/brasero-3.6.1:0/3.1::gentoo, installed)
    >=dev-libs/glib-2.25.7 required by (gnome-extra/gnome-games-3.6.1-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/gstreamer-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.29.14:2 required by (gnome-extra/sushi-3.6.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (gnome-extra/nm-applet-0.9.6.4:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (gnome-extra/libgda-5.1.1-r1:5/4::gentoo, installed)
    >=dev-libs/glib-2.31.2:2 required by (www-client/epiphany-3.6.1:0/0::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/phonon-4.6.0-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.34.1:2 required by (dev-libs/gobject-introspection-1.34.2-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.34.3:2=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2=[abi_x86_32(-)]) required by (sys-apps/systemd-215-r1:0/2::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.30:2 required by (app-admin/openrc-settingsd-1.0.1:0/0::gentoo, installed)

  (dev-libs/gobject-introspection-1.34.2-r1:0/0::gentoo, installed) pulled in by
    dev-libs/gobject-introspection required by (gnome-extra/gnome-games-3.6.1-r1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (media-video/cheese-3.6.2:0/7::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-gnome-2.40.2:2.4/2.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (app-i18n/ibus-1.4.99.20121006:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36:0.10/0.10::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10 required by (net-libs/gupnp-igd-0.2.2:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (media-video/totem-3.6.3-r1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.20.5:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6:= required by (dev-libs/libgee-0.6.7:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/clutter-gst-2.0.0:2.0/2.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.4 required by (gnome-base/nautilus-3.6.3:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30.0 required by (net-libs/libzapojit-0.0.2:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6:0/0= required by (dev-libs/libgee-0.6.7:0/0::gentoo, installed)
    dev-libs/gobject-introspection required by (media-libs/memphis-0.2.3:0.2/0.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (net-libs/gssdp-0.12.2.1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (gnome-extra/sushi-3.6.1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.1.1 required by (dev-python/pygobject-3.4.2-r1:3/3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.6 required by (gnome-extra/gnome-documents-3.6.2:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.6.3-r2:3/3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.7 required by (dev-libs/libgdata-0.13.2-r2:0/13::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.34.2:2.90/2.90::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/gtksourceview-3.6.2:3.0/3.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.2 required by (media-libs/cogl-1.12.2:1.0/11::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.36.4:2/2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.0 required by (gnome-base/gsettings-desktop-schemas-3.6.1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/gdl-3.6.2:3/5::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (app-editors/gedit-3.6.2-r1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.1 required by (dev-libs/libpeas-1.6.2-r1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-3.4.4:3/3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.3 required by (app-cdr/brasero-3.6.1:0/3.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.4 required by (net-libs/gupnp-0.18.4:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (net-libs/rest-0.7.90:0.7/0.7::gentoo, installed)
    >=dev-libs/gobject-introspection-1.29 required by (app-crypt/gcr-3.6.2:0/1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.8.3-r200:2/2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30.0 required by (gnome-base/libgnome-keyring-3.6.0:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-wireless/gnome-bluetooth-3.6.1:2/11::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.8 required by (x11-misc/colord-0.1.28:0/1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.26.5:2/2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (app-misc/tracker-0.14.4:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.40.2:2.4/2.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6:0/0= required by (dev-libs/libgee-0.8.3:0.8/0.8::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.0.91:2/2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.2 required by (net-libs/gnome-online-accounts-3.6.2:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (net-libs/telepathy-glib-0.20.1-r1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.7 required by (gnome-base/gnome-desktop-3.6.2:3/4::gentoo, installed)
    >=dev-libs/gobject-introspection-1.33.10 required by (dev-libs/gjs-1.34.0:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-wm/mutter-3.6.2:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.1 required by (gnome-base/gnome-shell-3.6.2-r1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.32.5:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/totem-pl-parser-3.4.3-r1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (net-im/telepathy-logger-0.6.0:0/3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.4 required by (net-libs/gtk-vnc-0.5.1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (net-libs/telepathy-farstream-0.6.0:0/3::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (app-text/evince-3.6.1:0/evd3.4-evv3.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36:0.10/0.10::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.14:2/2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/libgweather-3.6.2:2/3-1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.3 required by (net-misc/networkmanager-0.9.6.4-r1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.110:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (media-gfx/eog-3.6.2:1/1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/clutter-gtk-1.4.2:1.0/1.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.11 required by (net-libs/farstream-0.1.2-r1:0.1/0.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (media-libs/clutter-1.12.2:1.0/1.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (gnome-extra/evolution-data-server-3.6.3:0/40::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (gnome-base/gnome-menus-3.6.2:3/3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (www-client/epiphany-3.6.1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:0/0= required by (gnome-base/gconf-3.2.6:2/2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.6.0:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-dns/avahi-0.6.31:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (gnome-extra/gucharmap-3.6.1:2.90/2.90::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gstreamer-1.0.5:1.0/1.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.29 required by (dev-libs/libgusb-0.1.4:0/0::gentoo, installed)
    dev-libs/gobject-introspection required by (media-libs/libchamplain-0.12.3:0.12/0.12::gentoo, installed)
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.19:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.4 required by (x11-libs/mx-1.4.7:1.0/1.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (sys-apps/accountsservice-0.6.30:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (gnome-base/gnome-panel-3.6.2:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (x11-libs/libnotify-0.7.5:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/json-glib-0.15.2:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (gnome-base/libgnomekbd-3.6.0:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.29 required by (app-crypt/libsecret-0.12:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.8 required by (x11-libs/colord-gtk-0.1.24:0/1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (gnome-extra/libgda-5.1.1-r1:5/4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.10.2-r300:3/3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.6.3:2/2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.3 required by (sci-geosciences/geocode-glib-0.99.0:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (gnome-base/gdm-3.6.2:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (net-libs/libsocialweb-0.25.21:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (sys-libs/libosinfo-0.2.2:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.11 required by (net-libs/farstream-0.2.2:0.2/0.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gst-plugins-base-1.0.5-r1:1.0/1.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.7 required by (app-accessibility/caribou-0.4.7:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.3:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-util/anjuta-3.6.2-r1:0/0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1:0= required by (sys-apps/systemd-215-r1:0/2::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- virtual/python-argparse-1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org> (6 Jul 2014)
# (on behalf of python@gentoo.org)
# The modules provided by those virtuals are built-in in all currently
# supported Python implementations. If your ebuild depends on either
# of them, please just remove the dependency. Removal in 30 days.

- media-video/vlc-2.0.5::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman <TomWij@gentoo.org> (8 Jun 2014)
# Mask VLC ebuilds that are affected with security bug CVE-2013-6934:
#
#     A vulnerability has been discovered in VLC Media Player, which can be
#     exploited by malicious people to compromise a user's system.
#
# Some ebuilds also have other buffer and integer overflow security bugs like
# CVE-2013-1954, CVE-2013-3245, CVE-2013-4388 and CVE-2013-6283.
#
# Users should consider to upgrade VLC Media Player to at least version 2.1.2.

- net-nds/openldap-2.4.33-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (20 Mar 2014)
# Security mask of vulnerable versions, wrt bug #424167

- sys-power/upower-0.9.19::gentoo (masked by: package.mask)
/usr/portage/profiles/base/package.mask:
# Rick Farina <zerochaos@gentoo.org> (6 Jun 2013)
# Pm-utils based hibernate and suspend support has discontinued.
# For continued support, use the upower-pm-utils fork or systemd.
# Systemd users can switch to a systemd profile or unmask <sys-power/upower-0.99.0
# Openrc users can "emerge -C upower && emerge -1 upower-pm-utils"

- media-libs/mesa-9.0.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (26 Mar 2014)
# Affected by multiple vulnerabilities, #445916, #471098 and #472280

- net-im/amsn-0.98.9::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Markos Chandras <hwoarang@gentoo.org> (23 Mar 2013)
# MSN service terminated.
# You can still use your MSN account in net-im/skype
# or switch to an open protocol instead
# These clients may work until Oct 2013 (or even longer in China)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Mon Jul 28, 2014 5:04 am    Post subject: Reply with quote

enter chroot and try to run
Code:
emerge -v sysvinit
to correct
Quote:
!! The filesystem mounted at /dev/sda6 does not appear to be a valid /, try again
!! Could not find the root block device in .
Please specify another value or: press Enter for the same, type "shell" for a shell, or "q" to skip...
root block device() ::
one can hope for no blockers
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Mon Jul 28, 2014 8:16 pm    Post subject: Reply with quote

Now with sysvinit the system is booting.
But i have in xdm/slim (user/password) no keyboard.
I cannot switch to a console.

Now in the livecd..
Code:
 emerge systemd
fails because i have not mounted /dev/shm

When i try to do this i get:
Code:
 # mount shm
mount: mount point /dev/shm is a symbolic link to nowhere

Code:
# cat /etc/fstab
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda5               /boot           ext2            noauto,noatime  1 2
/dev/sda6               /               ext3            noatime         0 1
/dev/sda7               none            swap            sw              0 0
#/dev/cdrom             /mnt/cdrom      auto            noauto,ro       0 0
#/dev/fd0               /mnt/floppy     auto            noauto          0 0
#/dev/sda1               /mnt/windows    vfat           rw              0 0
# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec     0 0


When i try the next step i get
Code:
 
emerge: there are no ebuilds built with USE flags to satisfy ">=dev-qt/qt3support-4.7.0:4[accessibility,kde]".
!!! One of the following packages is required to complete your request:
- dev-qt/qt3support-4.8.5::gentoo (Missing IUSE: kde)
(dependency required by "media-sound/kstreamripper-0.7.100-r1" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

I mean this:

Code:
# emerge -av qtscript qthelp qtopengl qtsvg qttest qtcore qtgui qtsql qtdeclarative qtxmlpatterns vala qtwebkit gdm qtsvg qtdbus lvm2 qt3support
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
!!! Repository 'x-portage' is missing masters attribute in '/usr/local/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility

 * IMPORTANT: 30 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/expat-2.1.0-r4 [2.1.0-r2] USE="unicode -examples -static-libs" 0 kB
[ebuild     U  ] sys-block/thin-provisioning-tools-0.3.2 [0.1.5-r1] USE="{-test%}" 171 kB
[ebuild     U  ] x11-proto/xproto-7.0.26 [7.0.23-r1] USE="-doc" 299 kB
[ebuild     U  ] x11-proto/xextproto-7.3.0 [7.2.1] USE="-doc" 224 kB
[ebuild     U  ] x11-proto/kbproto-1.0.6-r1 [1.0.6] 0 kB
[ebuild     U  ] x11-proto/xf86vidmodeproto-2.3.1-r1 [2.3.1] 0 kB
[ebuild     U  ] dev-libs/libpthread-stubs-0.3-r1 [0.3] USE="-static-libs" 0 kB
[ebuild     U  ] x11-proto/xf86bigfontproto-1.2.0-r1 [1.2.0] 0 kB
[ebuild     U  ] x11-proto/inputproto-2.3.1 [2.2] 192 kB
[ebuild     U  ] x11-proto/damageproto-1.2.1-r1 [1.2.1] 0 kB
[ebuild     U  ] x11-proto/dri2proto-2.8-r1 [2.8] 0 kB
[ebuild  N     ] x11-proto/dri3proto-1.0  103 kB
[ebuild  N     ] x11-proto/presentproto-1.0  106 kB
[ebuild     U  ] x11-proto/xf86driproto-2.1.1-r1 [2.1.1] 0 kB
[ebuild  N     ] x11-libs/libxshmfence-1.1  USE="-static-libs" 285 kB
[ebuild     U  ] x11-libs/libXau-1.0.8 [1.0.7] USE="-static-libs" 289 kB
[ebuild     U  ] x11-libs/libXdmcp-1.1.1-r1 [1.1.1] USE="-doc -static-libs" 0 kB
[ebuild     U  ] x11-proto/fixesproto-5.0-r1 [5.0] 0 kB
[ebuild     U  ] x11-proto/glproto-1.4.17 [1.4.16] 124 kB
[ebuild     U  ] x11-proto/xcb-proto-1.10 [1.8] PYTHON_TARGETS="python2_7%* python3_3%* -python3_2%" 136 kB
[ebuild     U  ] x11-libs/libxcb-1.10 [1.9] USE="xkb%* -doc (-selinux) -static-libs" 465 kB
[ebuild     U  ] x11-libs/libX11-1.6.2 [1.5.0] USE="ipv6 -doc -static-libs {-test}" 2,286 kB
[ebuild     U  ] x11-libs/libXext-1.3.2 [1.3.1] USE="-doc -static-libs" 371 kB
[ebuild     U  ] x11-libs/libXfixes-5.0.1 [5.0] USE="-static-libs" 286 kB
[ebuild     U  ] x11-libs/libXxf86vm-1.1.3 [1.1.2] USE="-static-libs" 278 kB
[ebuild     U  ] x11-libs/libXdamage-1.1.4-r1 [1.1.4] USE="-static-libs" 0 kB
[ebuild  N     ] dev-util/gdbus-codegen-2.40.0  PYTHON_TARGETS="python2_7 python3_3 -python3_2" 0 kB
[ebuild     U  ] dev-libs/glib-2.40.0-r1:2 [2.34.3:2] USE="(mime%*) -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" PYTHON_TARGETS="python2_7%*" 0 kB
[ebuild  N     ] dev-libs/gobject-introspection-1.40.0  USE="cairo -doctool {-test}" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
[ebuild  N     ] dev-lang/vala-0.24.0-r1:0.24  USE="vapigen {-test}" 0 kB
[ebuild     U  ] gnome-base/dconf-0.20.0 [0.14.1] USE="X {-test}" 381 kB
[ebuild     U  ] dev-qt/qtcore-4.8.5-r2:4 [4.8.4-r1:4] USE="exceptions glib iconv qt3support ssl (-aqua) -debug -icu -pch (-c++0x%)" 235,832 kB
[ebuild     U  ] dev-qt/qtscript-4.8.5:4 [4.8.4:4] USE="exceptions iconv jit (-aqua) -debug -pch (-c++0x%)" 0 kB
[ebuild     U  ] dev-qt/qtgui-4.8.5-r3:4 [4.8.4:4] USE="accessibility exceptions glib mng qt3support tiff xinerama xv (-aqua) -cups -debug -egl -gtkstyle -nas -nis -pch -trace (-c++0x%) (-dbus%*) (-gif%*)" 51 kB
[ebuild     U  ] dev-qt/qtdbus-4.8.5:4 [4.8.4:4] USE="exceptions (-aqua) -debug -pch (-c++0x%)" 0 kB
[ebuild     U  ] dev-qt/qtsvg-4.8.5:4 [4.8.4:4] USE="accessibility exceptions (-aqua) -debug -pch (-c++0x%)" 0 kB
[ebuild  N     ] dev-qt/qttest-4.8.5:4  USE="exceptions (-aqua) -debug -pch" 0 kB
[ebuild     U  ] dev-qt/qtopengl-4.8.5:4 [4.8.4:4] USE="exceptions qt3support (-aqua) -debug -egl -pch (-c++0x%)" 0 kB
[ebuild     U  ] dev-qt/qtxmlpatterns-4.8.5:4 [4.8.4:4] USE="(-aqua) -debug -pch (-c++0x%)" 0 kB
[ebuild     U  ] dev-qt/qtwebkit-4.8.5:4 [4.8.4:4] USE="exceptions gstreamer jit (-aqua) -debug -icu -pch" 0 kB
[ebuild     U  ] dev-qt/qtsql-4.8.5:4 [4.8.4:4] USE="exceptions postgres qt3support sqlite (-aqua) -debug (-firebird) -freetds -mysql -oci8 -odbc -pch (-c++0x%)" 0 kB
[ebuild     U  ] dev-qt/qt3support-4.8.5:4 [4.8.4:4] USE="accessibility exceptions (-aqua) -debug -pch (-c++0x%)" 0 kB
[ebuild     U  ] dev-qt/qtdeclarative-4.8.5:4 [4.8.4:4] USE="accessibility exceptions qt3support webkit (-aqua) -debug -pch (-c++0x%)" 0 kB
[blocks b      ] >dev-qt/qthelp-4.8.4-r9999:4 (">dev-qt/qthelp-4.8.4-r9999:4" is blocking dev-qt/qtdeclarative-4.8.4, dev-qt/qtsvg-4.8.4, dev-qt/qtwebkit-4.8.4, dev-qt/qtopengl-4.8.4, dev-qt/qtxmlpatterns-4.8.4)
[ebuild     U  ] dev-qt/qthelp-4.8.5-r2:4 [4.8.4:4] USE="exceptions (-aqua) -compat -debug -doc -pch (-c++0x%) (-glib%*) (-qt3support%*) (-trace%) (-webkit%*)" 0 kB
[blocks b      ] <dev-qt/qthelp-4.8.5:4 ("<dev-qt/qthelp-4.8.5:4" is blocking dev-qt/qtgui-4.8.5-r3)
[blocks b      ] >dev-qt/qtscript-4.8.4-r9999:4 (">dev-qt/qtscript-4.8.4-r9999:4" is blocking dev-qt/qtopengl-4.8.4, dev-qt/qtsvg-4.8.4, dev-qt/qtwebkit-4.8.4, dev-qt/qthelp-4.8.4, dev-qt/qtdeclarative-4.8.4, dev-qt/qtxmlpatterns-4.8.4)
[blocks b      ] >dev-qt/qttest-4.8.4-r9999:4 (">dev-qt/qttest-4.8.4-r9999:4" is blocking dev-qt/qtopengl-4.8.4, dev-qt/qtsvg-4.8.4, dev-qt/qtwebkit-4.8.4, dev-qt/qthelp-4.8.4, dev-qt/qtdeclarative-4.8.4, dev-qt/qtxmlpatterns-4.8.4)
[blocks b      ] >dev-qt/qtcore-4.8.4-r9999:4 (">dev-qt/qtcore-4.8.4-r9999:4" is blocking dev-qt/qtopengl-4.8.4, dev-qt/qtsvg-4.8.4, dev-qt/qtwebkit-4.8.4, dev-qt/qthelp-4.8.4, dev-qt/qtdeclarative-4.8.4, dev-qt/qtxmlpatterns-4.8.4)
[blocks b      ] >dev-qt/qtgui-4.8.4-r9999:4 (">dev-qt/qtgui-4.8.4-r9999:4" is blocking dev-qt/qtopengl-4.8.4, dev-qt/qtsvg-4.8.4, dev-qt/qtwebkit-4.8.4, dev-qt/qthelp-4.8.4, dev-qt/qtdeclarative-4.8.4, dev-qt/qtxmlpatterns-4.8.4)
[blocks b      ] >dev-qt/qtsql-4.8.4-r9999:4 (">dev-qt/qtsql-4.8.4-r9999:4" is blocking dev-qt/qtopengl-4.8.4, dev-qt/qtsvg-4.8.4, dev-qt/qtwebkit-4.8.4, dev-qt/qthelp-4.8.4, dev-qt/qtdeclarative-4.8.4, dev-qt/qtxmlpatterns-4.8.4)
[blocks b      ] >dev-qt/qtdeclarative-4.8.4-r9999:4 (">dev-qt/qtdeclarative-4.8.4-r9999:4" is blocking dev-qt/qtsvg-4.8.4, dev-qt/qtwebkit-4.8.4, dev-qt/qtopengl-4.8.4, dev-qt/qthelp-4.8.4, dev-qt/qtxmlpatterns-4.8.4)
[blocks b      ] >dev-qt/qt3support-4.8.4-r9999:4 (">dev-qt/qt3support-4.8.4-r9999:4" is blocking dev-qt/qtopengl-4.8.4, dev-qt/qtsvg-4.8.4, dev-qt/qtwebkit-4.8.4, dev-qt/qthelp-4.8.4, dev-qt/qtdeclarative-4.8.4, dev-qt/qtxmlpatterns-4.8.4)
[blocks b      ] >dev-qt/qtopengl-4.8.4-r9999:4 (">dev-qt/qtopengl-4.8.4-r9999:4" is blocking dev-qt/qtsvg-4.8.4, dev-qt/qtwebkit-4.8.4, dev-qt/qtdeclarative-4.8.4, dev-qt/qthelp-4.8.4, dev-qt/qtxmlpatterns-4.8.4)
[blocks b      ] >dev-qt/qtwebkit-4.8.4-r9999:4 (">dev-qt/qtwebkit-4.8.4-r9999:4" is blocking dev-qt/qtdeclarative-4.8.4, dev-qt/qtsvg-4.8.4, dev-qt/qtopengl-4.8.4, dev-qt/qthelp-4.8.4, dev-qt/qtxmlpatterns-4.8.4)
[blocks b      ] >dev-qt/qtsvg-4.8.4-r9999:4 (">dev-qt/qtsvg-4.8.4-r9999:4" is blocking dev-qt/qtdeclarative-4.8.4, dev-qt/qthelp-4.8.4, dev-qt/qtwebkit-4.8.4, dev-qt/qtopengl-4.8.4, dev-qt/qtxmlpatterns-4.8.4)
[blocks b      ] >dev-qt/qtdbus-4.8.4-r9999:4 (">dev-qt/qtdbus-4.8.4-r9999:4" is blocking dev-qt/qtopengl-4.8.4, dev-qt/qtsvg-4.8.4, dev-qt/qtwebkit-4.8.4, dev-qt/qthelp-4.8.4, dev-qt/qtdeclarative-4.8.4, dev-qt/qtxmlpatterns-4.8.4)
[blocks b      ] >dev-qt/qtxmlpatterns-4.8.4-r9999:4 (">dev-qt/qtxmlpatterns-4.8.4-r9999:4" is blocking dev-qt/qtdeclarative-4.8.4, dev-qt/qtsvg-4.8.4, dev-qt/qtwebkit-4.8.4, dev-qt/qtopengl-4.8.4, dev-qt/qthelp-4.8.4)
[ebuild     U  ] x11-libs/libpciaccess-0.13.2 [0.13.1] USE="zlib -minimal -static-libs" 351 kB
[ebuild     U  ] x11-libs/libdrm-2.4.54 [2.4.40] USE="-libkms -static-libs" VIDEO_CARDS="intel (-exynos) (-freedreno) -nouveau (-omap) -radeon -vmware" 630 kB
[ebuild     U  ] sys-libs/ncurses-5.9-r3:5 [5.9-r2:5] USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs -tinfo -trace" 0 kB
[ebuild     U  ] sys-libs/gpm-1.20.7-r2 [1.20.7-r1] USE="(-selinux) -static-libs" 0 kB
[ebuild     U  ] sys-devel/llvm-3.4.2:0/3.4 [3.1-r2:0/0] USE="libffi ncurses%* static-analyzer%* xml%* -clang% -cmake% -debug -doc% -gold -multitarget -ocaml -python% {-test} -udis86 (-vim-syntax%)" PYTHON_TARGETS="python2_7%* -pypy%" VIDEO_CARDS="-radeon%" 15,598 kB
[ebuild  N     ] sys-apps/systemd-215-r1:0/2  USE="acl filecaps firmware-loader gudev introspection kmod lzma pam policykit seccomp ssl -audit -cryptsetup -doc -elfutils -gcrypt -http (-kdbus) -python -qrcode (-selinux) {-test} -vanilla" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2" 0 kB
[ebuild  N     ] sys-apps/gentoo-systemd-integration-4  0 kB
[ebuild  N     ] virtual/libudev-208:0/1  USE="-static-libs" 0 kB
[ebuild  N     ] virtual/libgudev-208  USE="introspection -static-libs" 0 kB
[ebuild  N     ] virtual/udev-208-r2  USE="gudev introspection -static-libs" 0 kB
[ebuild     U  ] sys-apps/hwids-20140627 [20130131] USE="net%* pci%* udev usb%*" 0 kB
[ebuild  N     ] sys-fs/udev-init-scripts-26-r2  0 kB
[ebuild     U  ] sys-auth/consolekit-0.4.6 [0.4.5_p20120320-r1] USE="acl pam policykit -debug -doc (-selinux) -systemd-units% {-test}" 370 kB
[ebuild     U  ] media-libs/mesa-10.2.4 [9.0.1] USE="classic dri3%* egl gallium gbm* llvm nptl -bindist -debug -gles1 -gles2 -opencl% -openmax% -openvg -osmesa -pax_kernel -pic -r600-llvm-compiler (-selinux) -vdpau -wayland -xa -xvmc (-g3dvl%) (-shared-glapi%*) (-xorg%)" VIDEO_CARDS="intel (-freedreno) -i915 -i965 -ilo% -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware" 6,962 kB
[ebuild     U  ] sys-fs/lvm2-2.02.107 [2.02.98] USE="readline thin udev -clvm -cman -device-mapper-only% -lvm1* -lvm2create_initrd% (-selinux) -static -static-libs -systemd%" 1,429 kB
[ebuild     U  ] sys-auth/pambase-20140313 [20120417-r1] USE="consolekit cracklib sha512 systemd* -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux)" 4 kB
[ebuild     U  ] gnome-base/gdm-3.12.2 [3.6.2] USE="branding%* introspection ipv6 systemd* tcpd xinerama -accessibility -audit -debug -fprint -plymouth (-selinux) -smartcard {-test} -wayland% (-consolekit%*) (-fallback%*) (-gnome-shell%*) (-ldap%*)" 1,487 kB

Total: 61 packages (48 upgrades, 13 new), Size of downloads: 268,698 kB
Conflict: 14 blocks

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.5-r3:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-4.8.5[aqua=,debug=,egl=,qt3support=] required by (dev-qt/qtopengl-4.8.5:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                 
    dev-qt/qtgui (Argument)
    >=dev-qt/qtgui-4.8.5:4 required by (x11-libs/qtscriptgenerator-0.2.0:0/0::gentoo, installed)
    ^^             ^^^^^^^                                                                                                                                               
    (and 7 more with the same problems)

  (dev-qt/qtgui-4.8.4:4/4::gentoo, installed) pulled in by
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/ktraderclient-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kpasswdserver-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/libkcddb-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/krunner-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kquitapp-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kephal-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                               
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdebase-menu-icons-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                           
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdontchangethehostname-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                               
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/ksmserver-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/knewstuff-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/attica-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                               
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kiconfinder-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kcminit-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kde-l10n-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kglobalaccel-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/katepart-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/libkcompactdisc-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                         
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdebase-data-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/liboxygenstyle-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kuiserver-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/plasma-runtime-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.7.4:4[accessibility,dbus] required by (media-video/kaffeine-1.2.2:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/konsole-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/korganizer-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kioclient-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/libkipi-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/svgpart-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdm-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                             
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/konqueror-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.7.0:4[accessibility,dbus] required by (sys-auth/polkit-kde-agent-0.99.0:4/4::gentoo, installed)
                                         ^^^^                                                                                                           
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kwallet-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.7.0:4[accessibility,dbus] required by (media-sound/kstreamripper-0.7.100-r1:4/4::gentoo, installed)
                                         ^^^^                                                                                                               
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kmimetypefinder-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                         
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdebase-desktoptheme-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                             
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdepasswd-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kopete-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                               
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/khotkeys-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/filelight-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kfind-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                               
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/keditfiletype-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/libkonq-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kwin-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                             
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/keditbookmarks-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.7.4:4[accessibility,dbus] required by (kde-misc/kde-gtk-config-2.1.1:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kcontrol-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdnssd-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                               
    >=dev-qt/qtgui-4.7.4:4[accessibility,dbus] required by (media-video/kmplayer-0.11.3d-r1:4/4::gentoo, installed)
                                         ^^^^                                                                                                         
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/libplasmaclock-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.7.4:4[accessibility,dbus] required by (net-libs/libbluedevil-1.9.2:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kscreensaver-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdepim-runtime-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kreadconfig-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/ksysguard-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/dolphin-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kstartupconfig-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/knotify-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/nepomuk-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kde-wallpapers-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdebase-startkde-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                         
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kontact-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdepim-common-libs-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                           
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kmail-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                               
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/ksplash-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/audiocd-kio-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdesu-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                               
    >=dev-qt/qtgui-4.7.4:4[accessibility,dbus] required by (net-p2p/ktorrent-4.3.1:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdebugdialog-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/plasma-apps-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/ksnapshot-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/solid-runtime-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kwalletd-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdepim-kresources-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                           
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kcmshell-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.7.4:4[accessibility,dbus] required by (net-wireless/bluedevil-1.2.4:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdepimlibs-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdepim-icons-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kfile-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                               
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kstart-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                               
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdebase-kioslaves-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                           
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/libkexiv2-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kfmclient-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/ktimezoned-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kgpg-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                             
    >=dev-qt/qtgui-4.5.0:4[dbus] required by (app-office/akonadi-server-1.8.1:0/0::gentoo, installed)
                           ^^^^                                                                                                         
    >=dev-qt/qtgui-4.7.4:4[accessibility,dbus] required by (kde-misc/polkit-kde-kcmodules-0.98_pre20120917-r1:4/4::gentoo, installed)
                                         ^^^^                                                                                                                           
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kurifilter-plugins-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                           
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdelibs-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/khelpcenter-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdebase-menu-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/libtaskmanager-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/drkonqi-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdialog-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/libkworkspace-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/systemsettings-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                       
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/phonon-kde-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kcheckpass-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kactivities-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdeartwork-kscreensaver-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                                 
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/solid-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                               
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/plasma-workspace-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                         
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/krosspython-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/nepomuk-core-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                     
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/libplasmagenericshell-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                               
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/renamedlg-plugins-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                           
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/knetattach-4.9.5:4/4::gentoo, installed)
                                         ^^^^                                                                                                   
    ~dev-qt/qtgui-4.8.4[-aqua,-debug,glib,qt3support] required by (dev-qt/qtcore-4.8.4-r1:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                                 
    (and 1 more with the same problems)

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.5:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.5[accessibility=,aqua=,debug=] required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^                                                                                                                                                                     
    >=dev-qt/qt3support-4.8.5:4[accessibility] required by (net-libs/libktorrent-1.3.1:4/4::gentoo, installed)
    ^^                  ^^^^^^^                                                                                                                                                         
    dev-qt/qt3support (Argument)
    (and 1 more with the same problems)

  (dev-qt/qt3support-4.8.4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.4[-aqua,-debug] required by (dev-qt/qtgui-4.8.4:4/4::gentoo, installed)
    ^                  ^^^^^                                                                                                                             

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.5:4/4::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtsql (Argument)
    ~dev-qt/qtsql-4.8.5[aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                 
    >=dev-qt/qtsql-4.8.5:4[qt3support] required by (net-libs/libktorrent-1.3.1:4/4::gentoo, installed)
    ^^             ^^^^^^^                                                                                                                                                     
    (and 2 more with the same problems)

  (dev-qt/qtsql-4.8.4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.4[-aqua,-debug,qt3support] required by (dev-qt/qt3support-4.8.4:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                             

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.5-r2:4/4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtcore-4.8.5:4[qt3support,ssl] required by (net-libs/libktorrent-1.3.1:4/4::gentoo, installed)
    ^^              ^^^^^^^                                                                                                                                                         
    ~dev-qt/qtcore-4.8.5[aqua=,debug=] required by (dev-qt/qthelp-4.8.5-r2:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                 
    dev-qt/qtcore (Argument)
    (and 11 more with the same problems)

  (dev-qt/qtcore-4.8.4-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.4[-aqua,-debug,glib,qt3support] required by (dev-qt/qtgui-4.8.4:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                                             
    (and 4 more with the same problem)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.5:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5-r3:4/4::gentoo, ebuild scheduled for merge)
    ^                ^^^^^                                                                                                                                                 
    dev-qt/qtscript (Argument)
    >=dev-qt/qtscript-4.8.5:4 required by (net-libs/libktorrent-1.3.1:4/4::gentoo, installed)
    ^^                ^^^^^^^                                                                                                                                         
    (and 1 more with the same problems)

  (dev-qt/qtscript-4.8.4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.4[-aqua,-debug] required by (dev-qt/qtgui-4.8.4:4/4::gentoo, installed)
    ^                ^^^^^                                                                                                                             

dev-qt/qtdbus:4

  (dev-qt/qtdbus-4.8.5:4/4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtdbus-4.8.5:4 required by (net-libs/libktorrent-1.3.1:4/4::gentoo, installed)
    ^^              ^^^^^^^                                                                                                                                         
    dev-qt/qtdbus (Argument)

  (dev-qt/qtdbus-4.8.4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-4.8.4[-aqua,-debug] required by (dev-qt/qtgui-4.8.4:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by gnome-base/gdm-3.12.2
# required by gdm (argument)
>=sys-auth/pambase-20140313 systemd

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

!!! The following installed packages are masked:
- sys-power/upower-0.9.19::gentoo (masked by: package.mask)
/usr/portage/profiles/base/package.mask:
# Rick Farina <zerochaos@gentoo.org> (6 Jun 2013)
# Pm-utils based hibernate and suspend support has discontinued.
# For continued support, use the upower-pm-utils fork or systemd.
# Systemd users can switch to a systemd profile or unmask <sys-power/upower-0.99.0
# Openrc users can "emerge -C upower && emerge -1 upower-pm-utils"

- virtual/python-argparse-1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org> (6 Jul 2014)
# (on behalf of python@gentoo.org)
# The modules provided by those virtuals are built-in in all currently
# supported Python implementations. If your ebuild depends on either
# of them, please just remove the dependency. Removal in 30 days.

- net-im/amsn-0.98.9::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Markos Chandras <hwoarang@gentoo.org> (23 Mar 2013)
# MSN service terminated.
# You can still use your MSN account in net-im/skype
# or switch to an open protocol instead
# These clients may work until Oct 2013 (or even longer in China)

- media-video/vlc-2.0.5::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman <TomWij@gentoo.org> (8 Jun 2014)
# Mask VLC ebuilds that are affected with security bug CVE-2013-6934:
#
#     A vulnerability has been discovered in VLC Media Player, which can be
#     exploited by malicious people to compromise a user's system.
#
# Some ebuilds also have other buffer and integer overflow security bugs like
# CVE-2013-1954, CVE-2013-3245, CVE-2013-4388 and CVE-2013-6283.
#
# Users should consider to upgrade VLC Media Player to at least version 2.1.2.

- net-nds/openldap-2.4.33-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (20 Mar 2014)
# Security mask of vulnerable versions, wrt bug #424167

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


emerge: there are no ebuilds built with USE flags to satisfy ">=dev-qt/qt3support-4.7.0:4[accessibility,kde]".
!!! One of the following packages is required to complete your request:
- dev-qt/qt3support-4.8.5::gentoo (Missing IUSE: kde)
(dependency required by "media-sound/kstreamripper-0.7.100-r1" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Mon Jul 28, 2014 10:52 pm    Post subject: Reply with quote

you will need to work in the chroot until udev and supporting cast are reinstalled. boots of the installed are not for working on the problem only for testing
from the chroot, try
Code:
emerge --nodeps systemd
emerge --nodeps virtual/udev

_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Tue Jul 29, 2014 5:27 pm    Post subject: Reply with quote

udev is installed now. systemd is stopping with error.
Code:

PATH=\"/etc/systemd/user\" -DUSER_DATA_UNIT_PATH=\"/usr/lib/systemd/user\" -DCATALOG_DATABASE=\"/var/lib/systemd/catalog/database\" -DSYSTEMD_CGROUP_AGENT_PATH=\"/usr/lib/systemd/systemd-cgroups-agent\" -DSYSTEMD_BINARY_PATH=\"/usr/lib/systemd/systemd\" -DSYSTEMD_SHUTDOWN_BINARY_PATH=\"/usr/lib/systemd/systemd-shutdown\" -DSYSTEMD_SLEEP_BINARY_PATH=\"/usr/lib/systemd/systemd-sleep\" -DSYSTEMCTL_BINARY_PATH=\"/usr/bin/systemctl\" -DSYSTEMD_TTY_ASK_PASSWORD_AGENT_BINARY_PATH=\"/usr/bin/systemd-tty-ask-password-agent\" -DSYSTEMD_STDIO_BRIDGE_BINARY_PATH=\"/usr/bin/systemd-stdio-bridge\" -DROOTPREFIX=\"/usr\" -DRANDOM_SEED_DIR=\"/var/lib/systemd/\" -DRANDOM_SEED=\"/var/lib/systemd/random-seed\" -DSYSTEMD_CRYPTSETUP_PATH=\"/usr/lib/systemd/systemd-cryptsetup\" -DSYSTEM_GENERATOR_PATH=\"/usr/lib/systemd/system-generators\" -DUSER_GENERATOR_PATH=\"/usr/lib/systemd/user-generators\" -DSYSTEM_SHUTDOWN_PATH=\"/usr/lib/systemd/system-shutdown\" -DSYSTEM_SLEEP_PATH=\"/usr/lib/systemd/system-sleep\" -DSYSTEMD_KBD_MODEL_MAP=\"/usr/share/systemd/kbd-model-map\" -DX_SERVER=\"/usr/bin/X\" -DUDEVLIBEXECDIR=\"/lib/udev\" -DPOLKIT_AGENT_BINARY_PATH=\"/usr/bin/pkttyagent\" -DQUOTACHECK=\"/usr/sbin/quotacheck\" -DKEXEC=\"/usr/sbin/kexec\" -DLIBDIR=\"/usr/lib\" -DROOTLIBDIR=\"/usr/lib\" -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src -I ./src/shared -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/shared -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/network -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/login -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/journal -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/timedate -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/timesync -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/resolve -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/systemd -I ./src/core -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/core -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/libudev -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/udev -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/udev/net -I ./src/udev -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/libsystemd/sd-bus -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/libsystemd/sd-event -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/libsystemd/sd-rtnl -I /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/libsystemd-network -Wp,-D_FORTIFY_SOURCE=2    -pipe -Wall -Wextra -Wno-inline -Wundef -Wformat=2 -Wformat-security -Wformat-nonliteral -Wlogical-op -Wsign-compare -Wmissing-include-dirs -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wsuggest-attribute=noreturn -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wstrict-aliasing=2 -Wwrite-strings -Wno-long-long -Wno-overlength-strings -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unused-result -Werror=overflow -Wnested-externs -ffast-math -fno-common -fdiagnostics-show-option -fno-strict-aliasing -fvisibility=hidden -ffunction-sections -fdata-sections -fstack-protector -fPIE --param=ssp-buffer-size=4   -O2 -pipe -march=native -MT src/path/path.o -MD -MP -MF $depbase.Tpo -c -o src/path/path.o /var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215/src/path/path.c &&\
mv -f $depbase.Tpo $depbase.Po
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/sh ./libtool  --tag=CC   --mode=link i686-pc-linux-gnu-gcc -std=gnu99 -pipe -Wall -Wextra -Wno-inline -Wundef -Wformat=2 -Wformat-security -Wformat-nonliteral -Wlogical-op -Wsign-compare -Wmissing-include-dirs -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wsuggest-attribute=noreturn -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wstrict-aliasing=2 -Wwrite-strings -Wno-long-long -Wno-overlength-strings -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unused-result -Werror=overflow -Wnested-externs -ffast-math -fno-common -fdiagnostics-show-option -fno-strict-aliasing -fvisibility=hidden -ffunction-sections -fdata-sections -fstack-protector -fPIE --param=ssp-buffer-size=4   -O2 -pipe -march=native -Wl,--as-needed -Wl,--no-undefined -Wl,--gc-sections -Wl,-z,relro -Wl,-z,now -pie -Wl,-fuse-ld=gold   -Wl,-O1 -Wl,--as-needed -o systemd-path src/path/path.o libsystemd-internal.la libsystemd-shared.la -lrt -ldl
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
libtool: link: i686-pc-linux-gnu-gcc -std=gnu99 -pipe -Wall -Wextra -Wno-inline -Wundef -Wformat=2 -Wformat-security -Wformat-nonliteral -Wlogical-op -Wsign-compare -Wmissing-include-dirs -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wsuggest-attribute=noreturn -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wstrict-aliasing=2 -Wwrite-strings -Wno-long-long -Wno-overlength-strings -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unused-result -Werror=overflow -Wnested-externs -ffast-math -fno-common -fdiagnostics-show-option -fno-strict-aliasing -fvisibility=hidden -ffunction-sections -fdata-sections -fstack-protector -fPIE --param=ssp-buffer-size=4 -O2 -pipe -march=native -Wl,--no-undefined -Wl,--gc-sections -Wl,-z -Wl,relro -Wl,-z -Wl,now -pie -Wl,-fuse-ld=gold -Wl,-O1 -o systemd-path src/path/path.o  -Wl,--as-needed ./.libs/libsystemd-internal.a ./.libs/libsystemd-shared.a -lrt -ldl -pthread
./.libs/libsystemd-internal.a(libsystemd_internal_la-sd-path.o): In function `search_from_environment':
sd-path.c:(.text.search_from_environment+0x50): undefined reference to `secure_getenv'
sd-path.c:(.text.search_from_environment+0x81): undefined reference to `secure_getenv'
sd-path.c:(.text.search_from_environment+0x102): undefined reference to `secure_getenv'
./.libs/libsystemd-internal.a(libsystemd_internal_la-sd-path.o): In function `from_home_dir':
sd-path.c:(.text.from_home_dir+0x51): undefined reference to `secure_getenv'
./.libs/libsystemd-internal.a(libsystemd_internal_la-sd-path.o): In function `from_environment':
sd-path.c:(.text.from_environment+0x31): undefined reference to `secure_getenv'
collect2: ld returned 1 exit status
make[2]: *** [systemd-path] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
 * ERROR: sys-apps/systemd-215-r1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=sys-apps/systemd-215-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/systemd-215-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/systemd-215-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/systemd-215-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215-abi_x86_32.x86'
 * S: '/var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215'
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/var/tmp/portage/sys-apps/systemd-215-r1/temp/environment: line 127: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)

>>> Failed to emerge sys-apps/systemd-215-r1, Log file:

>>>  '/var/tmp/portage/sys-apps/systemd-215-r1/temp/build.log'

 * Messages for package sys-apps/systemd-215-r1:

 * It's recommended to set an empty value to the following kernel config option:
 * CONFIG_UEVENT_HELPER_PATH="/sbin/hotplug"
 *   CONFIG_FANOTIFY:    is not set when it should be.
 *   CONFIG_FHANDLE:     is not set when it should be.
 *   CONFIG_NET_NS:      is not set when it should be.
 *   CONFIG_IDE:         should not be set. But it is.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.

 * Messages for package sys-apps/systemd-215-r1:

 * ERROR: sys-apps/systemd-215-r1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=sys-apps/systemd-215-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/systemd-215-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/systemd-215-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/systemd-215-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215-abi_x86_32.x86'
 * S: '/var/tmp/portage/sys-apps/systemd-215-r1/work/systemd-215'
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Tue Jul 29, 2014 6:19 pm    Post subject: Reply with quote

sys-apps/systemd-212-r5 is installed now. and virtual/udev.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Tue Jul 29, 2014 7:05 pm    Post subject: Reply with quote

well done!
https://wiki.gentoo.org/wiki/Localization/HOWTO use the sections for openrc to see if you can eliminate the locale comments
from the chroot see what
Code:
emerge -uND --bactrack=30 world
complains about now
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Tue Jul 29, 2014 8:49 pm    Post subject: Reply with quote

DONAHUE
emerge -avuDN system gives me out of the end:

emerge: there are no ebuilds built with USE flags to satisfy ">=virtual/udev-197[gudev,hwdb]".
!!! One of the following packages is required to complete your request:
- virtual/udev-208-r2::gentoo (Missing IUSE: hwdb)
(dependency required by "sys-fs/udisks-1.0.4-r5" [installed])
(dependency required by "kde-base/kdelibs-4.9.5" [installed])
(dependency required by "net-libs/libproxy-0.4.11-r2[kde]" [ebuild])
(dependency required by "net-libs/glib-networking-2.40.1-r1[libproxy]" [ebuild])
(dependency required by "net-libs/libsoup-2.46.0-r1" [ebuild])
(dependency required by "app-misc/geoclue-2.1.9" [ebuild])
(dependency required by "net-libs/webkit-gtk-2.4.4[geoloc]" [ebuild])
(dependency required by "gnome-extra/zenity-3.6.0" [installed])
(dependency required by "x11-wm/mutter-3.6.2" [installed])
(dependency required by "gnome-base/gnome-shell-3.6.2-r1" [installed])
(dependency required by "gnome-base/gdm-3.6.2" [installed])
(dependency required by "gnome-base/gnome-3.6.2" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


what is IUSE?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Tue Jul 29, 2014 11:15 pm    Post subject: Reply with quote

Code:
emerge hwids
USE="hwdb"  emerge  virtual/udev
hopefully this will satisfy portage. I think this use flag may have existed once but no longer.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Wed Jul 30, 2014 2:16 pm    Post subject: Reply with quote

DONAHUE, that USE flag hwdb does not help.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Thu Jul 31, 2014 1:52 am    Post subject: Reply with quote

try
Code:
USE="-hwdb" emerge -1 --nodeps --keep-going =sys-fs/udisks-1.0.4-r5 =kde-base/kdelibs-4.9.5 =net-libs/libproxy-0.4.11-r2 =net-libs/glib-networking-2.40.1-r1 =net-libs/libsoup-2.46.0-r1 =app-misc/geoclue-2.1.9 =net-libs/webkit-gtk-2.4.4 =gnome-extra/zenity-3.6.0 =x11-wm/mutter-3.6.2 =gnome-base/gnome-shell-3.6.2-r1 =gnome-base/gdm-3.6.2 =gnome-base/gnome-3.6.2

Code:
emerge -1 =virtual/udev-208-r2

Code:
emerge -uND --keep-going --backtrack=30 world


first time seeing a disappearing USE flag
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Fri Aug 01, 2014 12:44 am    Post subject: Reply with quote

At first, i must remove a few version numberings from your line
Code:
 USE="-hwdb" emerge -1 --nodeps --keep-going =sys-fs/udisks-1.0.4-r5 =kde-base/kdelibs-4.9.5 =net-libs/libproxy-0.4.11-r2 =net-libs/glib-networking-2.40.1-r1 =net-libs/libsoup-2.46.0-r1 =app-misc/geoclue-2.1.9 =net-libs/webkit-gtk-2.4.4 =gnome-extra/zenity-3.6.0 =x11-wm/mutter-3.6.2 =gnome-base/gnome-shell-3.6.2-r1 =gnome-base/gdm-3.6.2 =gnome-base/gnome-3.6.2

... because it's not finding the paket.

When i do this line i get:
Code:

cd . && glib-mkenums --template udisksenumtypes.h.template udisksenums.h ) |   \
   sed 's,U_TYPE_DISKS,UDISKS_TYPE,' | sed 's,u_disks,udisks,' >                        \
   udisksenumtypes.h.tmp && mv udisksenumtypes.h.tmp udisksenumtypes.h
( top_builddir=`cd .. && pwd`;                                          \
 cd . && glib-mkenums --template udisksenumtypes.c.template udisksenums.h ) |   \
   sed 's,U_TYPE_DISKS,UDISKS_TYPE,' | sed 's,u_disks,udisks,' >                        \
   udisksenumtypes.c.tmp && mv udisksenumtypes.c.tmp udisksenumtypes.c
gdbus-codegen                                                                   \
        --interface-prefix org.freedesktop.UDisks2.                             \
        --c-namespace UDisks                                                    \
        --c-generate-object-manager                                             \
        --generate-c-code udisks-generated                                      \
        --generate-docbook udisks-generated-doc                                 \
        ../data/org.freedesktop.UDisks2.xml                             \

make[2]: execvp: gdbus-codegen: Permission denied
make[2]: *** [udisks-generated.h] Error 127
make[2]: Leaving directory `/var/tmp/portage/sys-fs/udisks-2.1.3/work/udisks-2.1.3/udisks'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/sys-fs/udisks-2.1.3/work/udisks-2.1.3'
make: *** [all] Error 2
 * ERROR: sys-fs/udisks-2.1.3::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=sys-fs/udisks-2.1.3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-fs/udisks-2.1.3::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-fs/udisks-2.1.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-fs/udisks-2.1.3/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-fs/udisks-2.1.3/work/udisks-2.1.3'
 * S: '/var/tmp/portage/sys-fs/udisks-2.1.3/work/udisks-2.1.3'

>>> Failed to emerge sys-fs/udisks-2.1.3, Log file:

>>>  '/var/tmp/portage/sys-fs/udisks-2.1.3/temp/build.log'
*** Resuming merge...

>>> Emerging (1 of 11) kde-base/kdelibs-4.13.3-r1::gentoo
 * kdelibs-4.13.3.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...           

Code:
 -- Looking for isnan - found
-- Looking for isinf
-- Looking for isinf - found
-- Found PCRE: /usr/include 
-- Looking for PCRE_CONFIG_UTF8
-- Looking for PCRE_CONFIG_UTF8 - found
-- Looking for PCRE_CONFIG_STACKRECURSE
-- Looking for PCRE_CONFIG_STACKRECURSE - found
-- Looking for include file arpa/nameser_compat.h
-- Looking for include file arpa/nameser_compat.h - found
-- Looking for include file arpa/nameser8_compat.h
-- Looking for include file arpa/nameser8_compat.h - not found
-- Looking for include files sys/types.h, netinet/in.h
-- Looking for include files sys/types.h, netinet/in.h - found
-- Could NOT find HUpnp (missing:  HUPNP_INCLUDE_DIR HUPNP_LIBS) (Required is at least version "0.9.1")
-- To have UPnP support, explicitly enable HUPNP_ENABLED in the cmake cache
-- checking for module 'libudev'
--   found libudev, version 212
-- Looking for udev_device_get_sysattr_list_entry
-- Looking for udev_device_get_sysattr_list_entry - found
-- Found UDev: /usr/include 
-- Building Solid UDev backend.
-- Building Solid HAL backend.
-- Building Solid UPower backend.
-- Building Solid UDisks2 backend.
-- Building Solid fstab backend.
-- Found FLEX: /usr/bin/flex (found version "2.5.37")
-- Found BISON: /usr/bin/bison (found version "2.7")
-- Found LibXslt: /usr/lib/libxslt.so
-- Found LibXml2: /usr/lib/libxml2.so (found version "2.9.0")
-- Found DocBookXML: /usr/share/sgml/docbook/xml-dtd-4.2 
-- Found DocBookXSL: /usr/share/sgml/docbook/xsl-stylesheets 
-- Looking for posix_fadvise
-- Looking for posix_fadvise - found
-- Found SharedMimeInfo: /usr/bin/update-mime-database (found suitable version "1.0", minimum required is "0.60")
-- Looking for __progname
-- Looking for __progname - found
-- Looking for __progname_full
-- Looking for __progname_full - found
-- Looking for include file sys/pstat.h
-- Looking for include file sys/pstat.h - not found
-- Looking for pstat
-- Looking for pstat - not found
-- Looking for setproctitle
-- Looking for setproctitle - not found
-- Found ENCHANT: /usr/include/enchant 
-- Found JPEG: /usr/lib/libjpeg.so 
-- Performing Test GIF_GifFileType_UserData
-- Performing Test GIF_GifFileType_UserData - Success
-- Found GIF: /usr/lib/libgif.so (found version "4")
-- Found PNG: /usr/lib/libpng.so (found version "1.5.14")
-- Found Jasper: /usr/lib/libjasper.so (found version "1.900.1")
-- Found Avahi: /usr/include 
-- Adding support for OpenGL applets to libplasma
-- Adding support for Phonon to libplasma
--
-- The following features have been enabled:

 * X Rendering Extension (libXrender) , Support for compositing, rendering operations, and alpha-blending. STRONGLY RECOMMENDED
 * X Screensaver Extension (libXss) , Support for KIdleTime (fallback mode)
 * X Sync Extension (libXext) , Efficient operation of KIdleTime. STRONGLY RECOMMENDED
 * media-player-info , Enables identification and querying of portable media players.
                       Runtime-only dependency of the udev solid backend.
                       Support for m-p-i is included even if not found during build
 * QtWebkit , Needed for building kdelibs

-- The following OPTIONAL packages have been found:

 * Threads
 * QCA2 (required version >= 2.0.0) , Support for remote plasma widgets , <http://delta.affinix.com/qca>
 * FAM , File alteration notification support via a separate service , <http://oss.sgi.com/projects/fam>
   Provides file alteration notification facilities using a separate service.
 * LibLZMA , Support for xz compressed files and data streams , <http://tukaani.org/xz/>
 * PolkitQt-1 (required version >= 0.99.0) , "Support for executing priviledged actions in a controlled way (KAuth)" , <http://techbase.kde.org/Polkit-Qt-1>
   "STRONGLY RECOMMENDED: Required to make KAuth work, and hence enable certain workspace functionalities"
 * PCRE , Perl-compatible regular expressions in KJS , <http://www.pcre.org>
   Without PCRE, KJS will have extremely poor regular expression support, breaking many webpages.
 * UDev , UDev support for Solid , <http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html>
   Allows Solid to use UDev to provide information about devices on Linux
 * FLEX , Allows the Solid predicate parser to be updated , <http://flex.sourceforge.net>
   Required by the UpdateSolidPredicateParser target (mainly useful for developers)
 * BISON , Allows the Solid predicate parser to be updated , <http://www.gnu.org/software/bison>
   Required by the UpdateSolidPredicateParser target (mainly useful for developers)
 * PkgConfig
 * ENCHANT , Spell checking support via Enchant , <http://www.abisource.com/projects/enchant/>
 * Jasper , Support for JPEG-2000 images , <http://www.ece.uvic.ca/~mdadams/jasper>
 * Avahi , Facilities for service discovery on a local network (DNSSD) , <http://avahi.org>
   Either Avahi or DNSSD is required for KDE applications to make use of multicast DNS/DNS-SD service discovery

-- The following RECOMMENDED packages have been found:

 * OpenSSL , Support for secure network communications (SSL and TLS) , <http://openssl.org>
   KDE uses OpenSSL for the bulk of secure communications, including secure web browsing via HTTPS
 * Libintl , Support for multiple languages , <http://www.gnu.org/software/gettext>
   Enables KDE to be available in many different languages
 * ACL , Support for manipulating access control lists , <ftp://oss.sgi.com/projects/xfs/cmd_tars>
   STRONGLY RECOMMENDED
 * BZip2 , Support for BZip2 compressed files and data streams , <http://www.bzip.org>

-- The following REQUIRED packages have been found:

 * X11
 * Qt4
 * Automoc4
 * Phonon (required version >= 4.3.80)
 * KDE4Internal
 * Perl , <http://www.perl.org>
   Needed for building kdelibs
 * Strigi (required version >= 0.6.3) , Desktop indexing and search support , <http://strigi.sourceforge.net>
   Required by some critical kioslaves
 * DBusMenuQt , Support for notification area menus via the DBusMenu protocol , <https://launchpad.net/libdbusmenu-qt>
 * LibXslt , <http://xmlsoft.org/XSLT>
   Required by the KDE help system to process DocBook XML
 * LibXml2 , <http://xmlsoft.org>
   Required by the KDE help system to process DocBook XML
 * DocBookXML , DocBook XML , <http://www.oasis-open.org/docbook/xml/4.2>
   Required by the KDE help system to process DocBook XML
 * DocBookXSL , DocBook XSL , <http://docbook.sourceforge.net/release/xsl/current/>
   Required by the KDE help system to process DocBook XML
 * SharedMimeInfo (required version >= 0.60) , Shared Mime Info , <http://freedesktop.org/wiki/Software/shared-mime-info>
   Allows KDE applications to determine file types
 * GIF , GIF image format support , <http://sourceforge.net/projects/giflib>
   Required by khtml
 * ZLIB , Support for gzip compressed files and data streams , <http://www.zlib.net>
   Required by the core KDE libraries and some critical kioslaves
 * PNG , PNG image format support , <http://www.libpng.org/pub/png>
   Required by khtml
 * JPEG , JPEG image format support , <http://www.ijg.org>
   Required by khtml

-- The following OPTIONAL packages have not been found:

 * Grantlee (required version >= 0.1.0) , ModelEventLogger code generation (part of the ProxyModel test suite) , <http://www.grantlee.org>
   Grantlee is used for generating compilable code by the ModelEventLogger.
                         Without Grantlee, the logger will do nothing.
 * HUpnp

-- The following REQUIRED packages have not been found:

 * LibAttica (required version >= 0.4.2) , Support for Get Hot New Stuff , <https://projects.kde.org/attica>

CMake Error at /usr/share/cmake/Modules/FeatureSummary.cmake:430 (message):
  feature_summary() Error: REQUIRED package(s) are missing, aborting CMake
  run.
Call Stack (most recent call first):
  CMakeLists.txt:399 (feature_summary)


-- Configuring incomplete, errors occurred!
 * ERROR: kde-base/kdelibs-4.13.3-r1::gentoo failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3845:  Called kde4-base_src_configure
 *   environment, line 2852:  Called cmake-utils_src_configure
 *   environment, line 1132:  Called _execute_optionally 'src_configure'
 *   environment, line  648:  Called enable_cmake-utils_src_configure
 *   environment, line 1421:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 *
 * If you need support, post the output of `emerge --info '=kde-base/kdelibs-4.13.3-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=kde-base/kdelibs-4.13.3-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/kde-base/kdelibs-4.13.3-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kdelibs-4.13.3-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/kde-base/kdelibs-4.13.3-r1/work/kdelibs-4.13.3_build'
 * S: '/var/tmp/portage/kde-base/kdelibs-4.13.3-r1/work/kdelibs-4.13.3'

>>> Failed to emerge kde-base/kdelibs-4.13.3-r1, Log file:


This is something with a broken python-exec?
I have these two versions installed: dev-python/python-exec-10000.1:0 [10000.2:2]
I now emerge these line, (it's keep-going you gave me)

I'll see when it's ready. I still do have two gcc versions in emerge.. That will take some time on that netbook.
I'm pretty curious if this @world compilation will success at all. :-)

There were some people in the irc telling me, - such an old gentoo, cannot be updated anymore.

Hey i'm allways doing it like this on slow systems. It's much blocks and so on.

The only system which i had to reinstall was a primergy 500 where the complete OpenRC and minor things were updated. (installed 2006 - and 2009 or 2010 were some minor changes)
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Fri Aug 01, 2014 1:30 am    Post subject: Reply with quote

This has been a busy year or two for nasty changes involving udev and gnome. Persistence may or may not result in an upgrade via the patchwork path.
The easy way is to save your personal files to another drive/usb/, boot a livecd/usb, mount the gentoo partitions, rm-rf /mnt/gentoo/*, download a stage3 tarball and reinstall from https://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?style=printable&full=1#book_part1_chap5 when in business restore the personal files.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Fri Aug 01, 2014 2:44 am    Post subject: Reply with quote

Code:

Josef.95 wrote:
azp wrote:
Code:
emerge: there are no ebuilds built with USE flags to satisfy ">=virtual/udev-197[gudev,hwdb]".
!!! One of the following packages is required to complete your request:
- virtual/udev-208-r2::gentoo (Missing IUSE: hwdb)
- virtual/udev-208-r1::gentoo (Missing IUSE: hwdb)
(dependency required by "sys-fs/udisks-1.0.4-r5" [installed])
...

This comes from outdated installed =sys-fs/udisks-1.0.4-r5 Version
First attempts to update this
Code:
emerge -av --oneshot sys-fs/udisks:0


This (updating udisks at first) did the trick!
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Fri Aug 01, 2014 2:53 am    Post subject: Reply with quote

well done. persistence pays!
if kdelibs continues troublesome emerge -C kdelibs might be worthwhile. emerge -1 kdelibs when up to date.
what do
Code:
eselect python list
python-updater
produce?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Sat Aug 02, 2014 1:31 am    Post subject: Reply with quote

http://pastebin.com/vHqD5XGh
process takes some time on ;)

Code:

model name      : Intel(R) Atom(TM) CPU Z520   @ 1.33GHz
stepping        : 2
microcode       : 0x211
cpu MHz         : 1333.330
cache size      : 512 KB


i will do as next steps a -avuDN system and then world...

i didn't really remember.. is system in world? no?

for *me* system is system and world is world. :p

because of it's my lecture...
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sat Aug 02, 2014 2:52 am    Post subject: Reply with quote

Code:
mkdir  /usr/local/portage/metadata/layout.conf
echo "masters = gentoo"' >> /usr/local/portage/metadata/layout.conf

Code:
emerge -C agparse

system is in world; in the good old disciplined days it was less than 100 packages that were the vital toolchain
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Sat Aug 02, 2014 4:27 am    Post subject: Reply with quote

http://pastebin.com/eP9LjFkP
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sat Aug 02, 2014 4:40 am    Post subject: Reply with quote

fixable nuisance comments:

* Download the following files:
* jdk-7u65-linux-i586.tar.gz
* at 'http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html'
* and move them to '/usr/portage/distfiles'
*

!!! Repository 'x-portage' is missing masters attribute in '/usr/local/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility

Code:
emerge --deselect --ask $(qlist -IC 'perl-core/*')
emerge -uD1a $(qlist -IC 'virtual/perl-*')
emerge --nodeps perl
emerge perl-cleaner
perl-cleaner reallyall
what happens?
more soon
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Sun Aug 03, 2014 1:37 pm    Post subject: Reply with quote

http://pastebin.com/UvWVD36M

DONAHUE, what a service! I really like what you're doing!
That emerge --deselect --ask $(qlist -IC 'perl-core/*'): It came out, NOTHING to do.
That emerge -uD1a $(qlist -IC 'virtual/perl-*'): It compiled. But then i had a ssh drop out (maybe cause' of CPU/RAM) and i didn't have a screen on. (now.. i do have one emerge screen.)
The process started after, stopped, you can see it in the pastebin.

I did update gettext but it doesn't help much.

Nah, - if the question comes out, why doing gentoo on a netbook.
It is mainly for a travelling image i will do, (again.) In the other case i have an opened second device with a big PC cooler on it ;) for investigating stuff.

update:
It's done through an emerge locale-gettext.
>>> Installing (3 of 36) sys-devel/libtool-2.4.2-r1
update 2:
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
dev-perl/XML-Parser problem .. it is installed.. i'll try perlcleaner reallyall.

What i Really like on Gentoo is, - that it's portable. That is the reason why i make netbook images.
And of Course, - I Like The Cow! :)


    Zuletzt bearbeitet von ch64 am So Aug 03, 2014 1:28 pm, insgesamt 6-mal bearbeitet


Last edited by ch64 on Sun Aug 03, 2014 6:30 pm; edited 7 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum